[Migrated to Custom Capabilities] Rooms Manager: Smarter Rooms: Personalized rules based home automation with rooms Occupancy sensing from devices you already have in your home

:laughing:

heres another example. this turns on my outside holiday lights. the lights will turn on when lux <= 10 and time >= sunset and shut off at 10pm every day.

i have not forgotten about this. the only reason i have not added it so far is it would require use of significantly more schedules than the app uses now. though ST allows for presumably unlimited number of schedules now they do recommend max of 4 schedules and could enforce that any time. which would off course break the app and i dont want to provide something to the users knowing that it might not work in the future and they will have to change all their rules again.

i do find that using a combination of lux and sunrise or sunset gets me through all scenarios i have run in to where i would have needed an offset to either of those.

would you be willing to give that a try?

UPDATE: updated version 0.07.3 to github with the following changes:

*  Version: 0.07.3
*
*   DONE:   12/2/2017
*   1) added support for executing piston instead of just turning on a light
*   2) added view all settings
*   3) added room device indicators to the room device so they can be seen in one place
*   4) added timer to room which counts down in increments of 5
*   5) some bug fixes
1 Like

btw, the new room device indicator has a easter egg. see if you can find it. :wink:

I finished up the settings explanations. If i missed anything or it isnt clear let met know!
@bangali can you add the explanations to the first post?

1 Like

done. thank you for putting it together!

Just beginning to play around with this to replace webcore pistons for lighting, little bug for a UK user is that temp is in F are we able to have an option for C?

2 Likes

thanks. yes on my list will put it in.

opened an issue to track:

I found this yesterday, and I’m attempting to catch up, and convert my increasingly complicated WebCore pistons. So far, mostly so good. I’m not sure with the items below whether I’ve missed something, have foudn a problem, or am just very much an edge case (I suspect a bit of all three :slight_smile:

  1. Not setting a Motion Timeout on a room should make it become vacant immediately? Because it seems to be the reverse: the room never becomes vacant.
    Incidentally, setting the timeout to 1 produces errors. If I’m lucky, it’s “Please check the value range of input fields” (of course, with no indication of what the valid range is), but I’m also getting “Error refreshing page”, or “There was a problem processing your request. Please try again”. In such cases, sometimes the setting is saved, but doesn’t appear to work. I’ve settled on 10 seconds, which actually seems reasonable anyway :slight_smile:

  2. If I’ve put a Dimming setting on a room, but not set a level when Turning On, the lights seem to come back on at the post-dimming value, not pre-dimming. So, over a sequence of turning on, and dimming, and turning off, they gradually get increasingly less bright. I can specify a level for Turning On, but I was hoping to let the humans manually adjust this, rather than overriding them each time. (I could have multiple modes to select different lighting rules for the levels, but that gets messy.)

  3. My Lux Sensor is an Aeotec Multi-Sensor, doing double duty as a motion sensor. That also means it can see the light bulb in my living room. So I’m getting a loop whereby, if there’s motion in dark, the light comes on, so the Lux level goes up, so the light goes off. I dealt with this in WebCore by using a piston to set a virtual switch according to the light level, but only when the living room light is off. It looks like Rooms Manager needs to have an extra mode, rather than a switch, and then using that in the Lighting Rules. Correct?

  4. Changing mode doesn’t seem to trigger the lighting rules. I need to vacate and re-occupy a room in order for the lights to come on.

  5. I’ve got a Harmony Hub, so four mutually exclusive switches which could indicate my living room is Engaged (depending on which Harmony activity is on). But Rooms Manager wants a single switch. I could set up a Virtual Switch to reflect whether any of the activities is on.

  6. My Sonos speakers don’t have on/off switches: they have stopped or playing states. So I can neither use a lighting rule to start them automatically, nor use them to Engage a room when started. Again, I could put in WebCore pistons in to relay through more virtual switches, but that seems to be self-defeating (at least they’d be simple pistons!)

1 Like

First of all, thank you for the detailed feedback! We really appreciate this kind of feedback, it will help us alot to see what the user want/expects and if there are any bugs.

  1. We are going to check this. Can’t give an answer to this one yet.
  2. Well that’s how the lights work, they retain the last set level. So everytime when the lights turn on they turn on dimmed and gets dimmed again and so on. We are going to look to implement to retain the last level before dimming but we can’t promise anything.
  3. Well i would use a outside lux sensor for this because it will always have this problem. We are just checking if the lux goes above threshold, check the lights and turn them off or on accordingly. We will discuss if we could add a option to only check this when the lights are off but that kind of defeats the point in my opinion because we also turn on the lights with this threshold.
  4. We are going to check this.
  5. Totaly agreed, we are going to add multiple switches to switch to engaged state.
  6. This is very specific in my opinion, we are going to look what we can do.

supplementing what @johhnwilliam already said

when there is no motion sensor how do you define vacant “immediately”?

may be in this case set dim by level to 0%?

checked the code. when mode changes and the room is engaged or occupied the rules are evaluated so the lights should come on. please confirm the room was either engaged or occupied when the mode changed and there was at least one rule that should have evaluated as true.

speaker support is coming. :smiley:

hi sorry for the question about to come
but i installed area occupancy , then came across this room manager

do i need both or is one newer than the other ?
thanks

You’re very welcome. My apologies: I was afraid that I was being overly entitled. I really like this, and none of the quirks are absolute problems for me. But I wanted to ensure I’ve understood correctly, or whether I’d found something which didn’t behave as you expect.

  1. See below. I hope I’d just misunderstood the original description (maybe I haven’t, but I think this is behaviour anyway).
  2. Fair enough. I had exactly the same problem with my home brew pistons. I can change my expectations :slight_smile:
  3. You’re exactly right. My work around is a piston which changes to Evening mode when the light level drops, and changes back to Home when it rises again, but only when the light is off. I’d already got the piston anyway, so now I’m just changing mode, rather than a variable (I dislike mode, but that’s not your problem :wink:
  4. See below.
  5. Hooray!
  6. Fair enough. I’ve no idea about speakers as a general SmartThings device which would make it less specific. But it’s very much a nice-to-have, rather than anything which needs urgency.

Err? Wouldn’t that effectively mean no dimming? What I was after was walking into the room, and the lights coming on. I’d then manually set them to a comfortable level (eg. 100% if I’m working, 40% if I’m watching a film). After a while, they’d dim (to half of the previous level), and then turn off. When there’s motion again, they’d come back on at the level I’d set them to. Of course, what’s actually happening is that I set them to 100%, they dim, and go off. Next time they come on at 50%, dim, and go off. The time after that, it’s 25%, dim, and go off. And so on… Since my living room motion sensor can see my hallway, this happens just from walking past the room, and soon I’m at the point where the lights come on at 2% (oddly, they seem to stop there).
If I’ve understood correctly, I’ve got three things I can do here: one is to move the motion sensor to avoid seeing the hallway(!). Another would be simply to remove the dimming entirely. The more complicated one would be to define two new modes for Working and Film, then create lighting rules which specify the initial light levels. Is that what you’d expect?

Nope, I’ve just checked it. The rule is:
1: Mode=[Evening] State=[engaged, occupied] ON=[Living Room Light]
Setting the room to engaged, and then the mode to Evening doesn’t activate the light.
Setting the mode to Evening, and then the room to engaged does activate the light.

Once the light is on, changing the mode from Evening to Home doesn’t turn the light off. Changing the room to vacant does.

Yay! Although see above :wink:

I am going to set up 3 rooms just to kick things off. 2 kids’ room and 1 master bedroom. I’m thinking 2 motion sensors and 1 multipurpose sensor per room. This should be enough to get things started. That’s the device part. Now on to the settings part. I just want these devices to tell me when the room is occupied, vacant, and I supposed engaged (although, I don’t really know what that means). Can you give me an idea of how I should initially set the settings to provide me with this information? Just enough to get me started. Once I see how things progress, I feel I can take it from there. As far as the automation(lights, fans, etc) as a result of the status of the rooms, I can figure that part out. I just feel that I will screw something up with the initial setup. The way my life goes, I will accidently set it up to where the app will say it is vacant when there are people in the room and occupied when no one is in the room. Maybe just a picture of the settings like you did in the latest previous posted. Those picture examples are great!!!

This is the original and latest version! Please use this one for updates and new features.

right. that would mean no dimming. because earlier you said you wanted to manually control the light levels thought that might be the best solution for you.

actually looking at the code you may not need to do anything. i think the code restores the previous light level before turning it off but the command may not be reaching the light before it turns off. let me poke around a bit and figure out whats going on here.

i will check why the rule is not processing turning on when mode changes.
there is a setting in lux & time settings to turn off all switches. the setting is a little mislabeled and misplaced but would you please switch that on and see if the then changing the mode from evening to home turns the lights off?

thanks.

for each room specify the corresponding motion sensor for each room with the timeout settings. thats it. that will get you started with room being occupied or vacant. then go from there and add switches, engaged, rules etc.

now that rules have lux settings i am thinking of removing the main lux threshold from lux settings.

anyone objects? or sees a value in having it that i may be missing?

thanks.

this is fixed. will push with next release later this week.