[Migrated to Custom Capabilities] Rooms Manager: Smarter Rooms: Personalized rules based home automation with rooms Occupancy sensing from devices you already have in your home

one live log then go to the rooms manager app and click next then done. any error in the logs?

10:32:19 PM: debug getChildDevices(true), children=0

10:32:19 PM: warn DEPRECATION: You no longer need to call ‘unsubscribe’ within the ‘uninstalled’ method.

The other error did show up but ill look after a few days.

how many rooms do you have setup? why is that reporting 0?

  1. I do not know why it is reporting 0.

ok. are you still seeing the other error?

some of you may have been seen my mini rant over in another thread on why automations in the new app are so limited. so that needed a solution. hate doing one offs. so ported WATO … something i had coded for the HE platform last year. solved my presence sensor problem but is capable of doing much more than just that:

1 Like

I haven’t seen issues but I also paused a lot of my pistons.

ok. the pistons shouldn’t be causing any issues with this app though.

Hi @bangali

It’s been a while since I’ve worked on HA stuffs and been in the forums. I noticed today while in the IDE that there was a Github update for your app. Then I spent some time reading this thread where I left off.

So excited to see this app migrated. I updated the code via the IDE and can see version 1.2.0 in my apps. However, I do not see the new screens that go with it. Can you DM me the custom instructions you mentioned back on Oct 24th?

Thank you!!

1 Like

Hi @bangali

The instructions you sent worked perfectly!! Thank you!!

1 Like

Can’t open rooms manager v1.2.0 app in the new SmartThings app. I get the message “Something went wrong. Please try to install the SmartApp again.”

are you using GitHub repo method or pasting the code by hand for each of app and the DTH?

save and publish DTH and the apps from the latest code then try opening again. when trying again please have live logging open in IDE to check if there are any errors being thrown there.

Gitub since the beginning. Looks as if something updated on eiter Smartthings or your code and now the app wont even launch. Ironically I was just about to start copying my configurations over to HE . Is tthere any way I can dump my settings other than the GUI because I’m done…

well i am running the GitHub code on ST so it should work. are there any errors in the live log when you see the error in the app?

there isn’t an automated way of migrating the config from ST to HE … could be done but just haven’t done it. however for each room you can go to View All Settings option and take a screenshot of the settings. easier if you toggle the filter to only display settings that have values.

1 Like

when trying to launch the app from within the ios GUI i get this in the log

c1755d3a-7a99-4053-8b3b-965336e29e0d 11:16:49 PM: error java.lang.ClassCastException: java.lang.Integer cannot be cast to java.lang.String @line 1052 (batteryCheck)

c1755d3a-7a99-4053-8b3b-965336e29e0d 11:16:25 PM: error java.lang.ClassCastException

c1755d3a-7a99-4053-8b3b-965336e29e0d 11:15:47 PM: error java.lang.ClassCastException: java.lang.Integer cannot be cast to java.lang.String @line 1052 (batteryCheck)

One of my iris motion sensors’ battery that I’m monitoring went to 0%, can tha be related?

thanks. let me check the code in a bit then respond.

btw in the log is the error under the rooms manager or under one of the rooms?

Rooms Manager v1.2.0

update the code for just rooms manager app and try again please while watching live logging.

i am not getting the same error so might take a couple of tries to fix based on your feedback.

when updating, I noticed that my device handler was in draft status with v1.0.1. I saved the v1.2.0 device handler code. Rooms manager still will not launch and here is the new logging.

c1755d3a-7a99-4053-8b3b-965336e29e0d 12:33:58 AM: error java.lang.ClassCastException

c1755d3a-7a99-4053-8b3b-965336e29e0d 12:32:19 AM: error java.lang.ClassCastException

c1755d3a-7a99-4053-8b3b-965336e29e0d 12:31:56 AM: error java.lang.ClassCastException

c1755d3a-7a99-4053-8b3b-965336e29e0d 12:30:12 AM: debug perf scheduleNext: 748 ms

c1755d3a-7a99-4053-8b3b-965336e29e0d 12:30:11 AM: debug [[type:battery, time:Fri Dec 25 20:30:00 UTC 2020, timeS:15:30], [type:git, time:Sat Dec 26 00:00:00 UTC 2020, timeS:19:00], [type:time, time:Fri Dec 25 05:45:00 UTC 2020, timeS:00:45], [type:next, time:Fri Dec 25 05:45:00 UTC 2020, timeS:00:45, options:[time]]]

c1755d3a-7a99-4053-8b3b-965336e29e0d 12:30:11 AM: debug {“option”:"[time]"}

c1755d3a-7a99-4053-8b3b-965336e29e0d 12:29:14 AM: error java.lang.ClassCastException

ok. at least the errors don’t have a line number this time … that should make it easy :wink:

will have to go thru code and check where else it might happen tomorrow am … sorry for putting you thru a stressful night.

if this is going to keep you awake … let me know and i will give it another shot tonight.