[Migrated to Custom Capabilities] Rooms Manager: Smarter Rooms: Personalized rules based home automation with rooms Occupancy sensing from devices you already have in your home

I think it will work

1 Like

I’m happy to report that the adjacent room settings are now working for me. You’re the man!

2 Likes

i didnt actually do any code changes for this … just added some code optimization to only process any room for adjacent rooms when the adjacent rooms value for that room had changed.

before it used to process all rooms for adjacent rooms when any room was saved. since its working now … that confirmed what i was suspecting … the issues was happening from processing all rooms which was then timing out on ST.

Okay. I’m trying to wrap my head around this. I had a few pistons in webcore that was doing the job but like this idea more. Starting with a plain room with one motion sensor and one light. Want to change it to occupied, them after light traffic to engaged. Then turn off after no motion. The piston mentioned turns on the light with motion but also has its own rules about when to turn off. So I need to get rid of those? As it is now, light turns on, room changes to occupied and 45 second countdown starts. But no matter how much I move around the room, it never changes to engaged. It then goes to checking after the 45 seconds and even then movement does not restart the count. Then light goes off.

welcome to the club. :slight_smile:

for comprehensive automation of rooms in the house rooms manager works much better for me. i still use pistons for one off things that does not fit in this pattern.

you dont need the piston at all … so should disable the one for this room when you try this.

45 seconds count down should restart after each motion. so lights will not turn off while you are moving around in the room.

currently the engaged state with traffic is triggered by state change only. so in a short period of time if the room changes between occupied, checking and vacant it will trigger the change to engaged state based on the traffic setting.

wondering if i should trigger engaged when someone is in the room and moving around for a while. need to think a bit on if that makes sense from how it should work perspective. :slight_smile:

When in Occupied state if there is sustained motion … trigger Engaged state based on existing busy check setting?

  • Automatically trigger Engaged state
  • Do NOT automatically trigger Engaged state

0 voters

Thank you.

I might keep with webcore pistons. But I thought I would just try this out on an easy room first before going to ones with more usage and devices.

So I guess my question would be, if I don’t need the piston, then what triggers the light to come on? I didn’t see anywhere in the rule section anything that specifically stated when motion was detected to turn a switch on, which would then change the state of the room to occupied.

My thoughts were that this setup would set it to occupied and start a 45 sec countdown. So if I walked in and walked out, it would go to checking after 45 secs then turn off after that if no more motion during that whole time. If there was motion, then it would go to engaged and have a longer period of time before the light turned off.

But I guess I am misunderstanding something about it. So it does not automatically change to Engaged if motion is continuous? Just if it cyles through O, C and V in a short time? Ok. So I guess for the time being I just need to see why my device is not registering my continued movement and restarting the 45 sec countdown each time it does.

off course … i would never suggest deleting pistons. as i said just disable that piston while testing this. otherwise the piston and the app will interfere with each other because they both trigger and set the same devices.

the rule is already there but easy mode just gives a simplified view. turn off easy settings … then check the maintain rules settings.

vote above. :slight_smile:

correct on both counts.

if you keep the room open in things in the ST smartapp does the motion indicator show as active for the room or go inactive after the first moton? right below the status line like here:

also what is the motion timeout value for the motion sensor. if its larger than the 45 seconds timeout for occupied state that will also cause this to happen.

It was a larger timeout. Didn’t realize it. Will keep playing.

1 Like

ok. usually recommend:

occupied timeout motion timeout for the motion sensor + 30 seconds

I’m having a new issue. Last night one of my rooms stopped working, and kept saying there was motion when the motion sensors themselves were not indication motion, and the lights weren’t coming on automatically when there was motion in the room. I tried to delete the room, but I keep getting an “an unexpected error occurred”. I then tried removing some devices from the room, but when I go to save, i get an “error saving page” message and the following in the logs:

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:00 AM: info rooms manager: handleAdjRooms <<<<<

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:00 AM: info rooms manager: rooms manager: updating room HVAC Room with adjacent motion sensors: [] | 332 ms

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:00 AM: info rooms manager: rooms manager: updating room Living Room with adjacent motion sensors: [Kitchen Aqara Motion Sensor, Garage Motion Sensor, Garage PIR Motion Detector] | 320 ms

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:00 AM: info rooms manager: rooms manager: updating room Basement Storage with adjacent motion sensors: [] | 280 ms

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:00 AM: info rooms manager: rooms manager: updating room Play Room with adjacent motion sensors: [] | 274 ms

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:00 AM: info rooms manager: rooms manager: updating room Guest Bedroom with adjacent motion sensors: [] | 265 ms

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:00 AM: info rooms manager: rooms manager: updating room Garage with adjacent motion sensors: [] | 254 ms

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:00 AM: info rooms manager: rooms manager: updating room Kitchen with adjacent motion sensors: [Living Room Motion Sensor] | 237 ms

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:00 AM: info rooms manager: rooms manager: updating room Bar Room with adjacent motion sensors: [] | 203 ms

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:00 AM: info rooms manager: rooms manager: updating room Master Closet with adjacent motion sensors: [] | 194 ms

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:04:59 AM: info rooms manager: handleAdjRooms >>>>>

7023c38c-2202-49be-9edf-adb05818261c 9:04:59 AM: info Bar Room updated

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:06 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:05 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:05 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:05 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:04 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:04 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:04 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:04 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:04 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:03 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:03 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:03 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:03 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:02 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:02 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:02 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:01 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:01 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:01 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:01 AM: debug rooms manager: rSH initialized

68de09ea-f305-41b2-b3f0-f7aa044dd569 9:05:00 AM: debug rooms manager: rSH initialized

its virtually impossible for the app to show motion when the motion has not been triggered by the motion sensor. so lets check a few things:

  1. how many zwave devices do you have?
  2. how zigbee devices do you have?
  3. what is the radius over which devices are located?
  4. what is the brand/model of this motion sensor?
  5. is this motion sensor running on mains power or battery?
  6. is the motion sensor in an area that has breeze from a fan or duct or anything else directed towards it?
  7. from ST app if you open this motion sensor in things does it consistently show motion active / inactive when you move around?
  8. using 2 devices like phone or tablet … from ST app if you open this motion sensor on one screen and the room device on another screen under things … then move around does the motion activity for the motion sensor and the room’s motion indicator show active and inactive as they should?

on deletes … i need to look at that. but for deleting a room try this:

  1. from ST IDE go to devices then delete the device for the room
  2. then from ST app go to rooms managers app and delete the room

that should work.

every vote counts … dont tell me later you hate the feature: :wink:

1 Like

tip of the day: want to turn on and off switches on a certain day of the year?

setup a room … then add a rule with the following settings:

  • name of the rule
  • from date and to date (make sure hide advanced settings is false on the main settings page)
  • switches to turn on and off

when the rules date condition is met, switches specified in the rule will be turned on and off respectively.

i use a seasons room setup like this to turn on and off season switches spring, summer, fall and winter. you can then do a bunch of stuff that is season dependent.

So this was a really strange one… The room showed motion, but if I went to the individual motion sensors in the room, they were not showing motion. If I walked past the motion sensors (I have two in the room), they would indicate motion as expected, then return to no motion as expected when no movement, but the room consistently showed motion. I discovered that one of the plug in z-wave dimmers in the room had stopped working around the same time this problem cropped up, so I deleted it from SmartThings but still could not delete the room. I had to go into the IDE under locations and delete it from there. I then was able to recreate the room and now all is good.

As for the z-wave dimmer, it was showing offline, so I pulled it out of the wall and plugged back in and I could see it and turn it off and on from the app, but the actual light wouldn’t turn on. After much troubleshooting, I had to junk it.

1 Like

glad to hear its all working now.

these motion sensors were they also zwave?

The 2 motion sensors in that room are the zigbee Xaiomi sensors. One is an Aqara and the other is the older non-Aqara Xiaomi. Then there’s the z-wave lamp dimmer that went out and was replaced with the same brand/type, and three Lifx bulbs.

ok. i have used xiaomi sensors for a while now. they have a tendency to drop off unless there is a good zigbee signal repeater around.

personally i use xbee devices to act as repeaters … makes the xiaomi sensors much more stable.

I shall have to look into that. Perhaps I could replace one of the Lifx bulbs in that room with a Cree zigbee bulb, assuming it acts as a repeater. Thanks!

also see this thread: