Mi Connector (Xiaomi and Yeelight)

smartapp_misc
dth_sensors
requires_server
smartapp_appliances

(Gregoiredore) #64

token is ok
ip is ok too


#65

is there any way to expose color temperature options for webcore? Right now I’m only able to set a color. Also, I pulled the tokens out of the Mi Home app, which means now I can’t use the Yeelight app. Can the tokens be extracted from the Yeelight app also?


(Chals) #66

It’s dth bug.
I fixed xiaomi-light DTH.

You have to replace that.

Maybe you can call setLevel on WebCore.
I don’t have Yeelight but it would be worked even if you get token.


#67

Thanks for the response, I updated the dth, but looking at the code, I don’t see a color temperature capability. Only setlevel and setcolor. I’m unable to get accurate 2700K-6500K color temperature adjustments via webcore without this.

I can adjust this white light color temperature on the smartapp fine, just that the color temperature capability is not defined in the code. For example, like this RGBW dth:

Is this possible?


(Chals) #68

I have no idea well if color temperature is possible really.

I don’t have light…

You just add capability Color Temperature on the DTH.
And Let me know the result.

If it works, I will add the capability.

Thanks.


(Derek Murphy) #69

I’ve been looking for a real way to connect my robot vacuum to Smartthings. I gotta ask though, is a server or something required for this? I understand the whole smartapp part but the Docker part is foreign to me. Thanks for creating all this though, if I can get it working it would be great!


(Yaroslav) #70

You need some kind of home server for Docker. It could be Synology, or QNAP disk station, or Raspberry Pi, or any other always turned on PC.
Docker is a container with virtual machine which has all necessary software preinstalled.


(Derek Murphy) #71

I see. That could pose an issue for me. I have a Windows machine that I never use that I wouldn’t mind running as “server” but as far as setting up and running Docker, I’m not sure I could do that.


(Luca Mocci) #72

did you manage to integrate the lights into smartthings? I see the strip led among those available, but I can not add it.


(Yaroslav) #73

I have Xiaomi Philips Ceiling Lamp and it doesn’t work. Previously I can’t even add it to mi-connector. Always had an error. So I did apt update, apt upgrade inside docker container. After that my lamp is added to mi-connector and to ST, but it still doesn’t work at all.
I successfully added this lamp to homebridge, but I’m not able to do it with this connector.


(Chals) #74

What type do you have light?


(Chals) #75

MI Connector doesn’t support Xiaomi Philips Ceiling Lamp now.

Let me know the type, if you added.
ex) zhimi.airpurifier.m1


(Luca Mocci) #76

I have two yeelight bulbs and a strip led always yeelight. The strip is seen automatically by mi-connector, but it does not add me to smartthings, while the bulbs probably have to extract the tokens, but I do not know if they can be added then to smartthings.
mi air purifier and vacuum works perfect.


(Yaroslav) #77


Here you are. I know that it doesn’t support yet. That’s why I try to solve it by myself.


(Chals) #78

The Yeelight, vaccum type must be added manually with the token.


(Chals) #79

What version is you installed Mi-Connector?


(Yaroslav) #80

Is there more than one version? I have image version 0.0.1 downloaded from docker registry on my synology.
Aha. There is one more version which was updated 8 days ago. I’ll try in right now.


(Yaroslav) #81

Well. I did string 220:
}else if(params.type == "philips.light.sread1" || params.type == "philips.light.bulb" || params.type == "philips.light.ceiling"){
in smartapp
than
var yeelinkList = ["yeelink.light.lamp1", "yeelink.light.mono1", "yeelink.light.color1", "yeelink.light.strip1", "philips.light.sread1", "philips.light.bulb", "philips.light.ceiling"];
in miio.js
After that the light is appear in ST, but doesn’t work at all.
There is a part of log:
info: Initialize WiFi Device >> philips.light.ceiling(56XXXXXX) ip=10.0.24.17 {"label":"Mi-Connector","timestamp":"2018-04-14T18:23:40.614Z"} info: Control >> {"id":"56XXXXXXX","cmd":"power","data":"off"} {"label":"Mi-Connector","timestamp":"2018-04-14T18:28:13.394Z"} info: Requested to control by ST >> [philips.light.ceiling] >> {"id":"56XXXXXX","cmd":"power","data":"off"} {"label":"Mi-Connector","timestamp":"2018-04-14T18:28:13.400Z"} error: Control Device2 Error >> TypeError: device.power is not a function Error at Object.module.exports.controlDevice (/usr/src/app/miio/miio.js:968:57) at /usr/src/app/routes/control.js:10:12 at Layer.handle [as handle_request] (/usr/src/app/node_modules/express/lib/router/layer.js:95:5) at next (/usr/src/app/node_modules/express/lib/router/route.js:137:13) at Route.dispatch (/usr/src/app/node_modules/express/lib/router/route.js:112:3) at Layer.handle [as handle_request] (/usr/src/app/node_modules/express/lib/router/layer.js:95:5) at /usr/src/app/node_modules/express/lib/router/index.js:281:22 at Function.process_params (/usr/src/app/node_modules/express/lib/router/index.js:335:12) at next (/usr/src/app/node_modules/express/lib/router/index.js:275:10) at Function.handle (/usr/src/app/node_modules/express/lib/router/index.js:174:3) {"label":"Mi-Connector","timestamp":"2018-04-14T18:28:13.404Z"} POST /control 200 152.027 ms - 7 info: Control >> {"id":"56681072","cmd":"brightness","data":54} {"label":"Mi-Connector","timestamp":"2018-04-14T18:28:17.221Z"} info: Requested to control by ST >> [philips.light.ceiling] >> {"id":"56XXXXXX","cmd":"brightness","data":54} {"label":"Mi-Connector","timestamp":"2018-04-14T18:28:17.222Z"} warn: philips.light.ceiling is not supported to set brightness!!!! ID(56XXXXXX) {"label":"Mi-Connector","timestamp":"2018-04-14T18:28:17.225Z"} POST /control 200 9.769 ms - 7


(Chals) #82

Did you modified also models.js file?


(Yaroslav) #83

I tried it 2 minutes ago, but it didn’t help. It still always looks like turned on, even if it is turned off. Doesn’t respond to any action.