SmartThings Community

Mi Connector (Xiaomi and Yeelight)

smartapp_misc
dth_sensors
requires_server
smartapp_appliances

(Chals) #311

I know that you don’t have a hub.
That’s why you just remove location.hubs[0] and write null fron smartapp code.


#312

@fison67 thank you so much for a great/easy solution to integrate my Roborock vacuum into my smartthings eco system. Everything worked great for me using the Docker installs. I used an old Mi Home app on my Andriod to get the device token and manually added the device in the Mi Connector site.

I see in your device handler code for the vacuum s5, you have attributes defined for the consumable information in work time for the main brush, side brush, etc. But I do not see this information displayed while viewing the device in my SmartThings app. Would you be able to add a little detail section at the bottom that displays the current work time of the vacuum consumables?

Thanks again for this awesome solution!


(Chals) #313

@xtreme22886
I did not implement it before.

Re download docker image. fison67/mi-connector:test2.
If you need that value on webcore, use this.

mainBrushLeftLife
sideBrushLeftLife
filterLeftLife
sensorLeftLife


#314

Awesome! Thank you so much for getting this done and so quickly. I’ve got everything I need in that smartapp / device handler now. I did have to modify the device handler to remove the empty space as it wasn’t aligning right on my phone :slight_smile:

I removed the two references of “empty2_label” to fix the alignment.


(Krishnakumar) #315

Solved the problem, just had to restart the dockers and then everything showed up…
I have xiaomi gateway, mi app has bunch of motion sensor and humidity/temperature sensor. Have the docker running and i could see all the devices on the mi website connector. Nothing shows up in the smartthings app. when i look at the smartthings ide log i have : getChildDevices(false), children=0. what am i doing incorrectly.
i connect mi connector web via 192.168.1.216:30000
i entered the same in the smartthings app server address, nothing shows up. please help.


(Krishnakumar) #316

any way to give an option to display temperatures in F rather than C? As in US everything is in F…


(Chals) #317

@seashell.midwest
Device is showed in your smartthings?

I updated a xiaomi-weather, xiaomi-sensor-ht DTH.
Enter a thing’s setup
You can see Select a type. [ C , F ]
Choose a F and refresh


(Krishnakumar) #318

thank so much for the quick update. One more question, the graph is not displaying for the temp or humidity. how do i make it to appear in the smartthings app?
thanks


(Arkady Aidlin) #319

Hi . I have tried everything, even deleted docker and installed it again , but still can’t turn Philips Light fully On , it only turns on night mode . I saw you have updated TEST2 version, so I installed it for test , but it didn’t work for me at all. I have another problem , all of my lights are not updating status on ST App , they are always ON , even if turned them OFF from App. Please help ! :disappointed_relieved:


(Chals) #320

Inastall a db docker.
You can see that on github.


(Chals) #321

I don’t know your status exactly.
Turn on off is working? Even if it’s night mode

Not updating status problem is cuz wrong st app url, id, torken. See the setup page on mi connector.


(Arkady Aidlin) #322

Hi. Yes it’s turning on/off but even if I select some scene before , for the first time it’s turning to the same scene and for second time it’s turning to Midnight mode were small light is turning on and not Philips Ceiling Light it self . Thanks .


(Chals) #323

It looks like a normal.
On command is worked by normal mode.
When you press night mode, as I know small light is only on.
I have no philips ceiling light. So I don’t know exactly each scene.


(Vagelis F ) #324

I stopped the docker cause I had problems in the past [see above]
I have now installed the test version and it detects both vibration and cube! {apart from door sensors, gateway and buttons}

The problem is that, it still shows all 4 door sensors as “Open” and battery to -1% for door & button aq sensors.
For Cube it shows: “Battery: %”

The name for the same sensor types were identical, so I changed them like Xiaomi Door1, Xiaomi Door2 etc until I find which is which.

Any ideas how the door sensors display the correct state and battery is displayed correctly?


(Chals) #325
  1. The door sensor is registered to mi connector? You can see the dashboard on web.

  2. There is a log from docker to ST?
    You can see on log as below
    Notify >> ID(1111):type(lumi.motion.aq2) state={“key”:“motion”,“value”:true} >> [true]
    from log file when sensor state is changed


(Vagelis F ) #326

All sensors are registered in web (they have a “tick”)

The only thing that works is the Air purifier and the gateway [lumi.gateway.v3]

If I remove all door sensors, cube, vibration from original Mi Home, is there any chance to have the updated state and battery status?

If I just remove 1 of the 4 door sensors from Mi Home and then stop docker container, remove all 4 door sensors from ST and run mi-connector again (after Mi Home re-pairing) will it fix it?

What’s your opinion about that?

Thank you


(Chals) #327

Plz Check your log first.

File : connector.log


(Ian ruffell) #328

Hello

Do you think the Xiaomi zero ai doorbell might work using this system?


(Krishnakumar) #329

how to make the graph display in the smartthings app? I have the mariadb docker in the synology. I could see the graph in the in the website, but i could not see in the smartthings app. Do I need to change any other setting?


(Matt B) #330

I set everything up, SmartApp, Device Handler, Token, IP, everything. The furthest it got is that I have a new device in ST that says it’s “Initializing”. I tore it all down, started from scratch, same result. Any ideas?