SmartThings Community

Mi Connector (Xiaomi and Yeelight)

smartapp_misc
dth_sensors
requires_server
smartapp_appliances

(Arkady Aidlin) #268

I have saved it , with no errors , but it still does not work .
cannot get it publish APP_ID , APP_URL and ACESS_TOKEN
What else can I do ?
Thanks you for help !!


(TOO FLY FOR A FLY GUY) #269

I followed the instructions on your Github page

docker pull mariadb
docker run -d --name mariadb -e MYSQL_ROOT_PASSWORD=password1234 -e TZ=Asia/Seoul -p 33006:3306 -d mariadb

I tried changing the config.json to read port 33006, but that did not help either.


(Chals) #270

@same555
Server address is ip & port.
example) 192.168.0.100:30000

If this info is wrong, it doesn’t set ST value on web.

Or you just typing yourself on web. As your screenshot there are 3 info.


(Chals) #271

@flyize
Let me know your full command to run mi connector container


(Krishnakumar) #273

I have Smarthings v2, installed the mi-connector in synology. log in synology shows:
|018-12-17|14:38:30|info|DB is connected|
|2018-12-17|14:38:30|info|Initialize >> Auto Detect Device!|
|2018-12-17|14:38:30|info|DB Info >> {“host”:“192.168.1.217”,“port”:“33006”,“user”:“root”,“password”:“password1234”,“database”:“mi_connector”}|

When i open mi-connector inside smartthings, it has the config file with correct info. I am trying to connect aqara smart temp and humidity sensor. I added the device handler xiaomi weather. Please help me how to get this connected to the mi-connector? I tried to go into the management of mi-connector in smartthings but it keeps on moving the blue line on the top but it does not connect to any device. No device either shows on the web portal.
thanks

ps: I think I need gateway for this thing to work so ordered the gateway let me see if that will keep my 10 humidity sensors and 5 motion sensors connected.


(Chals) #274

You don’t have a gateway. So zigbee devices is not connected to mi connector.

Register a zigbee devices & gateway to mi home app first.


(Alcopop2006) #275

Hi @fison67, the Mi Connector has been working brilliantly for me so far! Thank you so much… Just wanted some advice in regards to Home Assistant.

I bought my Raspberry Pi with the intention of running Home Assistant originally, however after having some difficulty when I was initially setting up the Mi Connector, I installed a Hypriot operating system for Docker. I’ve tried installing Home Assistant as a Docker Container but I’m a real novice and I couldn’t get it up and running.

As I now know what the problems were when I set up the Mi Connector, I was intending upon having another go at installing Home Assistant and then setting up the Mi Connector again. However as the Mi Connector has been working so well, I’m afraid to disturb this set up :grimacing: … I was thinking of using a different SD card so that if I do get stuck, I can always just revert back to using the Mi Connector again.

I was also thinking of whether it might be better to just get another raspberry pi to run Home Assistant on as I’ve read that other users have had their’s fried after so long?

I’ve seen that you have started some code on GitHub for SmartThings/ Home Assistant, which looks awesome. :smile:

I was also wondering if you had any experience of integrating devices that use the Tuya/ Smartlife app? I don’t own any such products yet but was looking at purchasing some e14 rgbw candle bulbs but it looks like a struggle to integrate these with SmartThings.

Thanks again for your fantastic work!


(Arkady Aidlin) #276

Hi , thank you for your work !!! I have a small problem with Xiaomi Philips Ceiling light , then I’m trying to turn it on/off it does not work , but I can change scene from the app . Please can you help with that .
Thank you so much .


(Chals) #277

I need a detailed info.
What device? raspberry or synology?
Mi connector version.

If you did install a latest version, use a fison67/mi-connector:test (synology) or fison67/mi-connector-arm:test (raspberry) version.

And it’s looks like a weird. After restart a docker container, one more check plz.


(Chals) #278

I don’t know what you’re saying exactly.
My english skill is not good.

Mi connector has not connection with Home Assistant…

I don’t have a Tuya? product.


(Arkady Aidlin) #279

Do you know what can i do to fix Philips ceiling light ? Thanks


(Jon) #280

Hi all. Before I start, I realise I’m slightly out of my depth here, but I will persevere.

I have a ST Hub 2.0 and a load of Xiaomi devices (all bar the hoover, I connect directly to the hub using DH from this forum). I love it, it works very well, but now I’m hungry for more and my wife bought me a Raspberry Pi 3 Model B+ for Christmas.

Where the heck do I begin? My first project will be to connect my Xiaomi MiRobot to ST using this SmartApp.

Should I start by installing Hass.io, or HomeAssistant, then trying to sort the Docker out from there, or should I be just running it directly from the preinstalled OS on the Raspberry Pi?

Also, it seems if I want to gain additional control over my door/window sensors, I need to buy a Xiaomi hub, right?

Thanks :slight_smile:


(Chals) #281

Let me know device which you install a docker & installed mi connector version & mi connector docker log.


(Alcopop2006) #282

Hi No worries, thanks for getting back to me… I think I’m going to just buy another raspberry pi at a later date to save disturbing the Mi Connector. Thanks for your help and the great device handler, Merry Christmas :smile:


(Marius) #283

Hi @fison67,

Thank you for some awesome work on this! As I am still waiting for my Xiaomi gateway to arrive in my mailbox, I have a few quick questions:

  1. Would it be possible to connect Xiaomi bluetooth devices (Xiaomi Flora etc.) using a bluetooth dongle with my Synology NAS? Or is a Raspberry Pi the only options for connecting bluetooth devices?
  2. Would it be possible to run multiple Mi-Connector servers with the same Mi-Connector SmartApp? Or do I need to install one Mi-Connector SmartApp for each Mi-Connector server?

Thanks again.


(Chals) #284

Hi @mariuse

  1. Of course. I also use a dongle with synology nas.
  2. One Smartapp, One Mi connector.

(Marius) #285

Noted. Thank you for your prompt reply @fison67.


(Arkady Aidlin) #287

Hi , sorry for delay . I have Pi 3b+ , running docker 18.09.0 , I have installed all of your devices , i have all most everything from your list . Mi-connector version 0.0.3 (latest). This is the log
Thanks
2018-12-29 06:33:22 [info]: Requested to control by ST >> [philips.light.ceiling] >> {“id”:“728******”,“cmd”:“power”,“data”:“off”}

(node:31) UnhandledPromiseRejectionWarning: Error: changePower has not been implemented
at module.exports.changePower (/usr/src/app/node_modules/abstract-things/common/switchable-power.js:110:9)
at module.exports.setPower (/usr/src/app/node_modules/abstract-things/common/switchable-power.js:83:32)
at module.exports.power (/usr/src/app/node_modules/abstract-things/common/switchable-power.js:68:16)
at Object.module.exports.controlDevice (/usr/src/app/miio/miio.js:948:11)
at /usr/src/app/routes/control.js:10:12
at Layer.handle [as handle_request] (/usr/src/app/node_modules/express/lib/router/layer.js:95:5)
at next (/usr/src/app/node_modules/express/lib/router/route.js:137:13)
at Route.dispatch (/usr/src/app/node_modules/express/lib/router/route.js:112:3)
at Layer.handle [as handle_request] (/usr/src/app/node_modules/express/lib/router/layer.js:95:5)
at /usr/src/app/node_modules/express/lib/router/index.js:281:22
at Function.process_params (/usr/src/app/node_modules/express/lib/router/index.js:335:12)
at next (/usr/src/app/node_modules/express/lib/router/index.js:275:10)
at Function.handle (/usr/src/app/node_modules/express/lib/router/index.js:174:3)
at router (/usr/src/app/node_modules/express/lib/router/index.js:47:12)
at Layer.handle [as handle_request] (/usr/src/app/node_modules/express/lib/router/layer.js:95:5)
at trim_prefix (/usr/src/app/node_modules/express/lib/router/index.js:317:13)
(node:31) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1)
(node:31) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.


(Ian ruffell) #288

I have this all installed and have a gateway v3 device.

added the smartapp and the DH for gateway1 and 2

The web interface cant add it automatically, have added the code manually from inside the mihome app and still will not connect.

what am i doing wrong?


(Jon) #289

One question - do the sensors (ie open/close, water, temperature and movement ones) operate more reliably using the Xiaomi hub AND ST, or does it work just as well paired directly with the ST hub? Only I’m contemplating buying the Xiaomi hub 3.0…

Update to below I see when it’s charging it changes :slight_smile:

So I’ve managed to get it working with the test version! It’s great, thank you @fison67!
My only question is that the hoover always shows as “waiting” when it’s off. Normally a device on ST says “waiting” when I’ve pressed a button and I’m waiting for the device to respond. Is this intentional?