Meross native Integration

Hey JD. Just to be clear i tried adding the devices from the new app. The issue with the classic app was just an observation.

I have their regular plugs with energy monitoring and their 2 power strips, the one with the usbs and the one without.

1 Like

I have multiple smart plugs (UK) both energy monitoring and standard. I go through the process to connect SmartThings with Meross and it seems to go through ok but the devices are never added.


I have the exact same problem described here. I have this Meross outdoor smart plug:

Works fine within the Meross app and with Alexa voice commands. I can add my Meross account in SmartThings but no devices are available after sign in.

I have the outdoor plug as well and can confirm that it does not work with the SmartThings integration.

ST support told me that Meross has not added support for anything with a parent/child structure and to contact Meross to request it.

Meross support just told me “Not all models are supported in that integration.” I am still waiting for a list of what is supported.


Hey thanks a lot for looking into this. I guess we’ll just have to be patient. I’ll bug Meross about this and dangle a carrot of future plug purchases in front of them :slight_smile:
Aside from the ST integration the plug has been pretty solid and handles Canadian winters with ease.

1 Like

Using Alexa as a “man in the middle” works pretty well. this is my outdoor Meross plug:

You can put any logic you want on the ST side:

Out of curiosity, how does something like this show up in the smarthings devices if it has not been implemented by the company, in this case Meross?

FYI I have IFTTT as the middle man and it also works well.

It doesn’t, unless you create a virtual proxy so you can display the status.

The virtual sensor as described in the FAQ shows up as both a sensor and a switch. But if you are using one routine to turn on multiple devices then it’s not a one to one proxy.

The new cloud integrations are published by the manufacturer. SmartThings only does a security audit (as I understand the process). But it seems a lot of them are publishing them to the public app too soon.

1 Like

This is the response I received from them


Thank you for letting us know

Just went through the authentication process with the Meross integration again. Initially I thought it had done nothing as previous attempts. However, this time my devices have appeared in the new app!

A great step forwards for me, and will consider buying more Meross when they go on sale :slight_smile:


Is it bidirectional? I.e. can you change the on/off state in their app and it updates in the SmartThings app?


Yes! I’ve been waiting for over two years for this :grin:


When will Smartthings support the Meross range of TRVs?
i.e. Meross Smart Heating Radiator Thermostat MTS100

1 Like

That’s a question for Meross. They own the integration.

1 Like

Hi Rickydg. I went through the authorization process and I could see the meross device on the IDE, but not in the app. I then deleted the device (an outlet) in the IDE and tried to re-add it and now i’m not even seeing it in the IDE. Can you explain the process you did to get it working?

Would be good us they did as this would like be the cheapest option for TRV integration into SM…

I simply linked my ST account through the official integration within the new app. If it doesn’t work the first time, try going through the process again.

I’ve done it like five times. From home screen I tap + then “device” then by brand, then Meross, tap outlet, then link to Meross account, enter ID and pw, then authorize, then next. Get a message “End of Configuration”, tap done. See ST logo and Meross logo. When I tap dropdown for Install your Device Profiles, it just shows “All device profiles”. I can’t change anything there so I tap “Allow”. Goes back to Meross device screen. Go to home screen. No Meross outlets showing. Not in IDE either (though it did show up there the first time, but not since). I’ve now replicated this last scenario by deleting the smartapp and running through the authorization process. Shows up in IDE but not app. Hub was not showing so edited in IDE, but no change. Device type shows as “placeholder” which I changed to “Outlet Capability” but no change.

Update: I can see the outlet in the classic app but not the new one. I also see the meross smartapp in the classic but not new. Any thoughts?

1 Like