Maybe I don't need Rule Machine after all

Completely stuck on step 2, Access to the Toy4Rick/SmartThingsPublic repository has not been granted to SmartThings

I appear to be “forked from SmartThingsCommunity/SmartThingsPublic” but no clue of where to go from here.

Is there a better step by step doc to follow as opposed to the current high level doc and the detailed GitHub Integration doc?

Thanks, Rick

First thing you need to do is manually install Rule and Rule Machine per his instructions here. Do not connect to the Repository until this has been accomplished.

How to Install or Update Rule Machine
There are two SmartApps on Github. The first is called Rule Machine. You should install this in the IDE and Publish For Me. The second app is called Rule. This you should also install in the IDE, and Publish for Me. Rule Machine is a parent-child app, where you can create as many rules or triggers as you want, each an instance of Rule.

After you install Rule Machine and Rule as described above, then you can install Rule Machine in your mobile app. It can be found in the Marketplace, under SmartApps, My Apps. When you install it, the first thing you should do is click on Done in the upper right hand corner. After that, Rule Machine will appear in the list of your installed SmartApps.

Basically open the IDE go to SmartApps>New SmartApp>From Code and cut and past the code from his links in his post.

Tried to link them for you, but was not able to.

1 Like

Thanks John, I could not find that to help this fella (SMILE)

Since I am not a programmer, this is all Greek to me. I was able to finally get the Rule Machine installed, I believe… but now when I try to “select actions for …” on my Android, it tells me that I am “not authorized to perform the requested operation”

All I am trying to do now is just create a single rule for a single door sensor to text me if it’s opened. Trying to crawl before I walk.

Sure wish there was phone support for this :slightly_smiling:


Sounds to me like you didnt publish it in the IDE. After installing it you have to publish it. Button up above the code.

Read the thread on the how to install rule machine. Then read it again. Then, the third time you read it, follow the directions. Then, go back and read it again and follow all of the directions.

It’s pretty simple. Just follow the directions.

There is only so many ways to read directions by a NON-Programmer

  1. In the IDE, select My Smart Apps
  2. Select +New SmartApp
  3. Enter Rule Machine for Name (only way I could get it to work, not written in the instructions
  4. Enter bravenel in the Namespace (only way I could get it to work, not written in the instructions
  5. Enter bravenel in the Author (only way I could get it to work, not written in the instructions
  6. Enter a description - done
  7. Select a category - Convenience - done
  8. Select Create
  9. Publish for Me - done
  10. Do the same thing for the “Rule” (I did not publish for me as I have seen it listed both ways and if I remember correctly, bravenel says not to publish for me
  11. Select + NewSmartApp
  12. Select the Code tab
  13. Paste in the Rule Machine code from bravenel
  14. Publish for me
  15. View My SmartThings Apps and now I see 3 entries, the 2 I created and now a new one from the code I pasted in and published
  16. On my phone, add in a new smart app and select the Rule from step 13
  17. Navigate through setting up a simple when contact is open, do something… and it then says I am not authorized to perform the requested operation

Now, based on these detailed instructions, what am I missing?


Go too your smart apps, scroll down and tap on my smart apps.

Tap on rule machine. It opens, tap done.

Now go to your smart apps tab, tap on rule machine.

Tap done.

Now try and build a rule.

Let me know if that works.

I am not sure the names are matching up with what you are describing, hence things are still not working for me, here is what I have in my IDE

When I go into Marketplace/SmartApps/My Apps on my phone, I see 2 things, 1 called Rule (Rule) which came from bravenel (i can tell based on the icon) and 1 called Rule Machine (My House Rules) which is the one I originally setup in step 3 above.

When I try to configure the Rule, it allows me to set the Name of the Rule, the Conditions and when I try to select the actions for True (when door is open) it tells me I am not authorized to perform the requested operation

When I try to configure the Rule Machine, it only lets me set the Name and the specific modes, nothing else

I really appreciate the help, just not sure what I am doing wrong

I think yours previous steps (3 to 9) are not needed. You might want to delete them from IDE and re-do it…

1) In the IDE, select My Smart Apps
2) Select +New SmartApp
3) Select "From Code" tab
4) Paste in the "Rule Machine" code from bravenel
5) Click "Create"
6) Click "Save" and "Publish for me"

 Repeat above steps for Rule.

You have old (very old) versions of rule and rule machine, these are the two with the gray icons, these need to be deleted from the ide. Click the paper and pencil icon on the left, then delete both of then.
Then you need to install the current version of rule machine to match the version of rule that you already have installed.

Well the rule machine I am using is v1.7.3 and is dated Feb 2016. Where will the new code come from?

And to review the reply from dchau11, if steps 3-9 are not needed, how is the rule machine code brought into in the IDE? Did I not follow the instructions correctly?


Follow below to go to links for lastest codes of Rule and Rule Machine. Once you are at the code page, Copy/paste codes to your IDE.

OK, completely embarrassed now :slight_smile:

dchau11 message about about not needing steps 3-9 was the fix.
I was trying to create the rule/machine twice, once by manually entering the data and then by adding in the code and publishing it from gravenel. All that did was mess me up down the line on my phone.

Bottom line, RTFM as bamarayne pointed out. First simple rule created, now to test it out

Thanks a ton for all the patients and nudging me when I was being a bonehead


1 Like