Matter Hub + Bridge + Aqara (Sept 2023)

Here’s the list of child devices supported by Matter Aqara Hub M2 Matter Update Has Started to Roll Out - Aqara

1 Like

Has anyone tried either of the cubes through the matter bridge? I am curious as to how they will show up and smartthings. :thinking:

It is a bit messy. You get one main, and then one of the following for each side.

I’m having issues with the matter hub showing offline repeatedly in ST, and once I get that resolved I can get better info.

I also have the regular edge driver for the cube in my living room too, so I can do some comparison sometime

1 Like

I have some " Wireless Mini Switch", and also a cube. They are all in the Aqara list. Only the motion sensor shows up in smart things. Any recommendations on how to debug?

in hub m2 settings, under Geneal Settings, Matter, remove all connected ecosystems. Also Apple things.

I tried to add another body sensor and it works. Still, none of the switches and sensors show up. I’ve used the devices for years and they stopped working this year due to old groovy things became obsoleted. Really hope the matter thing can work and revive my buttons and smart things. I’m happy to share logs for debugging. Thanks!

Curious if anyone is able to use Aqara switches in smartthings through Matter?

Hi guys, as you know, Aqara have 2 version of devices, one is for China and one is the global version. The china version is only compatible to homekit, while the global ver is compatible to homekit,google and alexa. my question is if i have the Aqara hub M2 (global ver) and the Aqara E1 curtain (China version) which is matter ready, when i add them into the Aqara hub M2 which is matter bridge, i will be able to bring the Aqara E1 curtain to Smartthings and then to google home and alexa right? does anyone know?

yes, i have one that is integrated this way.

1 Like

my wireless aqara switches is not in smartthings through matter

Did you ever get a fix for this @Mark_Harrell ?

I just got a G3 to act as matter bridge for my aqara motion sensors but only motion comes through, not the light levels.

I only got the G3 as the aqara motion sensors have been hopelessly unstable when added directly to the smart things hub. Going off line on a regular basis. Now this solution means I lose the ability to only control lights when it’s dark. It’s incredibly frustrating!!!

@dublus have you managed to get the light readings for the motion sensors into smartthings? It’s very frustrating!

Getting Error code: 05-300 while trying to add m2 hub to my built in Ls43bm700upxuf smartthings hub. I have tried doing below with no luck. Any advice?

  1. Full reset hub
  2. Remove matter connection with Alexa
  3. Move every device to 2.4ghz
  4. Full restart phone, aqara hub, smart hings hub and router

Hub Details
Hardware Type
Hardware ID
Firmware Version
Controller version





























I believe support of Matter Bridges was not added to smartthings hubs until firmware version 50, so I think you’ll have to wait until your device is updated to at least that level.

They haven’t given us any timeline for when specific model hubs will be updated, and right now there is a lot of variation from Model to model.

I’m not 100% sure, but I believe that only the SmartThings V2, SmartThings V3, Aeotec, and SmartThings Station have received this update so far. :thinking:


Thanks this is the best information I was able to get so far. At least there is some hope.

1 Like

I have the same issue for a long time. Is there a way to get some logs for debugging?

I keep getting Error code: 05-300 when I try to integrate my E1 hub to SmartThings. I think I meet the necessary requirements:

  • my Aeotec v3 hub using firmware 000.050.00010
  • my Aqara E1 hub using firmware 4.0.6_006.004

I tryed yesterday more than 15x times to integrate Aqara in to Smartthings using methed from " Add Device → (Partner Devices) Add → Matter and then wroted the pairing code"

Everytime, after waiting some good minuts, got error 05-300. What i can do / check / try more please?

I’m sure that’s very frustrating. :disappointed_relieved:

The best thing now is to open an official support ticket with SmartThings.

This forum was set up a number of years ago so that customers could help other customers with SmartThings. But it’s not an official support channel, and when you go through an official channel, the SmartThings staff can see things about your account that we as other customers can’t. That’s the good news.

The bad news is that the first person you get will probably just be a general Samsung employee working from a script and may not know much about smartthings. But hang in there, and eventually, your ticket will get escalated to a SmartThings engineer, who hopefully can help.

1 Like

Hello again @JDRoberts, somehow today i managed to pair my Aqara E1 Jub into SmartThings. Also Aqara Cube T1 Pro.
In Cube, i see many Controls, like Pressed, Double Pressed, Held, Pressed 2 to 6 times, Toggle down and so on…What is work for me, is when i put the cube with a face up, held control appears. In fact, it’s the only control who works.

Can you quide me please how to make rest of Controls to work or a better clarification how they can be activated and what means each one. Ty!

I’m sorry, I don’t have the cube, so I don’t know anything about how it works in the integration.

@christian_turner has one working and may be able to say more: