SmartThings Community

Magic Home WiFi LED Control

That is a great start, send me a message directly and we can look at your config for the TCP Tunnel (command line parameters and style of logging you see).

1 Like

Awesome help by ph4R, I now have this working through the SmartThings app on my RGB controller and strip. A Pure RGB Mode needs to be added in the future and I needed to edit the .groovy file manually in my ST IDE but this works :slight_smile:

1 Like

Added WebCORE Color support in the repository.

Is there any guide for this? I have that controller linked in the very first post. I’d love to get it in SmartThings.

1 Like

The first post has the info you need. If you get stuck on something I can assist.

Good afternoon, everyone. I don’t know how you really do all this work, I’m on the third day installing device handlers to yeelight strip and virtually everything is turned on and adjusted, but in reality-nothing happens, instruments do not respond to this control, although with their Applications work and it’s not just your handler. The same with connection Figaro dimmer2, Magic light bulb WiFi RGBW … I don’t think I’m stupid and I’m going to do the same thing in your instructions. You can step into explaining what and where to insert and connect

have you added all that is needed for the RGB stuff to work as well? Can I get the version that is there and replace the one you made me modify manually?

I installed all the necessary handlers (WiFi 370 LED Strip Controller and add new device) to control the lamp Magich Ligtht Wifi, but there really device is not react - maybe I need something to change in the standard Grove under my IP or my account Magic light?

I have not yet

Do you have RGB, RGBW, or RGBWW lights connected to your controller? As noted by @pbarone above, we found that if you have only an RGB controller a small change is needed in the code. For him, we made the one line change in his code, when I have free time, I will make it a configuration. If you need more assistance with debugging your setup, please send me a DM.

I have these device WiFi Magic light Bulb RGBW https://m.ru.aliexpress.com/s/item/32801142958.html?spm=a2g0n.orderList.0.0.797a436bfoNd0i&#autostay
It is good work with Aleksa Echo dot2. I’m new to Samsung Smartthings and I don’t know what is the “DM”

I finally added the code for the RGB Only Mode. There is now a device preference for Controller Style.

RGB = does not understand extra byte for White Channel Filters
RGBW = RGBWW = set all 5 channels at once
RGB+WW = Set White channels then set color channels

The default mode of the device is RGBWW, for @pbarone and @korusdent I would suggest that you set it to RGB.

This latest push also has some work in progress code - The User Buttons at the very bottom do not work. It was something I was playing with before this RGB Mode stuff came up.

so nothing works, neither switching nor adjustment, only virtually on my application demonstrates the work, and the same with other device handlers (Fibaro, Yeelight strip)

Where do you have TcpTunnel running?

The way this solution works is that the SmartThings app sends an ASCII Command to the TcpTunnel running on something [PC, Raspberry Pi, etc] which changes it to a Hex-Encoded message that it sends to the light.

that’s what it means - I’m new. Did not know that such a Tunnel is needed, do I need all the devices? I do not know English well (google translate) if you do not mind, tell me sequentially what to install to add incompatible devices in Smsrtthings?

I just added a device handler for the desired device with GitHub (for example yours) then created a new device and attached it to the handler from the list at the end, then in the application Smartthings on androids found this device and tried to control it - and nothing happened with the lamps

Here are the steps from the original post, I am having a hard time understanding your english. I do not know what any of those other device handlers you have loaded are for and I cannot support them.

Thank you, and I also need use - https://github.com/ph4r/SmartThings-2/blob/master/devicetypes/ledridge/wifi-370-led-strip-controller.src/wifi-370-led-strip-controller.groovy, ? So for Magic light devices through the Smartthings hub, do I have to always turn on the PC with Tcptunel?

Yes, that is the device that talks to the TcpTunnel. The tunnel PC / Raspberry Pi does need to be always on.

I have a Rasberi pi, I bought it to communicate Vera plus with Homekit on the Iphone. How do I install Tcptunel on raspbery pi?