Lost link to ADT Smartthings hub

Starting today, I’ve suddenly lost my integration with my alarm system. Before I was able to operate scenes and automations based on alarm states. It no longer changes a virtual button I created and it no longer changes SHM. It’s been so long since I’ve set this up that I don’t even remember where I did most of it. I believe that my ADT tools app has been broken for awhile so I don’t think that’s it. Anyone know the best way to go about linking an ADT smartthings panel to a virtual button?

I have an ADT hub too. Nothing linked to alarm states has been working post migration. I can still see alarm states in the old automations but I can’t create new ones because the option is missing. I opened a ticket with support and they said it was never supported and should not have worked. It worked for two years and I never did anything outside of the app to set it up.

Ended up using webcore to patch up the issue.

In webcore you can select “Smartthings Adt Panel”. I linked that state to a virtual button/sensor to trigger other automations.