Location confusion!

I don’t know how i set it up, but my parents house is my second location. However it is under my parent email not mine.

I am having typical new app woes, the new app doesn’t see the second location at all.

Did they drop this kind of location support, are all locations under one account?

I realize I could log off and one under the other email, but that is a pain, and the app is buggy. If you log off you will lose a lot of your gui customization.

Login under that second account and send yourself an invite

in the location you want to add yourself to, select the hamburger menu in the top left, them members, then the plus sign on the top right

What if I get an error telling me that my personal account is in another region than the second account?

Ouch, That’s a ticket to support (support@smartthings.com) They used to give you a ‘sorry we can’t help you, create a new account’ response but I’ve seen at least 5 positive results of people getting the geo changed. Keep pushing for escalation.


That actually worked. I recall thats how i did it originally.
There was something screwy where i was no longer listed as a user. But today I was listed…twice.
I sent an invite anyway and clicking that link repaired it.

1 Like

Just for the record, I never managed to get my account confusion solved.

I am a 2012 Kickstarter backer and my first Hub (although clearly labeled as a European customer) was tied to the “default” shard. Also my SmartThings account and later Samsung account were tied to US region. With the classic app this wasn’t a problem but the new app has new restrictions, so I couldn’t use my original account to access all of my hubs anymore. (My two other hubs were tied to the European shard, and most of my Family’s Samsung accounts were able to access them.)

I contacted support@smartthings.com. They told they cannot do anything and I’d have to sort things out with Samsung support. I contacted Samsung support and got the response: “As we are part of SmartThings Support we can only assist queries related to SmartThings app and we don’t have any access for escalating to channel to change Samsung account shard.”

I created a ticket to Samsung support (https://help.content.samsung.com/csweb/ticket/createQuestionTicket.do) and got my account’s region changed. Except that the SmartThings app still claims that the invites cannot be accepted due to accounts being in different regions. Now the Samsung support (in US) refuses to help me be since I’m an European customer. The local Samsung support doesn’t respond to tickets and the UK SmartThings support says: “With the Account regions, this is somewhat outside of our knowledge base so we’re still figuring out what variables can be changed and how best we should be recommending different steps to users, so I would definitely recommend getting in touch with the Accounts Team in your region to get their perspective on the problem you’re experiencing.”

1 Like

For more background, I was able to use both my primary account and the rest of the family’s accounts to access my home hub with the classic app. Using the new app, my primary account would see my home devices under my summer cottage hub (the original Kickstarter v1 hub). The other accounts could see and control the devices in my home and everything worked fine.

When, after the region change of my primary account, I still couldn’t access my home hub with that account, I tried to delete my home location from that account (so that I could re-invite that account using my home locations owner account). Well, my home location was also removed from its owner in the new SmartThings app. The owner could still see the location in the IDE, though. According to the IDE, the owner of the location was my primary account (which couldn’t see the location in the IDE).

Support confirmed that the situation: “It is very odd that it would be claimed to that account after the Location is owned by a different user and has been deleted.” and recommended: " I’ve had checked and there is absolutely no way that we can change the owner of a Location right now, and thus my recommendation would be to factory reset the [my home location] Hub and reset all of the devices connected. I can appreciate that this is not ideal, however, due to the Location being in some kind of limbo I do believe this to be the best route to take."

I run the factory reset procedure to the hub. Currently I can see two instances of it in the IDE:

The IDs of the second and third row are identical, except that the third has the _16…_DELETED attached to it.

I think it’s a pretty ugly situation. It would probably easiest to ditch that hub altogether and just buy a fourth one. I’ve already spent two days trying to reconnect all my devices to my home hub. It seems that some of the cloud-to-cloud integrations are still tied to that _DELETED instance and fail to re-install to the new.