Living in Fear as a SmartThings User (Jan 2019)

ActionTiles does it for both :wink: :heart:. We especially love that our customers rate us at 4.8-Stars (Play Store) to 4.9-Stars (Facebook). That’s what keeps us motivated, despite the challenges with this SmartThings → Samsung transition.


There’s a lot of love in this Community … but participation has leveled off or dropped considerably. And there are a lot of folks at SmartThings that share the same affection for what Community Developers have accomplished.

Unfortunately, it’s pretty evident that above at a certain level of management and above, the passion lies elsewhere. I think there is genuine passion for the new App, new API, and for Bixby AI, etc., etc…

Officially or realistically, we’ve been “unfriended” until we learn and apply all the new tricks that they want developers to care about.

3 Likes

I appreciate your perspective and contribution to this discussion.

2 Likes

Thanks… I wish I could do more than just express empathy and realism. I suppose I could try optimism, but it is hard to do that with accurate perspective. I don’t know when things will get better.

We do know that SmartThings is and is intended to continue to be a Platform. That means Samsung absolutely wants to have happy developers. And, ultimately, that will mean happy customers.

So in the meantime, the criticism of the transition is completely valid. But I think the vision is good. That’s why I don’t mind the New App: It is not inconsistent with the vision.

2 Likes

Also, new customers don’t know what SmartThings is and what was promised ages ago. They are happy to have their light come on and off with a sensor and a lightbulb.

2 Likes

I started this thread at 9:52am est on January 14, 2019.

On January 14, 2019 at around 4:30pm est, I opened up the “New App” to play around with it some more. I went into the Automations tab and clicked on one of the Custom Apps that was listed in there. I am not sure which one but I got the “Something wen wrong. Please try to install the SmartApp again.” message.

On January 14, 2019 at around 5:15pm est, I get an call from the Wife saying that the lights keep going off.

On January 14, 2019 looking through the logs, I noticed that at around 4:30pm est the following devices mysteriously found themselves offline and will not reconnect even after a reboot.

Bedroom Motion Sensor 2 SmartSense Motion Sensor Home Home Hub 000D6F001099E199 3E64 OFFLINE Local 3 hours ago
Bedroom Shoe Closet Door SmartSense Open/Closed Sensor Home Home Hub 000D6F000B6668F0 1989 OFFLINE Local 3 hours ago
Boys Room Door Visonic Door/Window Sensor Home Home Hub 000D6F000B23759D A2FC OFFLINE Cloud 3 hours ago
Boys Room Motion Sensor 2 SmartSense Motion Sensor Home Home Hub 000D6F00056B4431 F9DF OFFLINE Local 3 hours ago
Day Room Door 1 SmartSense Open/Closed Sensor Home Home Hub 000D6F000B238429 7270 OFFLINE Local 3 hours ago
Day Room Door 2 SmartSense Open/Closed Sensor Home Home Hub 000D6F000B23A221 1509 OFFLINE Local 3 hours ago
Eboni’s Room Door SmartSense Open/Closed Sensor Home Home Hub 000D6F001095AED7 C713 OFFLINE Local 3 hours ago
Eboni’s Room Motion Sensor SmartSense Motion Sensor Home Home Hub 000D6F00056B196E 1939 OFFLINE Local 3 hours ago
Front Outdoor Switch 1 Z-Wave Switch Generic Home Home Hub 44 OFFLINE Local a day ago
Guestroom Fan Dimmer Switch Home Home Hub 3F OFFLINE Local 4 days ago
Kitchen Motion Sensor SmartSense Motion Sensor Home Home Hub 000D6F00057B8993 188C OFFLINE Local 3 hours ago
Living Room Motion Sensor SmartSense Motion Sensor Home Home Hub 000D6F00056B22C1 3533 OFFLINE Local 3 hours ago
Mailbox Visonic Door/Window Sensor Home Home Hub 000D6F000B239651 F981 OFFLINE Cloud 3 hours ago
Outdoor Switch 2 Z-Wave Switch Generic Home Home Hub 45 OFFLINE Local
Study Door Visonic Door/Window Sensor Home Home Hub 000D6F000B238063 E120 OFFLINE Cloud 3 hours ago
Toilet Door SmartSense Open/Closed Sensor Home Home Hub 000D6F00057B76F9 742C OFFLINE Local 3 hours ago
Upstairs Closet SmartSense Open/Closed Sensor Home Home Hub 000D6F000DEC5D39 6D15 OFFLINE Local 3 hours ago

On January 14, 2019 at around 7:00pm est, I opened up the New App and went back to the Automations Tab and tried to open another Custom App and got the same error.

On January 14, 2019 around 7:18pm est, I went back to the IDE to do some more searching and noticed that Devices listed as Offline were actually back online since around 7:00pm est.

Now, I am no brain scientist but ummm, ummm, its something going on funky when I try to use the New App. For now, I am going to avoid it like the plague until its no longer causes me anxiety attacks!

Ok, not to beat a dead horse but:

1 Like

Starts considering the number of iOS users who have Samsung appliances…. :thinking:

3 Likes

You probably shoudln’t use anything you live in constant fear of.

You’re passing judgement of an app that isn’t ready yet, even SmartThings staff won’t recommend you use it. Yes at some point they’ll force a switch and deprecate the old app but that doesn’t mean that the new app will be the same as it is today when that time comes, you’re worrying about a future that doesn’t exist yet.

If you’re having that many difficulties all over the classic app, I wonder if you’re using a DTH or SA which is crippling your setup.

Fascinating…

1 Like

By not having my v2 hub work over the past month due to a hardware issue, I’m also having second thoughts. I’m not a big webcore/groovy user. I do use device handlers.

And I’m still waiting for Samsung to ship my replacement hub… (Broken record) Hubitat is looking better and better, and if I have to buy a new hub, it will be my next purchase.

2 Likes

You are correct. I initially wasn’t but now I am because of the reasons I stated above.

I am voicing my concerns as to what I have witnessed thus far. You are right, SmartThings staff won’t recommend using it now but unfortunately, the Classic App hasn’t been updated for some time now. The “Things” tab will no longer load for me. This is true for all 6 of the devices that it is installed on. I disagree with your statement about worrying about a future that doesn’t exist. For me, this is a “Right Now” issue. The only update offered is to use the New App which again, I can not use at this time. SmartThings customer service has been on vacation for over a month so…

I typically don’t have issues but something is amiss. The only issue I was having was my “Things” tab not loading. Wasn’t that big of an issue because I can still get to things via Rooms. Seems to be in connection with the number of devices I have…However, someone or group of someones has screwed the pooch over at SmartThings. If you ever decide to go back through my post, you will see that I offer a lot of help to those who visit this forum. Maybe its something I did, but I doubt it.

3 Likes

But you’re voicing your concerns on something that isn’t valid. If they were forcing people to the new app tomorrow then we’d be 100% in agreement. The new app is supposedly a long LONG way off, so it’s just pointless speculation and worry right now.

Again, how many “devices” do you have (I put it in quotes because you need to include everything that would be listed in ‘Things’ including virtual devices)? How many custom DTH/SA’s do you have uploaded to your account that you are using?

I have 157 “devices” and the Things list can take a while to load, if I ever do go in the app (which is rare) I usually just jump straight to the ‘Rooms’ section which loads almost instantly, coincidentally if I switch back to Things shortly after, it usually loads quicker for some reason.

Well your experience might not necessarily be commonplace though, just like you have some people that have serious issues with the app – or the platform as a whole – and scream bloody murder. And even if it was common, that doesn’t necessarily mean that the concerns aren’t valid… if my experience with the platform continues to deteriorate over time, I have to assume that it’s only a matter of time before I have to jump ship.

I’m certainly not going to wait until absolutely everything stops working to consider other options, regardless of how things are behaving for other folks.

I personally don’t have that many devices, yet I use the app every single day. A lot of the time it’s because some device failed to respond (just now I had to go back and “poke” a light that wouldn’t turn off), or to confirm that the garage door status is showing up as “unknown” again.

2 Likes

Wow this thread that i read from top to bottom came at the either the right or the worst time. Right when my family was complaining of me spending way to much time with my HA.
It opened my eyes yet depressed me all at the same time, thinking of all the countless hours i have invested building it.
I have over 150 devices and growing and a mixture of all sorts of protocols, brand names etc etc .
So since we have already bit this bullet the least we could do is have a contingency plan in place for the future whenever that may be.
Hence the question what should one do next?? Hass.IO, Domotics, Vera, Hubitat…its open for discussion.
D

2 Likes

The issues I stated are valid. YMMV but I am experiencing an unrepresented amount of issues and so are others. I am probably at around 275 devices including virtual devices. I have lost faith in believing that stuff will work as it did in the past because of the current state of SmartThings. As I also stated, I am even more concerned that while dealing with this “Cluster F**k”, I also have the looming thought that I will be forced to abandon my Custom Apps and DTH because of the Classic App going by the wayside.

Maybe this stems from something as simple as displaying weather on my Tablets via ActionTiles. Maybe it has something to do with the wife being happy for over a year now all of a sudden she is calling me every other day about something that isn’t working anymore. Maybe it has something to do with delayed motion events or alerts that spam over and over. Maybe it has something to do with my HEMs reporting bogus data that was working perfectly for over a year. Maybe it has something to do with the alerts to let the dogs out to potty has gone to "S**t. Maybe it has something to do with the lights turning on/off randomly. Maybe it has something to do with devices falling off the network.

Maybe, just maybe, it has something to do with very valid reasons why I am Living in Fear of stuff not working like it use to…

Things were running smooth as butter then after the last firmware update, it all went to hell. It’s a bit much to deal with and I dread the thought of moving everything over to Hubitat even though I am steadily and slowly moving things over as they break.

3 Likes

This has always been my beef with SmartThings as a whole though… when things are working, it’s just straight-up MAGIC. You drive up and OMG THE GARAGE DOOR IS OPENING IT’S LIKE THE DAMN JETSONS and everybody is happy and it’s 72 degrees all day and birds are singing.

Then BOOM you get kicked in the face and your lights blink 72 times at 3AM because your sensor is home oh no it’s away never mind it’s home oh there you go again welcome home you’re back. Or 3 lights turn off and the other 3 don’t and you’re standing around like a fool flicking the switch up and down feeling like a donkey.

When things work, you get a glimpse of the future and you feel like the platform has so much potential, and it will be like that for a couple of weeks, then there will be some MAJOR issue with a firmware upgrade or an outage or sun spots and it depresses you and makes you wanna throw everything in a box.

8 Likes

Thanks I needed this post! You had me rolling on the floor.:rofl::rofl::rofl: I believe you nailed my emotions perfectly.:facepunch:

1 Like

Okay, you’re right :slight_smile:

MAN… Just yesterday I was yelling about the garage light being off… who keeps messing with the switch? The light turns off by itself, don’t mess with the switch…

Flip the switch… nothing. Flip it again… nothing. Third time, light turns on.

Turns out the routine that was supposed to have turned it on after it detected motion fired but the bulb never got the message.

I’m out there feeling like the donkey from Shrek.

1 Like

And of course, today is the day that the app has decided that I have not returned home after school drop-off, and the house is in Away mode and here come the intrusion notifications.

The wife which is out of town is like “WTF is up with all these notifications on my phone” – because remember how awesome it was when ST decided to remove the contacts functionality so you had to notify everybody connected to the hub? Yeah that was awesome.

Even after a reboot and fiddling around with location, the only way I could get the app to realize I had arrived is the old trick of opening the Home location and checking the geofence. Then it finally said that I arrived, 30 minutes after the fact.

The only saving grace is that this is so common that I already have a workaround that involves a piston that forces the house mode to Home mode and sets a boolean to prevent the mode from changing while I sort things out.

2 Likes