Linear gd00z-4 stops my garage from opening fully


(Chris) #1

I have a linear gd00z-4 paired to my genie pro 1024 and have it successfully linked to my smartthings. When I use the smart things app, the garage opens and closes properly. However, when I try to use the wired push button on the wall or the wireless garage door opener remote, the garage door starts to open immediately and the gd00z-4 starts its normal warning beep. By the time the garage door gets to about 3/4 of the way open, the warning has stopped and it sends a signal to the garage opener and it stops the garage door about 3/4 of the way.

I have the gd00z-4 wired into the same terminal on the genie as the wires from the wired push button (1 wire from each the push button and gd00z-4 In each terminal, so two wires in each terminal).

Has anyone else experienced this and have a solution? My wife (6 inches shorter than me) has bumped her head several times and wants me to disconnect it…


(Ron) #2

Something is wired wrong here? When you use the physical buttons or dedicated remotes the GD00Z-4 shouldn’t even be in play. It should report the change in status but that is from the tilt sensor. The “beeping” indicates the GD00Z-4 has been requested to open/close the door and this should not be the case.

I also have a Genie Door opener and when I use either of my physical buttons or the dedicated remotes the door opens/closes without any alerts from my GD00Z-4.

I have the buttons wired directly to my garage door opener and I have the GD00Z-4 also wired to the opener. Each simple closes the circuit to open/close the door. The buttons close the circuit when the button is pressed with no delay and the GD00Z-4 alerts with light and sound before issuing the closing of the circuit to open or close the door.

It sounds like we have the devices wired the same so I am not sure why this is happening.


(Chris) #3

I tried swapping the gd00z-4 wires but it does the same thing. I also tried joining the wires outside and the having just one wire go into each port, but it did the same thing too. I believe I’m just going to request a replacement from Amazon before the return period ends.


(Ron) #4

@cantbeyou nice picture but I have no idea what each of those wires is connected to :slight_smile:

I sill don’t see how pressing the button on the dedicated remote could be triggering the GD00Z-4, that’s weird.

You should be connected to 1 and 2 according to the manual
http://www.geniecompany.com/data/products/retail/1022-1024-1042-install.pdf

But you have other wires plugged into the same terminals so whatever they are connected to in essence your GD00Z is also connected to. I would be curious if you short the two wires from the GD00Z-4 does it trigger the device. If yes that would explain why closing the circuit of the other wires would cause this.

I have three sets of wires connected to my Garage door opener contact terminals. Two from buttons, one is a Genie button, one is a doorbell style button and I have the third set of wires going to my gd00z-4. But I don’t have this issue.

The wires going into 1 and 2, looks like green and white into 2 and red and white into 1. What wires are for the GD00Z-4 and what wires go to your switch?

I can’t tell if the red wire in the middle is going into 2 or 3 but looks to me like 3, is any wire exposed and touching exposed wire from #2?

I still think this is a wiring issue and not a faulty device. If shorting the two wires from the GD00Z-4 briefly makes the device trigger then that would seem like a faulty device.


(Chris) #5

The white wires in one and two go to the gd00z-4 and the red and green in one and two go to a doorbell push button. Three through six I assume go to the laser sensor at the base of the garage door.

Thanks for trying to help. I have no knowledge of electrical things and i couldn’t find any help anywhere else. How would i short the gd00z-4 wires?


(Chris) #6

The red wire going to 3 is by itself and nothing is exposed


(Ron) #7

Take out the two white wire. Touch them together briefly. Does that trigger the GD00Z-4 ? I don’t think it should.

Again this issue makes no sense to me as described. The GD00Z-4 just closes the circuit like a momentary switch (doorbell button in your case). Closing the circuit shouldn’t trigger the alarm countdown. Only a zwave signal should trigger that countdown. Are you sure you don’t have some rule set up that is triggering the GD00Z-4 (motion sensor where the button is placed, contact sensor on door which you open to press the button etc.)


(Chris) #8

That was it! I tried to set up a rule to close the garage after it had been open 30 minutes. I had something faulty in the app. It was set to close when It detected the door open, i wanted to have a delay of thirty minutes but never set that part up.

It works perfectly now!! Thanks so much!


(Ron) #9

Perfect, I started suspecting something like that, nothing else made sense!

You probably could have figured this out if you watched the logs to see what is happening. You would have seen the rule fire in the logs. If you are not familiar with the logs there are here ide.smartthings.com, select “Live Log” then test your actions and watch what gets written to the logs.