Lightwave RF Integration (UK)

Hi, I only set up the Smartthings integration about 3 weeks ago. The issue has been there since then.

LWRF support just pushed the question back to Samsung.

Hi Folks - wondering if this is a simple fix or not.

Just moved hard drive to a new machine. Set static IP on the router so it has the same IP as before to avoide updating device settings.

However when i send a command through ST now, node server just repeats “Attempt xx - Sending message :001 etc…)”. It keeps doing this until the 200 limit set in the code.

Any ideas why it’s not making it through to the LWRF hub? I seem to remember something about linking, but cant find any info.

Cheers

Sorted it - had to use ST website and run simulator to effect ‘pairing’ after removing all linked devices on the LW hub

Anyone know how to change the Lightwave account linked to Smartthings?

A while back I linked to Smartthings with my Link 1 account and hub, discovering that I needed a
Link 2 hub and account.

I have now acquired a Link 2 hub and account, but can’t work out how to connect to the new account.

If I try to add a new device in Smartthings and select Lightwave it does not give me an opportunity to add the new account details, it just uses the old account details.

Sorry all.

Manged to work it out.

Sorry if this has been asked before or is know.

Has anyone experienced an issue where you will turn on the lightwave switch manually (at the socket not via smartthings or the LWRF app) but the state isn’t updated in smartthings unless you refresh the app? This is partially annoying when you use something like actiontiles on a mobile device (on wall).

Is there a workaround?

That is how the gen1 LW kit works - there is no built in monitoring of the state of the switch.

Or do you have the gen2 LW kit?

I am all gen2.

Should I have to refresh in the app for the state to change?

Not sure if anyone is still using Adam’s Smartthings-> nodejs - >lightwaverf local integration but I recently decided to give it a go as the official lightwave integration had got incredibly slow. It worked really well and solved that issue but I have a lot of legacy (gen 1) LightWaveRF devices and working out the room/device numbers was getting tedious. So I thought I’m a developer I can solve this.

So for my own use I have created a Smart App that contacts the lightwaverf connect server logs in with my (or any account) and queries the undocumented api to download the list of rooms and servers. It then creates devices using Adam’s handlers for each of the devices on the list assigning all the correct parameters. Devices are named Room Name Device Name for example in my set up I have a Light in the Spare Bedroom and this gets named Spare Bedroom Light.

If anyone is interested I could spend a bit more time to tidy it up for more general use.

Yes please!

Sounds awesome :+1:

Ok first cut is here
garrywma/LightWaveRFSmartthingsLocalDeviceCreator: Note requires https://github.com/adamclark-dev/smartthings-lightwave-node-server

Neil do you still have an account with a PIN. I haven’t been able to test against one. The code uses the api from the modern connect dashboard at manager.lightwaverf.com which requires a password so I suspect it will not work with a PIN but worth a try

Hi Garry. I login to that site with my email and a 4 digit pin. If needed I may be able to ‘reset’ my password to something alphanumeric.

I haven’t had time to test your solution yet, that’s a job for the weekend so will report back soon.

Garry_Whittaker Developer
March 31

Neil do you still have an account with a PIN. I haven’t been able to test against one. The code uses the api from the modern connect dashboard at manager.lightwaverf.com which requires a password so I suspect it will not work with a PIN but worth a try

OK it may be that they are treating the pin as being the password for converted legacy accounts will be interesting to see if it works.

Garry - looks to have worked perfectly. Except I got this error after saving my LWRF account details and installing the SmartApp. “Something went wrong. Please try to install the SmartApp again.”

But . . . it has added devices with LWLOCALx-y as the Network ID. So not sure what the error relates to but it seems to have worked as intended?

Where it doesn’t quiet work is if i have a device thats in my living room, listed under Study in the lightwaveRF app because i have too many devices in my living room - the naming convention doesn’t work in this case. But as a base to start from, with just a few tweaks to device names, this makes setting up the network on ST for the first time SO much quicker.

That is really good to hear although I am puzzled by the error. Was this the new or old Smartthings app? I only have access to the new one and haven’t seen that error. Are you able to run it with the live log running to see if anything gets recorded (warning re-installing will delete and recreate all devices)

Any thoughts on an alternative naming convention? Would be happy to add in another option

Edit: one thought on the error you don’t have more than 500 lightwaveRF devices? I would have thought unlikely but I do know SmartApps can have a maximum of 500 child devices

@Neil_Oakley Did you see my post above?