Lighting Automation motion timer issues (lights turning off even with active movement)

New user here and I just got a V2 hub and some “things.” In the garage I have a SmartThings Motion Sensor (v2) and an Aeon Labs Smart Energy Switch. I set up the Lighting Automation smart app to turn on the light when there is motion and “Turn off after motion stops” set to 3 minutes. It seems to work as expected most of the time.

My problem is situations of continuous movement. In my studying it appears that Lighting Automation starts a 3-minute timer on the “motion has stopped” event, but does not kill the timer if there is subsequent movement. It is especially frustrating because you have to wait until the sensor actually decides that motion has stopped before movement will turn on the light again.

Here is an excerpt of my event logs. You can see that the switch off command happened 3 minutes after the “motion has stopped” event. The “detected motion” a few seconds after that event did not stop the timer. I suspect that if motion had stopped long enough to trigger another “motion has stopped” event a fresh timer would have started, but in this case the motion was continuous.

6:09:20.204 detected motion
6:09:20.298 APP_COMMAND switch on
6:09:41.157 motion has stopped
6:09:46.934 detected motion
6:09:47.103 APP_COMMAND switch on
6:12:41.339 APP_COMMAND switch off

Did I do something wrong in setting this up? It seems like “detected motion” should be stopping the timer or that the SmartApp should check that motion is in fact “inactive” before sending of the off command. I have tried deleting the app and starting anew, but no effect. The motion sensor is sending events as it should be as far as I can tell; its the SmartApp’s timer that gets confused.

Turn off after inactivity is always tricky to get set up just right. @bravenel is a grandmaster this so he may have some comments.

There’s also a known bug right now in turn off after inactivity, but I don’t know if that’s what you’re running into.

This has been identified as a known bug in the lighting automation.
Shoot an email to support, that’s one way that they prioritize fixes.

That’s probably what’s going on. I have no idea why Smart Lighting is failing this way, other than the numerous reports here about it.

One work around is to use Smart Lighting to turn on the lights from motion, and my little app called “Turn off after motion stops” to turn them off later. My app doesn’t have the bug. This would hopefully be a temporary workaround, until ST fixes Smart Lighting. See this thread: Turn off after motion stops.

Another way around ST’s bugs, it to use my Motion Lighting app: Motion Lighting


After some initial testing it appears that @bravenel’s turn-off-after-motion-stops is working perfectly! Thank you all for your help. I’m going to send support an email as well as @Mike_Maxwell suggested.

1 Like