Lightify RGBW strip not discovered by Alexa (but is by ST)

I’ve seen a couple of similar posts but no clear resolutions.

I recently added a Lightify RGBW strip light to my ST system (no lightify hub, just ST hub), and it was discovered by ST and seems to work fine (default handler). But it refuses to be discovered by Alexa.

I have confirmed that the Amazon Alexa smartApp has “access all devices” selected.

The light fails to show up as a device in Alexa’s app, while my other ST devices do (as they have for ages). ST Hub V2 and Classic (iOS) ST app.

Any suggestions?

A work around if no one else has anything better… Create a virtual switch that when turned on, turns on the strip, discover that in Alexa, and that’ll at least give you voice control to turn on and off.

I have had similar problems with other devices. Just my thoughts here…
I have the Amazon Alexa smartapp installed in my SmartThings app (classic) (on my phone). Open that Amazon Alexa app and add your device - probably under “Switches”. Since your device is present in ST, it should be available to select and add to the Alexa app. Save that. Then tell Alexa to discover devices again.

Hmm… I created a virtual switch to try this workaround, but Alexa does not discover it either - so maybe something else unrelated to the Lightify device is going on. I’ll check in with ST support to try to resolve.

(Also, I already had “all devices” chosen in the Alexa smartapp in ST.)

@georgeh

Can you confirm that you can select your light device in the Alexa app in ST?

Yes, the Ligtify device (as well as my later virtual switch for workaround testing) does show up in the Alexa SmartApp within ST. But it (and later switch I created) fail to show up after running Alexa’s discovery. I’ve tried with both the “select all device” option in the Alexa SmartApp, as well as independently selecting (all) devices – neither works.

@georgeh,
You might try logging in and out as suggested below. I know it’s not a virtual device but it might work.

Circling back to close this - disabling the SmartHome skill in Alexa, and then reenabling (and relinking the accounts) fixed the problem.

Make sure the DTH for your switch is the “Alexa Simulated Switch”.

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.