Light won't turn off - did set TCP to "never"

Anything else I’m doing wrong or can try?

Put the TCP under the ‘with’, line 25.

Should your IF be Motion Sensor 1 Changes To Active ?

Without a trigger, conditions will act like one (as indicated by the orange lightning bolt).

:+1: Yep, missed that…LOL

Thank you! I’m new to webCoRE and didn’t realize you can place the TCP on a specific line. That did it!

One more question…I am using presence for an if-then for whether the water heater turns on or not. However, I want to make it so even if people are home, that it still turn off at a certain time of night. So basically the time needs to override the presence. How would I do that?

Just add another timer statement right under the existing one that turns off the switch at whatever time you choose.

So just another if-then underneath the other one? When I do it like this there is no countdown on the dash. I’ve also noticed that when one of the two people are home it still says “false” for the presence part even though on ST it shows the person as “present”.

Like this, substitute the correct task and device where Location is…

So sorry but how do I set “no operation” by itself? I can select the water heater and then “no operation” but I don’t know if that’s the same thing. I’ve searched this site (and reddit) and can’t find anything. Also how would I then make the piston aware of presence at 6:30am again? Thanks for all the help!

No operation is just a placeholder. Use turn off or whatever appropriate command your device takes.

Duh is me! Thanks!

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.