Light Control Fails from Short Cut ,but works from "Things"!


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #1

I have noticed a weird issue today. I was not able to control one of my lights (Jasco) through SmartTiles Dashboard. So I opened the SmartThings app and tried to control it through the SmartThings Lights and Switches dashboard. Strangely, the light was showing as OFF, although it was on, so I tried turning it ON and just like SmartTiles it did not respond. So I went to the device directly under “Things” and from there I was able to control the light with no issues. The status was also getting updated correctly. I have contacted support and waiting for a response. Meanwhile, did anyone else have this issue before? Any idea on how to address this? What could be causing this technically?


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #2

Try deleting / removing the Shortcut to the Light/Switch and adding it back?

Shortcuts are implemented with hidden / magic SmartApps, so perhaps the SmartApp stalled or received an upgrade that failed. You can also check your “My Locations” page in the web IDE to see what is listed as your shortcuts (Under “Solutions” - “Lights & Switches” - …).


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #3

I just did it and it did not really help address the issue. I evaluated the problem with a little more detail. The problem is that in the shortcut menu, the light shows up as off, when I exit the page and come back to it (even though the light is actually ON) - When I click on the light switch, in the shortcut, it updates to “Turning it ON” and while the status of the icon is “Turning it ON”. if I continue clicking on it, the light turns on/off… but when I leave it for few seconds to update its state, it does not get updated. From the SmartTiles dashboard, if I keep clicking, I can get it to turn on, but can never get it to turn off…

If that was the case, wouldn’t all my short cuts get impacted. Only one light is getting impacted here.

Its definitely nothing to do with the device, because when I control it from “Things” page, it works perfectly fine. What could be the difference in how the light is controlled in “Things” page vs any other smartapp ?

I can make a quick video and post, if its difficult to follow what I am saying…


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #4

This is the inexplicable part.

Perhaps create a Shortcut to a group of the same type of lights to see if the behavior is the same?

I suspect a race condition of some sort… Some step in the process is slow. I often have Shortcuts out of sync with the actual Things, but if the platform is slow it gets worse.

You can also try removing and re-adding the actual Device completely… We’ve certainly seen object instances get corrupted or stuck on a bad server…

Tech support may be able to read more logs, but I would not be surprised if they walk you through same steps.

We can Skype to screen share so I can observe, perhaps…


#5

Similar problem last night with one (& only one) of my shortcuts. One of the two light stayed on while the other turned off as it should. The shortcut said both were off. The only way to turn off the rogue light was via Things. I should point out that this is not new with this particular shortcut. Same thing happened a few months ago. Without any doing on my part, the problem cleared and the shortcut worked fine the next evening and ever since until last night.

As I was writing this post I decided to try the shortcut this AM. Worked perfectly… :smile:


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #6

Just checked, and I definitely have 1 Switch Shortcut that is stuck in the “On” state even if the direct Thing Tile is correctly up to date.

We have a bug. Who’s calling it in?


#7

Everyone who has the bug should report it to support@smartthings.com That way support can get a sense of the magnitude of the problem.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #8

I’m not stopping anyone.

But it’s not a critical bug to me, so I frankly don’t want to deal with the step-by-step email exchange effort required by Support (i.e., delete this, uninstall that, rate me 5 stars, etc.). I’ll do that from time to time.

For a non-critical problem, just call me a bad Community member because you’ll often just see me confirm it here.


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #9

I have opened a ticket with support. Before they could ask questions I let them know everything I tried except removing the light and adding again. Also sent this video to them so they understood the problem.


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #11

Have you observed “Live Logging” while toggling the Shortcut?

]1. When I toggle the malfunctioning Shortcut, I get a single debug message from it’s associated SmartApp:

4d40ab54-05b8-4152-8a49-2999920894ff 11:48:51 PM: debug Parse returned [Back Under is off]

]2. When I toggle a working Shortcut, I get a ton of responses in the log.

]3. So … I just renamed the malfunctioning Shortcut, and … now it works.

Problem Solved. :confused:


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #12

i just tried renaming but it did not help. :frowning:
Let me see what the support comes back with today…


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #13

It seems like i figured a way to solve this.i shut power to the switches first (using the air gap switch) and then waited for approx 30 secs. Soon after that i tried and the switches were still not working as expected. Then i used the “replace” function on device preferences… After which the switch started working as expected.

But the power reset was key. When i tried using just the “replace” function , it did not help on one of the switches.

I hope this can help others in future.i had contacted support and they were still looking into it.