Lidl Smart Home with SmartThings

Hi

I’m new to SmartThings (been meaning to buy a hub for a while but finally got around to it). I’ve got a couple of the Silvercrest USB Extension Leads so have tried adding a custom device using this DTH but I only get one socket showing up in the SmartThings app. I’ve tried deleting and adding it again and have tried adding binhead2004’s line of code but still only get one outlet showing up and working.

I don’t know if it makes any difference but mine are the UK version of the leads. Is there anything else I can try to get these working properly?

thanks

I had not read the product description on lidl’s page and it seems interesting:

  • Depending on each day of the week, up to 6 watering intervals can be programmed.
  • The duration of the watering of the daily intervals can be adjusted separately.
  • With frost detection: at temperatures below 5 ° C irrigation is not carried out.
  • Irrigation rhythm: from daily to once a week
  • Watering intervals per day: 0-6.
  • Irrigation duration: from 1 to 9 hours, 59 minutes.

I get the impression that all these programming settings are stored in the valve itself.
This is important, since once the valve is programmed, you do not need to do automations that depend on the hub or the internet. They are done autonomously and you can monitor or cancel from the app.
If this is true, is it still better to leave it installed on your lidl hub?

I think that for the operation with smartthings it should not affect.
To ensure that it is inside the dth, you can publish its raw description and data from the IDE.

Did you follow the steps, create and publish DTH in IDE and then pair the power strip?

You can also try this version of the DTH, updated to reduce the transmission of messages to the hub.
I have it installed on 2 strips and it works fine.

You need to change your device type in your IDE at

https://graph.api.smartthings.com/

In the forum you can find help about how to do it.

Hi

yes, I’ve tried a couple of the DTHs linked to in this thread (where the link to the DTH still works) and published it “For me” before pairing but I get the same result, only 1 working outlet.

After messing round with the “Type” of the paired outlet, I managed to get two sockets working by selecting “ZigBee Multi Switch” but two sockets is as good as it’s got

You have to choose the dth “Integrated ZigBee Switch”.
As you have published it for you, it has to be at the end of the drop-down list

Hi Luis

Thanks - I’ve just re-looked at that. The original link to github results in a 404 error, which is why I hadn’t used that one previously, but after hacking the url down to “GitHub - LAMS144ai/smartthings: Little mod DTHs for Smartthings” I found there’s code for “Lidl_powerstripe.groovy” which appears to be the current version of that code and after applying the remaining steps (albeit now selecting “Lidl Power Stripe” as the Type), I can confirm I now have all three sockets working!

many thanks for that, I should now be able to get my second strip added into SmartThings when I can get it out of the loft.

Hi Mariano,

I’ve just managed to sort this after relooking at the info Luis quoted but thanks for your help anyway.

1 Like

These came to Lidl in Ireland last week. Glad to hear it will work with ST, gonne try and get one and give it a go myself!

Hi

So seams that without Lidl Hub is impossible to change this closing parameter after 1 minute? No other solution. I know it’s cheap but to buy only because of changing this one parameter is waste of money and later Lidl Hub will stay unused.

2 Likes

Hi folks,
I’ve managed to connect the device to ST, but it doesn’t work. It was recognised as a thing, and I changed it to the ZigBee button, but nothing happens. I’ve tried to change it to ZigBee switch and multi-button but without any success. Is there anybody that managed to fix it?