SmartThings Community

Leviton VRCS4

dth_remotes
dth_lighting

(Nathan Hall) #21

I figured it out - unsurprisingly it was new user error.

I was pasting the code into the new device type section vs. new smartapp - once I pasted into the correct smartapp section the error went away.


(Ian D) #22

I finally got my first VRCS4-M0Z installed today. I’m using both Brian’s device type and app. I’ve been able to pair the device and buttons 2, 3 and 4 works a expected. But I can’t seem to be able to make button 1 work. In the activity feed I can see when “Button X Was Pushed”, but only with the last three buttons. When I push the first one nothing happens. Any idea what I might be doing wrong?

The dimming buttons don’t raise anything in the activity feed either.

Edit: I’ve also tried the device type through the IDE. I can see commands being fired whenever I press buttons 2, 3 and 4 and also when I press the dimming buttons, but it seems that nothing happens when I press the first button. Could it be a pairing issue?

Thanks


(Ian D) #23

Arrgh!! It is getting worse. I’ve tried un-pairing and re-pairing it and now it’s only the first button that works and the other three don’t do anything anymore!!

It is clearly a pairing issue, but the manual is no help…


#24

Leviton intends the S and the Z to be used in different ways for different purposes. S is a lighting scene controller, z is a zone (group) controller.

As engineered, most hubs handle this for the S by adding two devices to the network. (Stay with me here.) button 1 is intended as an on/off to control the load from the switch. Just on/off using local current. So it does control a single load from button 1.

http://www.leviton.com/OA_HTML/ibcGetAttachment.jsp?cItemId=d8DLxxzNJ.VZiFgntntBtg&label=IBE&appName=IBE&minisite=10251

Buttons 2 through 4 are intended to select between 3 scenes, like 50% bright, 75% bright, 100% bright. Turning one on turns the other two off. The actual action requests are intended to be sent by the hub to each end device.

So 4 buttons, controlling 4 scenes and 1 load (by default the load is controlled by button 1).

The Z model is a zone controller. Which mostly means group association. And does allow more than one button to be used at a time. Like one for entertainment system and a different one for a particular lighting scene. But again depends on zwave group association.

4 buttons, one for each zone, plus a dimmer control (which won’t work the way you think)

http://www.leviton.com/OA_HTML/ibcGetAttachment.jsp?cItemId=wX70.gE7ieRqWrLLLCKXzQ&label=IBE&appName=IBE&minisite=10251

All of this is true with or without ST.

( edited to add Leviton released two versions of BOTH devices. Gen 1 did not control a load in either the S or Z models. Gen 2 did for both. If you pick these up from a discount house, you might get the older one.)

So here’s my guess. ST may not be picking up that this works like two devices. And when you’re seeing only button 1 working somehow you’ve picked up on the on/off switch device. But that’s purely a guess.

The following link will take you to directions for a nonST hub, so not everything applies. But read 2B carefully. This is where I think the issue might be.

http://wiki.micasaverde.com/index.php/Leviton_Scene_Controller


(Bruce) #25

Have you pressed Configure after pairing? At one point that was necessary to tell the device to treat the four buttons the correct way. Also, be sure to factory reset the device after exclusion (hold 1 and 3 down for 10 seconds until red blink – I think – read instructions). It took me multiple attempts before I was successful. Also, either use a minimote right next to the device for inclusion, or include right next to the hub.


(Ian D) #26

Yes, I did press Configure and the ST hub did see the device as a Z-Wave Remote. After it is configured I go in the IDE and switch it to Brian’s custom device. From then I can use the first button, the other 3 don’t fire anything.

I also did the factory reset multiple times and I did do my pairing with the ST hub just a couple of feet from the device. I can repeatedly exclude and re-include the device and make the first button, but only the first time I’ve installed it I was able to use buttons 2,3,4- but then button 1 was not working.


(Brian Dahlem) #27

Hey @reward72 and everyone… I just merged a few changes submitted by @dmazzoni in the github repo a looong time ago that might fix your problem. When you do a factory reset of the VRCS4, it messes up the associations inside the switch, the device type code should now take care of that.

I also just updated the smart app… it stopped responding to button presses for me. I had to change line 150 to use evt.value instead of evt.data


(Ian D) #28

I’ve update both the device type and the smartapp to the latest version in github and still can’t make any of my four VRCS4 work. I do the factory reset (holding button 1 and 3 until it flashes red) and try to re-assiocate the device (holding 1 and 3 again until it flashes amber) and all I get is a “Z-Wave Remote”. If I change its device type to the custom one or to a Z-Wave Switch I can then use the first button, but I can never make the other 3 buttons work. When I look at the logs in the IDE nothing is fired at all when I press those buttons.

I must be doing something wrong. I have not tried switching the breaker off for a few minutes after reseting the device, is that really necessary? Maybe you can post step-by-step instructions here on on github?

I hope these devices will be supported with the new hub…

Thanks for trying to help, that’s much appreciated!


(Brian Dahlem) #29

The Z-Wave Remote is a good start. You change that to the custom device type Z-Wave Scene Control. Make sure to press the configure button for the device on your phone. That tells it to associate button presses with the smart hub. After that you should see button presses in the logs.


#30

Where is the configure button? That’s not the one in the IDE?


(Bruce) #31

No, it’s a tile in the preferences for the device in mobile app. Press gear on device, then press Configure tile.


(Ian D) #32

Maybe that’s where my problem is. Nothing seems to happen when I press the Configure button. Actually now that I think about it, with over 100 “things” in my hub, I don’t recall ever seeing anything happen when I press the Configure button on any device that I have. What it is supposed to do? Maybe I should read the manual… :smile:


(Bruce) #33

It sends some configuration commands to the device. In the case of the VRCS4 these commands tell it that it has four scene buttons. You won’t see anything happen unless you watch live logging. In the live log you should see the configuration command sent and its response from the device.


(Ian D) #34

Good to know! Thanks Bruce. I will try it out tonight.


(Ian D) #35

That was it!! Pressing the Configure button made my three VRSC4 work!

Suggestion to ST: Have the Configure button give some feedback. A simple popup dialog saying “Device was configured” or something like that would make quite a difference in the user experience. I really thought that button was doing nothing.

Now… If we can make my two VRCZ4 work… but I guess I’m pushing my luck :smile:

Thanks again Bruce for enlightening me!


(Bruce) #36

Glad it works. Bear in mind this is a custom device type developed in the community, by @bdahlem. At some point in the future the device type may be able to use a fingerprint so that ST identifies it automatically; in that event, the configuration would become automatic.


(Ryan) #37

Thank you Brian for all your effort on this!

I have the switched installed and working via your apps. My goal was to use this as a switch to control 3 other Leviton switches (VRI06) plus the existing hardwired switch.

The challenge I’m having is that I can’t even get the hardwired switch to work properly! From the app it works perfectly, but the VRCS4 top button will turn the light on but not off.

Any idea what I’m doing wrong?

Thank you!

  • Ryan

(Chris) #38

Some of us are having the same issue with the Enerwave scene controller. The running theory is that ST throttles / de prioritizes apps after awhile and they miss the first press of the controller after it has been unused for awhile.


(Brad Knight) #39

Would you be able to give me specific directions on how to assigning the buttons to specific devices and apply actions?


(Alek) #40

Just curious if anyone was able to get the dimmer buttons to work.