Leviton VRCS4

The SmartThings Z-wave implementation is broken at the moment.

Device handlers can send AssociationGroupingsGet() messages, which the handlers use to determine how many buttons are to be set up, but the SmartThings platform is not providing the AssociationGroupingsReport() to the handler.

Sniffing the Z-wave network I can see the packets arriving at the VRCS4, and I can see it responding to the correct address of the hub. The SmartThings Hub is then not propagating the message up to the device handler. It is not fully broken because I can see where a ManufacturerSpecificReport() is being received from VRCS4 upon request.

There may be a hack around this; the handler could send association and scene configuration based on an assumption about the devices characteristics.

FWIW my hub is on firmware 000.027.00009.

Until SmartThings fixes the above issue, no handler that configures itself via this API is going to work.

1 Like

Tagging @Kianoosh_Karami

Also,… any device which was installed/configured when the driver was working, aka before AssociationGroupingsReport() was broken, should continue to work ( looking at my own logs, I see that if the device is properly configured then it still works with the SmartThings Hub).

1 Like

I am looking into this.

1 Like

Found the root cause. Will fix in the next release, that should be out in the upcoming weeks.

Apologies.

The issue should not happen if the communication with the device is secure (using S0). I cannot find any other workaround for time being.

1 Like

Thanks @BrianAker and @Kianoosh_Karami to make the situation more understood, I really apreciated.

@Kianoosh_Karami , is there a way while including the device and seting up DHT and SMARTAPP make the communication unsecurity to make the device work propertly now?

Or, there is a way to downgrade the hub firmware?

Or there is no way to fix it and we need to wait to new hub firmware?

Thanks again

I think a single device driver could be written for the zone and scene controller. Both devices send SceneActivationSet() to whatever device is associated with the button/group being actived/deactived, so other then providing the expected response ( which may be the same for both devices ), the two devices as far as the Smartthings hub is concerned are the same. The exception is that the Zone controller sends out the off command ( and the SceneActivationSet() ) in I believe all cases when another button is selected ( if the Hub is in each group ).

The setup for both devices is the same.

1 Like

When will this be fixed? I had a switch that I had to reset and now i can’t re-add it.

Hi @Kianoosh_Karami , some news about deadline to fix it???

0.28.11 firmware was released for all 2015 and 2018 SmartThings hubs. This issue should be resolved for the hubs using that firmware, please let me know if you are still having issues.

Thank you very much @Kianoosh_Karami , it has worked perfectly. Now I will can keep my smartthings… thanks again

1 Like

(any idea when this firmware update will roll out to Samsung connect home devices? Or is there any way for me to force the update? I am currently on firmware version 000.027.00010)

That’s the most current firmware for that hub model.

The firmware for the Wi-Fi mesh model is different than for the standalone model, so they are on different development paths.

Hey Brian,

Thanks for all the work you’ve done for this device. I just got my Leviton VRCS4-M0Z Vizia RF + 4-Button Remote Scene Controller and tried setting it up.

So far I have done the following:

  1. reset the device to factory defaults
  2. successfully added it to my smartthings a ZWave Remote
  3. in API, added a new device handler with the code from your github, “Z-Wave Scene Control”
  4. in API, added a new SmartApp with the code from your github, “VRCS-Button-Controller”
  5. changed the device type from remote to scene controller
  6. assigned the 4 buttons to actions in the VRCS button controller app

However, now when I go to the device, it only shows “Button -standby” instead of all 4 buttons.
Does anyone know what I may be missing?

Current state of device in app:

SmartApp installed:

Thanks again!

Hi, I think that you must use the OLD APP, not the NEW ONE to set-up your devices.

Thanks, Mauricio. I did try it with both the new and the classic app. same result :frowning:

My VRCS4 devices show only stand by too. It is normal…

I am using DHT and smartapp developed my MPK , you can find it here Leviton VRCS4

For me is the best DHT and SMARTAPP for VRCS4 devices.

Try it, and after install set up the smartapp using the CLASSIC APP.

Good luck

MPK’s DHT and smartapp are not for VRCS4 (scene controller). They are for VRCZ (zone controller). different product. Has anybody had luck with bdahlem’s DHT/smartapp ? i am able to get button 1 to toggle lights but I can’t get button 2/3/4 to work. With MPK’s zone controller, I couldn’t get even button 1 to work.

I have the opposite problem (as do many others according to replies on this thread). For my situation, the first button works, but the other 3 do not. I saw @bdahlem and @dmazzoni talking about conflicts with VRCS4-M0Z vs MRZ. The code that Brian developed may only work for the scene controllers with a load (MRZ). Dominic was trying to setup an M0Z (no load). I haven’t figured out yet if they resolved these conflicts…

I had this same issue. Then i messed around with different device handlers and smartapps… now i can’t even get the configuration i had before where button 1 was good.