Leviton VRCS4

There are lots of options Since these do not control the current to the deviceS. You have to have a smart device at each location (a smart bulb or a smart switch or smart inwall relay). Then the button on the zone controller send a message to the hub which sends a message to however many of the smart devices you want to include.

Some of these are Mains powered, some are battery powered, but there are quite a few that can work in this set up.

Start with the buttons and remotes FAQ and see if there’s anything there that you like. That FAQ was intended to have only one or two posts per device, and typically that post has a link to a discussion thread about it

If you have any follow-up questions about a specific device, either post it in the discussion thread or Start a new thread of your own and ask. Thanks! :sunglasses:

FAQ: Full list of buttons and remotes confirmed to work with SmartThings

Hi, I noticed that when the vrcs4 worked fine it showed in current states four button, now it shows only one button. It looks strange because when we add it to smartthings it shows this way, after change the device type it keep showing this way.

So I am at the configure part and hit configure but dont see a response from my device in the live logs. I also can only see the first button. Nothing else is showing up.


Hi Immerd

I have contacted smartthings support and them told me that our device is not compatible with SMARTTHINGS, then them told me to contacts developer support, I have done it and them told that them can´t help too. Them told me to develope my own device handler. It is looking that SMT is not caring with our problem. I have no time and I don´t know too how to develope a new device handler. I am trying to hire some one to develope this to me because I have 5 VRCS4-MRz and spent more then $500 plus taxes to import it to Brazil, how I have this spent for me is better pay to develope than throw them away.

Anyway I will post here any news, please let me know if youn have some solutions too. Maybe we can help each other.

I have 7 of these working with the current smatthings wifi hub with and without the internal relay. There is a currently working device handler and mapper app available. I sent these up using the classic app but they work in either app once configured. You have to pair the device using the standard documentation by pressing buttons 1 and 3 and holding until all lights blink orange and then scan for new device in smartthings. You next go into the IDE and change the device type to the one noted in the attached pics. You next load the mapper app and run through the button configuration. To make the internal relay work you need to pair that as a separate device by hold buttons 2 and 3 until all lights blink orange and then scan
scan for a new device in smartthings. I have attached pics of the IDE info for my Kitchen in and out 4 button switches (out has a relay controlling the exterior porch light. I also attached pics of the device handler name and mapper app name so you can search for those in the community blog. Good luck, these are work quite well and are very responsive now compared to using the remote button configuration that was first available many years ago. Funny, after I went through a divorce I finally got these to work very well… the WAF isnt an issues anymore and now they are working better than ever! go figure!


1 Like

Hi Michael

Thanks by try to help, but your dht and smartapp just recognize the first butoon too. I don’t know what happened, but since I bought the wifi ST hub the vrcs4-mrz works just button 1.

Look my device, it is different from yours. Yours show numbutton 4 the mine not.

Reset the device, put in pairing mode, scan from the classic app, once connected go nk into the ide and change the device handler, then install the mapping app. I have installed may of these on 2nd gen hub to current wifi hub… make sure you reset the device. What error are you getting in the mapper app? If you dont change the device handler the mapper app will not let you save your configuration changes.

For the “Z-Wave Scene Control” device driver, the device will only associate itself with what it believes is the number of available buttons ( so if you only see one button, then that is all it is associating with ).
Hitting configure should cause the switch to associate all four of its groups with the Smartthings Hub.
The driver only calls associationSet(); it never calls associationGet to see if the associationSet occurred. The reason you don’t see any traffic is because drivers doesn’t generate any traffic from the switch to the hub ( at least in the driver that I looked at ).

Hi Michael

Thanks again by the answer.

I have tryied to reset the device a lot of times. I am out of my house now I will be back on monday, I will try againnand let you know. I really apreciated your help.

This is insane. Im wondering if there are some that just dont work. I am seeing many people wiht only the first button working. I cant get past that. Ive tried about 6 device handlers and 3 apps and nothing works. configure doesnt do anything. Any suggestions before I send it back?

can you control scenes instead of devices , like if you press button one run scene " goodnight " ?

I have 7 of these working

The Leviton VRCS4 and the Leviton VRCZ4 are different devices which use different Z wave commandsets. It just isn’t possible to use the DTH for one with the other.

This thread is about the S4, but the code that you linked to is for the Z4.

If you can post a picture of the devices you have working, we can tell you which model they are as they have different button types.

Third-party sellers, particularly on eBay, often sell these under the wrong name. But here you can see the official pictures showing the differences.


The VRCS4, which is a scene controller, allows only one button to be active at a time. You are supposed to be selecting between scenes which use the same devices.



The VRCZ4, which is a zone controller, has an Independent on/off state for each button.

So I have two VRCS running on the original device handler and app at the top of this thread. One of them, which has worked for years, stopped working at some point over the last week. I tried excluding, factory resetting, and setting it back up, using both the original device handler and the later one in this thread, and I can see the button 1 press but no others. The other VRCS works fine for all buttons.

Any ideas for how to fix this? I’ve tried resetting a bunch of times, hitting configure a bunch of times, etc.

@JDRoberts I have both versions of the VRCS4 with and without relays. They are all setup using @mpk Device Handler & Button Mapper app on a Smartthings Wifi hub and yes these are all VRCS4 versions (the scene controller) and they do work with the Zone Controller Device Handler. This is the best working (smoothest operation) configuration I have found and the lights are quick and all buttons work and are configurable to control pretty much everything in the house. The ceiling , pendant, and table lights are all Hue controlled with a V2 Hue bridge. The dimming is slow but we do not use that function much but it does work. I made some short videos showing the button operation and lights working but I can’t figure out how to upload them to this site as it says they are non supported file types “mp4”. See attached pictures.


1 Like

HI Michael

I have done exactaly what you said and now my device on the IDE show this way.

Just after config the mapper app it showed * button1: 3B

  • button2: 1C,1B
  • button3: 31
  • button4: 24

But unfurtunally it just recognize yet the button 1 , and always show : Current States * [button]: default

I have pressed all buttons , starting by the first on the top. It looks like if the DHT only recognize the first button, the others 3 logs show just “Keypad TV button was released” never pressed.

IF you have another try, please let me know. Still looking for some solution.

Yeah, I’ve been getting annoyed lately too by how slow the dimming (still) is on my VRCZ4 DTH. (I’d already sped it up in the past.) It’s a pretty simple tweak to adjust the ramp rate – happy to talk you through it, if you like?


Michael Philip Kaufman
234 321 9090

Have you developed your own DHT and it is working for you. Could you develope one to solve the problem that we are finding in our device recognize just buttom one? Could you make it pay for use or say a price that we could donate and you could make available for everyone that needs it.

Since now I apologize if I expressed myself in wrong way, my english is not so good, but I think you understood what I mean.

Others seem to be saying that my DTH is working for them with the scene controllers (VRCS4)…no?

I don’t think so, look Brian has reported thar his device stop working too.