Leviton DZ6HD Switch - How to detect firmware version

I have several DZ6HD switches. I want to verify that I am running the latest stable version.

I tried to get the version information from the SmartThings cli (used the -y option). But it doesn’t seem that SmartThings publishes the version. Do I have to write a custom driver to extract it?


Good question to which I do not have a good answer.

As long as the IDE is available and providing you haven’t updated the device firmware since it joined your mesh, you can get it in the device page in the IDE.

You’ll see it in the Raw Description field. That seems to persist even if the device has auto-migrated to Edge. Unsure if it will be available if you paired it directly to Edge.

Thanks so much, I forgot about that IDE.

Mine state firmware is 1.20. Hopefully, that’s the latest.


Firmware details available here:

V1.22 is latest for the DZ6HD.

1 Like


The OTA files aren’t usable for SmartThings since, of course, it doesn’t support ota updating of Z-wave devices. Motivated me to send a question to Leviton as I couldn’t find the hex files.

It doesn’t, but you can pair a USB Zwave stick as a secondary controller and update it in place. I updated an Inovelli and Zooz switch this weekend using this method.

1 Like

Yes. I think we’ve had this conversation on other threads. Using a stick as a secondary controller within the SmartThings mesh will work for some situations and some brands of devices.

The article below is for Zooz but mentions files with .hex, .otz, and .gbl with Simplicity Studio.

Are the .ota files linked above the same with a different name or are they using a different packaging?


.ota = uncompressed
.otz = compressed form of ota

PC Controller accepts .hex, .ota, .otz, .gbl.

1 Like

It occurred to me that the last time I was able to do a firmware update using a secondary controller was when the (old?) app supported the Z-wave “replace” operation.

I think @krlaframboise has confirmed that Zooz devices require a reset after a firmware update and so will never correctly update using a secondary controller.

Very possible for some types. I did a ZEN71 this weekend and it worked fine after the firmware update.

1 Like

Good to know! It’s been a couple of years since I tried. And my Zooz devices are all from their previous generation.

Thanks for all your help.

My situation is Leviton devices and I have a MAC or RaspberryPI platforms not a PC.

Is it possible to upgrade the firmware or do I have to pull out my soldering iron :slight_smile: ?


My knowledge is pretty limited but I’ve not seen any mention of software that will let you update firmware on a Z-wave device from a Unix or Unix-like platform.

Might need to find a friend with a Windows laptop who can come over for a visit.

Some of their device automatically factory reset after updating, some can sometimes have random issues if they’re not reset afterwards, and others can be updated without having to reset them, but after updating 100s of devices I’ve found that it’s a lot less frustrating to just always factory reset them.

1 Like