Leviosa Motor Shades - Custom Motor Shades now fully SmartThings compatible

Greetings. I recently installed Leviosa Blinds and was eager to automate them with SmartThings.

I’ve added the groups and can trigger them “manually” with the SmartThings app. However, I cannot setup a custom automation.

I go through all the steps, setting the time etc, when I get to the step of what device I want to trigger, the shades are not in the list… not under the room listing or the A to Z listing.

Can anyone assist with this? I wrote Samsung and their reply was “Leviosa shades are not supported” which is a nonsensical answer.

I called technical support and they suggested adding the Samsung hub “might” help. The certainly sounded unsure. Frustrated.

You say you can manually open and close them with the new app. So you have the ST app linked to your Leviosa zone?

If so you should be able to create a custom automation to open or close at a specific time. I just looked in the new app on mine and when I select devices I can then select any of my shades.

I don’t use the new app for automations per se myself, I have all my automation setup using webcore and virtual switches. When I first got my shades the new app caused me a great deal of problems. So I avoided using it as much as I could. I setup the virtual switches and have automations in the new app that open and close the shades if the virtual switch opens or closes. I then control the virtual switch with webcore and the classic app.

With the new device profile (required by ST), some users have had to unlink and relink their accounts so automations can work. We PM’d you directions - here they are for the group, starting at ST homescreen:
• Add device (the + sign, upper right)
• Select “Leviosa Shades”
• Select ‘Other” (will soon be ‘window treatment’ we are told, as it should be)
• Skip locations, select Next
• Select ‘Done’ on Account linking page, since you are already linked.
• Select DENY on next page, and EXIT
• You are back at account linking page. Select 3 dots on upper right. Select DELETE, and confirm Delete to remove the App.
• Select Other
• Choose locations, select Next
• Select Link Account, and enter Leviosa App email and pw
• Go back to main menu – the icons for your groups appear.
• Now add Automation. (‘+ custom automation’ at the bottom on screen)

Complete setup of automation – your devices will appear.

1 Like

Update: With the new device profile, commands have been change to simple ‘raise’ and ‘lower’ so pre-set positions are now enabled. For automations, a user can simply set double commands (say, a minute apart) to pass multiple pre-set positions.

For users who do not utilize pre-set positions, the shades will simply travel all the way up or down with a single command.

I followed these instructions with no success.

I will note that the instructions say to “skip locations” but this option does not appear in the app. So I went on to the next step. It seems like the instructions don’t quite match the app.

I have the same issue as Scott. I.e the shades are not showing up in scenes/automations. Without that the ST integration is quite useless.

Also, I’m using the classic app. Is there a workaround to make it work in the classic app? (although it doesn’t even work in the new app automations)

Hi Scott-
As we noted in PM, ST acknowledges the issue with iOS where the devices are not populating correctly. We will advise you when the issue is resolved.

This is only an issue for iOS - the Android version works properly.

Hi Am4ture-

ST acknowledges the issue with iOS where the devices are not populating correctly. We will advise you when the issue is resolved.

This is only an issue for iOS - the Android version works properly.

Leviosa is not listed in the Classic App per guidance from ST. Leviosa is listed in the New App which ST states is the future platform for ST.

Hi Tony,

I am currently using an android device with the new smartthings app and I am having the same problem as the people above. I’ve tried following the directions to unlink and relink the accounts, but there is no change. The shades also say Checking Status… forever and never update. They are unavailable on the automations screen.


HI Nate-
Thanks for letting us know, and we will look into this. We have a new Leviosa App update planned this weekend for both Android and Apple that should address this issue.


In the ide that shades are coming up as Type placeholder - I’m assuming this is not correct. Do you know what type they should be? This may be the problem.

This is expected behavior for new cloud integrations.

Ok thanks.

Tony - can you post here when the app is updated so we know when to try again?

You can add me to the list. I just added a 5th shade today. I use virtual switches to control the shades so that I can use the classics app to control them. The first 4 still work, but the one I just added does not, it does not show up in automatons so that I can use it with a virtual switch.

It has a nice Shade icon that will open and close, but only if you open and close it with the new app. It will control the shade. If you use the remote or the Alexa skill to open or close the shade it’s state is not being reported back to the new app. I don’t get the metadata error, that I noted in an earlier post when opening the Guest room shade. I still get it when I open the shades I added earlier. I thought about removing and reinstalling everything but I am glad I came back and reread this. I think if I do I will then have none of them working with ST.

See screenshot below. The dining room device is a Leviosa shade. That shade works the Guest room does not.

We released the new Leviosa FW and new Apps today (iOS and Android) on schedule, but these will not impact ST functionality.
Samsung’s code freeze was removed recently after its Developer Conference (SDC wrapped up 10-30-19) and they have now deployed a change to production which improves users’ experiences. Leviosa will be updating its device profile to meet these changes in the next few weeks. They have also introduced a new schema for cloud-to-cloud integrations such as ours. This should facilitate onboarding with faster execution commands (almost 400 ms faster!).

We applaud Samsung’s commitment to improving the user experience, and we will be updating Leviosa Zone device functions to meet new ST requirements shortly (estimate is 12-1-19).

1 Like

Please see the update we just issued in this space. And we will continue to provide updates as we meet new ST requirements.

Ok. Finally things are running smoothly and I can control my Leviosa shades with the SmartThings app. What I have yet to figure out how to do is group shades or add them to any automations from within the ST app. None of the automation workflows display the shades as devices that can be controlled. What am I missing?

I don’t think you are missing anything. Apparently they are still working on getting the shades fully compatible with the new app. I currently have 5 shades and 4 are integratedish with ST the last one I ordered I can only control though the Leviosa app. Apparently the shades I set up earlier use a different DTH. Not sure what the difference is and I have been hesitant to play with them as I don’t want to mess up the 4 I have working.

I can control the first four by using automations in the new app to raise and lower the shades based on virtual switches. I can then control the virtual switches with webcore . I cannot, however, create a automation for the last shade I ordered. Like what you are seeing it does not show up as a device I can tie an automation to. Hopefully the update they mention about 2 post up will fix this.

1 Like

Does Webcore work with the new one?

No, as I said the new one does not show up as a device I can create a automation for. Just as you are seeing.

Webore cannot directly control any of them. My older ones, however, can be controlled with webcore. I have to setup an automation in the new app to lower and raise the older shades based on the state of the virtual switch. I can then control the virtual switch with the classic app and webcore.