Laundry Monitor

@bmmiller I just hooked up the Aeon Gen 6 to the washing machine and my wattage was anywhere from 4 to 72 when running the wash. I set the app up this way but it never sent me a notification. I am using your device type as well and I noticed every 5 minutes it polls and reports unless there is a no change. When my wash stopped, it said 1kw and never reported again.

Any ideas?

I wouldn’t use my device type as it got replaced by one that had proper documentation made by @jpansarasa and I didn’t bother updating mine. Looks like he even has a new version with added functionality. Yay!

Thanks. Your device type ended up working with Rule Machine, but I will update to the latest Device Type anyway as it can’t hurt.

@mattjfrank,

I have the aeon heavy duty power sensor physically installed like you show above and linked to my hub using the device driver supplied by @jpansarasa. However, I am not getting regular updates on the power usage.

(I also have the light duty one attached to the washer and it works as expected.)

If I look under the Recently tab of the device in the iOS SmartThings app, all I see are entries that are triggered by pressing the Refresh button on the Right Now tab. Do I need to do anything special to get regular messages to show up with the current energy values on their own without me pressing the refresh button? (In the settings, I have the report interval set to 1 (minute)).

Any thoughts?

TIA,
Matt

My recently is blank always has been. But I get the alerts from Laundry Monitor

Interesting. My alerts work for my washer but not my dryer. I just assumed it was a device issue, not a smart app issue.

Mind sharing what settings you have in the smart app for your dryer? I currently have the minimum running wattage at 50 and minimum amount of below wattage time to trigger off (secs) set to 60.

I will try to delete the smart app and recreate it in case something go screwed up there.

I just set this app up and it appears to be working. I did the first load of laundry and was notified when it finished. However, I enabled both Push ash and SMS notifications. I received the SMS notification however no one linked to my smartthings account received the push notification. Any idea on what could be the cause?

This is a v2 hub that was a clean install. I am receiving notifications from other smartapps, such as one for my door lock.

The default behavior of the code reads that if you specify an sms number, it doesn’t send an app alert. If you want both but aren’t familiar with what change to male to the code, I am happy to post it tomorrow. (I also added a second sms number to mine and changed it to do anything that is specified for the times that I want both sms and app alert.)

Ahhh that makes sense. I just looked at the code and saw it. I’m a novice at programming (thats even a stretch), but I figure I just need to modify the notifications section as such:

if (phone) {
                    sendSms phone, message
                    sendPush message
                } else {
                    sendPush message

However, I would be interested in hearing how you got it to accept two phone numbers!

@Jnick try below below 2 updates…These codes are from the members in ST community…

input "phone", "phone", title: "Send a text message?", required: false
 paragraph "For multiple SMS recipients, separate phone numbers with a semicolon(;)"


    if (phone) {
        if ( phone.indexOf(";") > 1){
  			def phones = phone.split(";")
 			 for ( def i = 0; i < phones.size(); i++) {
			    sendSms(phones[i], message)
 			 }
   			} else {
  			sendSms(phone, message)
  			}
    } else {
        sendPush message
    }

To make things easier for everyone, I’ve added the changes discussed above to the main app.

You can now push and SMS simultaneously, as well as add multiple SMS recipients. Since I don’t utilize SMS, let me know if something doesn’t work.

Looking for any suggestions for why my set up is not working. I am using the DSC06106 switch with bmmiller Laundry Monitor (Latest from github). I am using elasticdev : Aeon Labs Smart Switch (2nd Edition) for the switch handler but I have also tried the default as well as the bmmiller hanlder as well. The device is monitoring usage properly in the log and drops to 0 but I never get an alert. I tried adjusting the wattage levels between 0 and 8. I also tried removing the device and smartapp and re-adding but it still hasn’t helped. Any suggestions for what I am missing?
Thanks,

Are you using push or SMS. If push, do you get other push notifications from SmartThings successfully?

Also, what is your setting for “Minimum amount of below wattage time to trigger off (secs)” ?

I am using push. I also tried SMS but it did not work either. I do get push notifications from Smart Alarm as well as Rule Machine.
This morning I set up ‘Yet Another Power Monitor’ and as I am writing this I just got an alert through that for the washer so that should work for me. Still not sure why I couldn’t get your app working properly but thank you for the reply.

Also, what is your setting for “Minimum amount of below wattage time to trigger off (secs)” ?

I tried 8, 6, 4, and 0.

During the last couple minutes of the typical cycle my washer goes from 7 to 6 to 0

I’m asking about time, not the wattage. There is a second setting immediately below the minimum running wattage setting. If your washer hits 0, you should probably go with 2 on the minimum wattage, and something like 60 for the time setting.

I’m sorry. I left the time at 60 seconds

Got it. Yeah, that should be fine then. Not sure why you’re having an issue, maybe try delete the SmartApp and setting up fresh again.