Konnected devices not available to ActionTiles and WebCoRE

I received, and installed, the new version of Konnected Alarm Panel 2 and Alarm Panel Interface. The new install procedure uses the Konnected cloud to interface to SmartThings. I was able to program all the zones (11 zones total, and a Key Switch and they are all available in SmartThings. However these devices are not available to ActionTiles and WebCoRE, which is the main reason I went with Konnected. I am almost sure it is because the Device Handler is not built correctly.

If I click on any of the devices in SmartThings and then go to Settings for the device, I get this:

If I go into IDE and look at the properties for the Device I get this:

The Device type is “placeholder”.

I am reaching out to Konnected, but thought I would also post here to see if anyone has any ideas on how to fix this.

You may want to use the new SmartThings app instead of the Classic app. On my integrations using the cloud-to-cloud integrations, I can not see the settings page in the Classic app but can in the new app.

Placeholder is the correct type you will see for all new could-to-cloud integrations from the new app.

As for webcore, in settings > available devices > available devices > look under select devices by capability and group 1-3

I can not answer on ActionTiles.

1 Like

I cannot speak to the cloud-to-cloud. But once you get your devices showing up correctly in ST “devices”, then you can add them to the ActionTiles app within ST just like you do with webcore.

Thanks @jkp, @Pantheon. I followed the advise of jkp and I was able to add the devices to WebCoRE. Then when I searched around on ActionTiles, I was able to find the devices. They were not in the main section, but I was able to find them. Problem solved.

Did anyone get their native motion detectors (from adt) to show up in webCoRE. It shows up in smartthings correctly. All of my other alarm components do surface to webCoRE

Look in settings > available devices > available devices > select devices by capability > capability group 1-3

1 Like

Thanks - got it. Just switched over the the Konnected cloud platform— so far so good. I did have to manually update firmware on each of my modules first. But the response time somehow seems quicker.

@jkp, are you sure about this? All of my devices are offline. I don’t need to change the device type to Konnected?