Kasa and ZooZ Zen34 switch all stopped working yesterday

After years of no problems, all of our KASA switched outlets and our ZooZ Zen34 switch all stopped working last night. In the SmartThings app they all show offline. Any advice as to how to restore them all? Thanks

For the Kasa devices you can use the following Edge Driver or the official cloud to cloud integration.

For Zooz you need to install the official Zooz driver for the Zen34.

I have the same issue with the zen34 remote switches. All 3 were working fine until recently.

I even tried excluding one of them and reinstalling it from scratch. It appears to install successfully, but when you go to configure it, it says it is still updating device properties for a while, and then after a little while it goes to the same “offline” status.

FYI, when it is in that “offline” status, the driver option is grayed out.

I seem to be fixed thanks to the suggestions from @Paul_Oliver (thank you). For people that see this later- I had to

  1. install the TP-Link driver on the smarthings hub (as Paul said above)
  2. install the Zooz driver on the smarthings hub (link below)
  3. delete all TP-link/Kasa devices. Remove the TP-link associated service from smarthings
  4. upgrade all TP-link/Kasa firmware via the Kasa app
  5. add TP-link back using the smarthings app- it’ll suggest adding all TP-link devices.

here is how to install Zooz to the smarthings hub
How to Access Advanced Settings for My ZEN34 Remote Switch on SmartThings - Zooz Support Center


1 Like

So this must be a widespread issue then. I have two Zen34’s and the last time they both worked was Thursday last week, and both stopped working the day after that. Showed up as offline. Removed, re-added and even factory reset one of them. They just show up as “Z-Wave Device” with no events to write routines against. Somebody broke this!!!

You need to install the Edge Driver for the Zen34 on your hub using the following link.

Once you install this driver you can switch drivers using the mobile app.

Unfortunately that’s not working. I’ve been going back and forth with Zooz and everything is set up the way it should be, ST just won’t let me assign the correct driver.

I’m so frustrated with this.

What Zooz model is giving you problems?

1 Like

Sorry, that would be helpful info to put in my post!

The ZooZ Zen34 switch. I’ve done the works. Factory reset, went out and bought an Aeotec hub, literally everything I could think of. Drivers are all installed. It’s so incredibly frustrating because of what I use the switch for. :frowning:

I have a Zen34 and it works good with the Edge Driver.

I am not sure what you have done to date. I would do the following:

  1. install the “Zooz Zen34 Remote Switch” Edge Driver from the link below.
  2. Exclude the Zen 34 right next to your hub.
  3. re-pair the zen34 right next to your hub.
  4. relocate the zen34 to where you want to use it.

Yep, I’ve done all of that with both my V2 hub and then I went out and got an Aeotec just as a last gasp effort (I figured I need to get it anyway as a thread border).

I get errors that the device hasn’t updated all its status information. When I try to do it online with the advanced app, it says the fingerprints don’t match. I’m at a complete loss.

EDIT: And thank you for your help!

Here is the fingerprint (027A-7000-F001) from my Zen34 does it match yours?

Yes! That’s exactly what I have, it just won’t let me switch from the default “Z-Wave Switch”

I go to the drivers on the advanced web (it shows “no results” for drivers on the app)

It’s defaulted to “Z-Wave Switch”

I go to the drop down, select Zooz ZEN34 Remote Switch

A red banner at the top says, “Error changing device driver to “Zooz ZEN34 Remote Switch”. Ensure that the driver you are trying to change to has a valid fingerprint match with this device”

Screenshots attached

It’s driving me nuts :frowning:

Have you tried making the driver switch using the ST Mobile App or the API Browser+?

Yep, same results. I either get “api browser plus pinsky.us says Driver change failed with HTTP error 400” on the API

Or just these in reverse order (couldn’t do it right), it just shows that I have the driver selected when it is randomly connected sometimes and when disconnected, but I don’t have any drivers available when it’s online.

It’s just driving me crazy at this point.

Sorry I am out of ideas

You put a lot of time into responding over and over, with different ideas I really do appreciate it!

I am having the same issue with one of my Zen34 switches. I have two, I was able to assign the driver to one of them with no problem and it is working great. But, when I try to assign the driver to the second one, I get that same error: “Error changing device driver to “Zooz ZEN34 Remote Switch”. Ensure that the driver you are trying to change to has a valid fingerprint match with this device.”

If I try to set the driver in the mobile app it says no drivers found. I really wish that SmartThings would just let me override the driver.

One thing that may be different in my case is that the Manufacturer Code for the device that isn’t working is showing up as 0000-0000-0000. I’ve excluded and reincluded the device several times, and no change to the results.

It will never work with a Zero fingerprint. You need to exclude and repair it until you get a real finger print. Do your exclusions and pairings right next to your hub.

Thanks, Paul. I tried a couple of more times (excluding and re-including) and it finally came in with the correct manufacturer code. It is working correctly now. :slight_smile: