June 2019: August Pro Z-Wave commands fail if August app is not in use (previously worked fine)

Hi I also request the downgrade and they did it because I already have the WiFi bridge I like to have local integration rather than cloud to cloud. After the downgrade remove and add again to the z wave network the locks are working.

Has anybody else had the issue where their doorsense stopped working after they downgraded their FW to get Zwave working?

Ever since I downgraded 3 months ago, my Zwave connection has been rock-solid, however doorsense has stopped working. When I go into the lock settings to enable doorsense, on Android it doesn’t let me get past the first step of calibration, and on iPhone, it says calibration was successful, but DoorSense still does not get enabled. Anyone else have this problem? Or know how to get around it?

Has anybody been able to get their firmware downgraded recently? Is it still working?

I contacted the customer service but they refused my downgrade request claiming it would not solve the problem.

I switched to the cloud integration.

I have been able to get the firmware downgrade from August for my Z-Wave Lock Pro Gen.3

I did so about a month ago (~15-Jun_2020). I had been sitting on the lack of function since May, but it took me a while to have time to fiddle with the lock. I use the Z-Wave lock via ST without Connect. August was very helpful. I described the loss of function as others have in this thread, August acknowledged the issues and initiated a firmware rollback. They then advised that they would fix the firmware from their end so it would not be updated and break functionality. At first I was not able to see the firmware version. I was on 1.59.0-1.13.2. Now the firmware shows UNDEFINED-1.59.0-1.13.2.

Once the rollback was initiated, my ST functionality returned. No problem locking/unlocking. I also recovered Alexa functionality both via the app and voice. As long as there are no autolock/autounlock routines Alexa voice commands will work.

I am using the August Lock Pro Zwave Lock with Doorsense device handler and have not noticed any problems with battery discharge.

Hope this helps!

Looks like the latest firmware (UNDEFINED-1.59.0-2.0.1, released on 9/25/20) is working fine now.

Thank you for letting me know, I might try to upgrade but for now I am happy how SmartThings and August work together
Best
Zoran

After seeing the comment in this thread about a new firmware I contacted August. I requested they remove the restriction preventing updates (since I downgraded a while ago). They had no idea what I was talking about, even after I clearly described what was going on. So I just gave up speaking to them and will remain on the old firmware til the lock breaks and then get their latest gen which is smaller anyway.

(I used to have 2 of the 3rd gen pro locks but one of them stopped working when a cheap aluminum gear broke and the company refused to sell me a replacement part or even give me a part #/specs so that I could get another one myself. It’s kinda pathetic that what’s probably a $1 part made a $200+ lock completely useless.)

same here. They wanted me to jump through all these hoops with uninstalling the app, logging in and out etc to try and update the firmware.

I am on the latest firmware “UNDEFINED-1.59.0-2.0.1” and it still does not work. August won’t downgrade my firmware since the working firmware is too old according to them. They ask me to use the Connect bridge. I don’t plan to use the bridge and will likely ditch this lock unless I can find a solution to this stupid bug. I hate myself for buying this dumb lock. Looks like they drop Zwave on the latest version of this lock, so i guess bye-bye August.

I had the firmware block put in, and never removed and things have been fine until the past week (the lock doesn’t respond to lock/unlock commands but does seem to get current status). Anyone else having this issue? I’m on the new smartthings app.

I recently bought it and facing this exact same issue. I am considering returning it now.
I run it using an Aeotec Gen 5+ stick and Home Assistant. Looking at the logs, the command to unlock via z wave goes through. Then the lock responds back with the status but the state of the lock remains unchanged.

1 Like

Hi. I know it’s been a while since anyone posted here but I found this thread after looking for a solution to the August Problem. I’ve had a August Lock Pro that I have been using for months without issue. About a month ago though that all changed and my lock stopped responding to anything after a firmware update. I just tried removing it and adding it to SmartThings several times over the last week and nothing is working anymore. It doesn’t even report into SmartThings correctly anymore.
The lock is on firmware 1.59.0-2.0.4.
And I keep getting the notice about Zwave S0 instead of S2
It doesn’t even look right in the app.

I had a similar issue a couple months ago. I reached out to August Support, and they told me to remove the lock from the Z-Wave network, then do a full factory reset on the device:

Open the August app and tap on the three-bar menu on the top left-hand corner
Choose Home, underneath Keychain, select the name of the house
Tap on Settings, followed by Lock Settings
Select Factory Reset
Please remove/reinsert a battery on the Smart Lock. Please make sure you are getting a green light on the lock (only one flashing green light)
Open the August app again and tap on the three-bar menu one more time
Select Set Up a New Device and choose the Smart Lock 3rd Gen Pro
When the set up is done please try adding the lock one more time through z-wave
Once this has been tried let us know the results.

After I did this, the lock started working again on my Z-Wave network. (note that I’m using Z-Wave JS with Home Assistant, but the symptoms sound similar enough that a factory reset might help you)

I’m also seeing smartthings not connecting to my august smart lock… has anyone else confirmed this will work? I’m worried about factory reset if it’s not the issue?

Bumping this thread up again.

As of March 2022, I am (once again) experiencing this issue on my August Pro (3rd gen) on firmware 1.59.0-2.0.4. I tried all the usual troubleshooting steps, but nothing helped. What I found out is that when I factory reset and took that firmware update, all Z-wave functionality broke. When I tried to add the lock back to SmartThings, the SmartThings app tells me that it was added insecurely.

I’ve since concluded there is an issue with this version of the firmware (since that was the only thing that changed with my device), and August has to fix this issue and push updated firmware to our locks. Others have noticed an issue with S0 vs. S2 - I also believe this is the root cause of the issue, given the error message I got about the lock being added unsecurly. For some reason, the lock is unable to connect via the more secure S2 spec (vs. the less secure S0 spec) and SmartThings no longer can communicate over Z-wave to it.

So I tried emailing and calling customer service. They said they can’t downgrade due to “security fixes in the latest update” and that “downgrading would break the device”. They said they would instead “submit a Jira ticket” to the engineering team, yet they had no ETA on when or if a fix would be available. And let’s be honest: August has basically given up on Z-Wave – notice how they dropped Z-Wave support on their latest 4th gen models, which tells me August no longer believes this feature is valuable for their customers and has removed it from their product strategy.

When I pressed for a free August connect bridge, they told me that because I’ve owned the device for 4 years, I’m outside of their warranty window, and that “the best they can do is offer me a 30% off coupon”. That’s complete b.s. to have to pay additional money just to use a lock to restore remote access when August themselves broke functionality on their own locks!

Anyways, hope this helps someone else out. If you’re still under warranty, I’d strongly calling them up now, as your chances will be better at getting a free bridge.

As for me, I guess I’ll just have to constantly call back and complain until they actually do something about this…

1 Like

I’m back.
After they downgraded my firmware to the “last known good” version (1.59.0-1.8.15) things were working perfectly. Recently things started to act badly on one of my locks but not the other.
I checked the bad lock and found that it is now running 1.59.0-2.0.4.
The working lock is still on 1.59.0-1.8.15.

I sent them an email (just like the one I sent them last time).
We’ll see if they respond. I am not optimistic.

In the worst case… I may end up having to swap out these damn locks.
To be honest, I really like these locks… except for this crappy zwave bug which is pushing me to insanity.
If they won’t downgrade me… does anyone have a good recommendation for a smart lock which:

  1. Works with smartthings (z-wave or zigbee)
  2. Shows up as a both lock (which can be controlled through the ST app) AND works as an open/closed sensor which can be used to trigger events.
  3. Supports a keypad which lets me add/revoke/control guest codes, etc.

I;m not looking forward to swapping… but if August won’t fix their stuff… I seem to have no choice.

I know you mentioned z-wave or zigbee but depending on which model August lock, have you considered getting an August Connect which uses wifi? That way, you can continue to use your current locks that you like. :slight_smile:

Yeah, I actually have two of those sitting in a closet.
I was using them initially, but was very unhappy with their performance.

Unlocking a door when you’re waiting on the other side is one of those things that you want to happen quickly. I find that the WiFi option added a lot of latency. And I’d like to keep it all local to my house/network and not have access to my house dependent on Comcast. :slight_smile:

I assume you are talking about the speed from the ST app. If you use the August app, it uses bluetooth when in range of the lock (direct connect between phone and lock - about as local as you can get) :slight_smile:

hopefullly others will give you good recommendations for z-wave/zigbee locks. Schlage locks are good.