June 2019: August Pro Z-Wave commands fail if August app is not in use (previously worked fine)

Assuming that you have a Z-Wave stick and utilities to see the routing table for each device, that the only way to confirm for sure that the lock is connecting to the repeater directly. The way most folks do it to simply move the hub away from the lock say 75 to 100 ft, put the repeater closer to the lock say 20ft, reboot the hub and do a Z-Wave repair.

However, after seeing all the comments on this topic and especially given the fact that the lock seems to work just fine after it’s woken up (e.g. manually lock it or activated from the August app), it sounds like it may be a lock firmware issue that has some role to play in it. That is very unusual behavior. You may need more sophisticated Z-Wave tools and sniffers to see what’s going on here.

Out of curiosity, do either of these devices have the connect or keypad paired to them?

Mine does have a Connect paired.

Both devices have a keypad.
Neither device has a connect.

I’m having the same problem. I had been using the lock with smartthings in “I’m Back” routing and it worked pretty well but recently it just stopped working. The routing goes off and the log shows that it unlocked the lock but it actually doesn’t. My lock has a connect that is only a couple of feet from both the lock and the hub. The lock seems to work when I try to lock or unlock it from smartthings manually but the “I’m Back” routine does everything else except actually unlocking the lock.

It sounds like your issue’s different and specific to the routine itself. In the case we’re describing all commands, whether via routine or manually, fail. This is because the commonality using ZWave to send the commands.

I’m having the same issue - the August Pro’s is unresponsive to SmartThings commands (either directly or via Routines) unless the August is somewhat active (e.g. the August app is open and Connect light goes on, or I manually lock/unlock the August in advance). I have firmware 1.59.0-1.13.2. Tested with both a Connect registered and unregistered from the account. Ticket also logged with August support.

Updated the firmware on my august pro and now seeing this :-1:t2:

Same problem, exactly as described by others.
A Z-Wave lock that no longer works reliability with Z-Wave is useless to me…

3 Likes

I’m pretty surprised we haven’t had any response from August on this yet. Surely they’ve been able to reproduce it by now, assuming they’re trying. I’d expect better but sadly know they probably just don’t care.

Anyone heard an update? Seeing the same issue and opened a ticket with August, but wondering if it is a waste of time.

Nothing here. I don’t know how they can be failing to at least acknowledge this for such an extended period of time, given how many people are experiencing it. I have to imagine that if there’s this many (on the thread here) who have taken the time to discuss it, there’s a proportionally larger subset of people who are just frustrated and curse their lock every time it doesn’t open.

Or maybe the majority is just using the terrible August app to manage lock events directly instead. Either way, the Z-Wave integration was one of the main selling points of this particular lock model and it’s totally crippled now.

And I have no idea who to ping… :frowning:

I emailed them last night. Keep opening tickets. They’re now saying it’s a known issue and that they’ve reached out to SmartThings.

Just to add a little additional info, I and several others have had the same issue with this lock paired to Hubitat. That leads me to believe that it’s not a platform specific problem and is related to the 1.59.0-1.13.2 firmware.
FWIW, I excluded the lock and did a factory reset. The firmware version is now listed as 1.13.2 (without the 1.59.0 part) and the lock has worked as expected for over a week now. Hopefully, it won’t try to update again until August figures this out.:wink:

2 Likes

Very interesting results - the factory reset is something I hadn’t considered, I didn’t think a commodity consumer product like this would have backup firmware storage. Nice test and thanks for the post!

1 Like

I was the first person in the hubitat forums to try and suggest doing the factory reset on the lock. Unfortunately, it worked reliably for about a month and then stopped working again.
The procedure was as follows
Removed the lock pairing to the hub. Did a factory reset on the lock and did a zwave repair.

So far I did this three times, the first two times each lasted about a month, I did this the last time around 10 days ago and it’s still working, so for whatever reason it fixes the lock temporarily ( approx. 30 days).

Does the firmware actually get downgraded with a factory reset and then re-upgrade itself, or is it something totally different? I guess I may as well give it a try. I had previously tested with repeaters, etc, thinking it was a signal problem or faulty devices until coming upon this thread.

My firmware shows 1.13.2 like shoot31 mentioned. I never thought to check it again when it stops working to see if it actually changes but I’d be surprised it if somehow did change as I never open the august app.

Again, this isn’t really a fix but more of a workaround if you’re willing to do it every 3-4 weeks.

Thanks. This is really helpful as at least a temporary workaround. I’ll give it a shot.

By the way, much more helpful than what I’ve received from August in response to my ticket:

A bug ticket will be filed by our Development Team in order to review the issue you are facing. If there is an update or if any additional information is required, we will reach out.

Please report back after you try, I’d be interested to see if it works the same with ST as it does with Hubitat… I’m not sure how/why it works and then reverts back to not working. Is a memory leak possible with firmware??

© 2019 SmartThings, Inc. All Rights Reserved. Terms of Use | Privacy Policy

SmartThings; SmartApps®; Physical Graph; Hello, Home; and Hello, Smart Home are all trademarks of the SmartThings, Inc.