Jasco switch won't operate


(Bob Solimine) #1

I bought a GE zw3001-wcs from a seller on eBay and I can’t get any response from it even manually. When I give it power, nothing happens until I press “on”. Then the LED lights. After that, nothing. The light doesn’t turn on and the LED doesn’t change.

Has anyone seen this? I’m figuring it’s defective but thought I’d check with the community before sending it back.


(sidjohn1) #2

Looks like a known issue with those switches and halogen lights. IDK if the bulb you are using is halogen or not… but it sounds like a replacement is in order :wink: Also from reading the thread it seams to be an incandescent only switch/dimmer, so LED bulbs may also not work.
http://forum.micasaverde.com/index.php?topic=24663.0


(Bob Solimine) #3

Dang! It’s funny. This switch is controlling the one incandescent light in the house. Thanks for confirming what I was thinking.


(John O) #4

@robert_solimine

Something to try… Just maybe the switch is at its lowest dim setting. When you turn it on press and hold it to increase the dim.


(Bob Solimine) #5

Good idea. I did try that and still no response. I did manage to get the LED to toggle on and off but the switch still doesn’t operate the light.