Jasco/Honeywell 39351 Device Handler

My 1st DTH.

Creates child device for actions with button scenes.

Note: Button release action is presented as 6x because there is no release member for supportedButtonValues

Supports:

Product is on sale at https://byjasco.com/honeywell-z-wave-plus-wall-smart-dimmer

2 Likes

I have been using this handler and it seems to work great Thank you. One thing I am trying to do is keep the dimmer functionality but remove the ramp down when shutting the switch off, is that possible? I set switch mode but then the dimmer does not work anymore.

I am also having difficulty with the associations. I have the latest tool installed and have created the associations. but don’t seem to be honored.

The settings represent what capabilities the hardware supports. From my observation in switch mode it would turn on/off immediately from the manual control, but in smartthings/zwave it would still behave like a dimmer.

For the association, what group are you using? 2 is for single click and 3 is for double. Check the data section in the groovy ide for the device and ensure associationGroup1, associationGroup2, associationGroup3 and supportedGroupings are there. The 1st 3 maybe , the supportedGroupings should be 3. Also verify groups is 3 in current states. If these are not present select “Sync Associations” from the settings in the app. This will force the updates, I noticed sometimes the device doesn’t respond to all the commands on install (not sure if too many commands). You can avoid the associations and use automations to achieve the same using the scene controller device. I personally used the associations for other zwave devices. My reasoning was in case the hub fails I would have some of the available functionality.

Please make sure you are using the latest version, I made some changes and fixed a few bugs along the way. It should work with the new app UI.

The association groups show up but I don’t see SupportedGroupings. Groups 3 does exist under state. why would supportedGroupings be missing?

I notice it seems to be setting the association for group 1 only. Even though I am using group 2 and 3, in my association group. Also it seems I have to force sync the association each time I make a new group should they be automatically synced? or is that expected?

Thanks again

supportedGroupings was a mistake on my part, its no longer used.

I found a bug that I introduced where it was not setting the association after the tool calls configure. I pushed the fix to github. I also tried to correct some cases where it may not have the associations set which would prevent it from setting the new value. Try it out and let me know if you still have trouble.

2 Likes

I have updated it seems to be working better. There are still some funky sync things but I am now seeing associations get set eventually. Thanks for taking a look!

1 Like

Thanks for the update. I just made some additional changes and added a Reset Associations option to maybe make life easier. That will set the device associations back to the initial state and then you can use the z wave tool to reset to the updated value.

Is it possible to expose these button events to work with ABC advanced button controller?

I’m trying to use the honeywell dimmers to control groups of sylvania smart lights which always have power so we can use in-wall switches as if they are normal lights.

What changes do I need to support this? It exposes the buttons and events that can be used with automatons.

I’m not sure what changes need to be made. The device handler only shows one button (I know there are different values for each press) as opposed to different buttons for the different types of clicks like the innovelli switches. I see that you also have child handlers, how do I use those? Maybe that would solve my problem.

The child handlers are not used because there were some issues with Google and Alexa integration with the new app. The intent was to use those to have reusable code.

Wrt the # of buttons, I used the up and down to differentiate the buttons since there is no real up vs down event for those. Would it work better to set it as 2 buttons and converted to use the pushed_* events?

That may help, I’m not sure. I know that the GE Jasco custom device handler, which only supports double-clicks, not triple or hold events, reports 2 buttons (one for up-2x and one for down-2x) which seems to work well.

Here is what I saw in testing

keyAttributes: 0= click 1 = release 2 = hold 3 = double click, 4 = triple click
sceneNumber: 1=up 2=down

technically 2 buttons with 5 events. Would this work for you if I change to 2 buttons? The do emit 3x click, I personally use it. The z wave associations only support single and double.

Yes, I think that would help. And btw, thank you so much for being so responsive!

I ran into a bit of a snag. To update to 2 buttons, all the examples I see require a child device. If I add the child device, I lose the assistant integration. I am not sure if the previous issue with child devices was fixed to support me making this change. That seems to explain why I used a single button. I will look into options but I am fairly new to this platform.

Hello, I recently got some honeywell switches from costco and it seems like it is the 39348 / ZW4008 model, wondering if you would have time to create a device handler for this device?

It should work for that device. The only difference I see is your device only supports 2 configs which are a subset of the ones available. I think it would work just ignore the unsupported configs.

https://products.z-wavealliance.org/products/3599/configs

Thanks for the handler! Is there any way to create an automation that will adjust the default brightness setting based on time of day? I’ve been trying to do this with webCoRE but have had no luck.

Currently no, I was thinking to make time to enhance it to the new api which would allow that.

1 Like

That would be awesome! I’m wanting to use it in my bathroom so that the dimmer defaults to full brightness during the day, but defaults to a lower brightness at night. That way getting up to go to the bathroom at night doesn’t mean you get blasted with the full brightness. :joy:

Thanks a ton!