SmartThings Community

Jasco/GE Motion Switch 26931

Updated the github with the spelling fix and heading changes suggested by @aruffell. Also set the invert switch parameter to the correct parameter number. However, this still does not set the switch to an inverted function. I will need to reach out to GE/Jasco for a full resolution.

Below is the documentation on the parameter numbers for reference
http://products.z-wavealliance.org/products/2035/configs

@mlebaugh - I think I have found the error in the DTH that was preventing the Mode tile from updating…

standardTile(“operatingMode”, “device.operatingMode”, inactiveLabel: false, decoration: “flat”, width: 2, height: 2) {
state “default”, label:‘Mode: ${currentValue} tap to toggle’, unit:"", action:“toggleMode”
}
main([“switch”])
details([“switch”, “motion”, “operatingMode”, “refresh”])

In the code above, “operatingMode” was written all in lowercase however in all the rest of your code the M was uppercase. As soon as I changed all lowercase instances to uppercase it started working properly.

I only have very basic knowledge of Groovy so I am not sure how to read the code but I am a bit puzzled by the use of “operatingMode” Vs “operationMode” - are they meant to be different?

I was also wondering whether a shorter label for the mode tile would look better. An example could be:

label:‘Mode toggle: ${currentValue}’

1 Like

Yup that would do it.

I think i had set them up operationMode as the setting preference and operatingMode as the attribute, but I’ll need to go through it to double check. This is because if the setting preference (operationMode) is changed, the switch’s mode (operatingMode) may not reflect the setting - especially if you use webcore or the tile to change the mode.

For example I might set it to occupancy in the settings click done and toggle it to vacancy with the tile. The setting will remain “occupancy” but the mode would change to vacancy. The setting would remain that way (but not get sent to the device) until the next time “done” is pressed. It would be nice to be able to change the settings for the device if changed via another method to keep them in sync, but last I looked smartthings did not let device handler settings to be changed this way. (for security reasons I’m sure.)

Either way I should probably clarify the naming of these two somehow and add some comments for readability.

Yes, this looks much better.


I committed the fix for the tile and format to github.

Thanks a ton for fixing this!

1 Like

Glad I could help and thanks for the code explanation! Makes sense to me now.

I now have 3 of these installed and one of them, the one that gets used the most, occasionally freezes. The only way to get it to work again is to pull the air gap out. Is anyone else having the same issue?

Also, I wonder whether it is software related or maybe a hardware issue.

Same here - mine are both on (separate) 3 way switches and I thought it might happen when I switched with the add-on switch. Still haven’t figured it out, but it happens about once every couple of weeks, most often on the one I use most.

They aren’t really integrated into my ST system at all, no features based on their status, so I’ve considered just removing them. They function well enough on their own and it would be a good way to rule out ST-side/handler problems.

Please let us know your findings as I too am curious whether it is a sw issue or a hw issue. I emailed Jasco’s support but have not heard back yet.

I have had this issue on 1 of 2 of my switches. None of the dimmers have had this issue. I suspect a hardware issue, but am interested to know what jasco support has to say.

Hi I am a newbie and not a dev. Thank you for all for this work. I was interested in double tap and custom DTH so was perusing this thread.
I am still using the stock DTH on two side by side switches. One for light and one for bathroom vent fan. This second one had to be air gapped twice in a week old install as it just stops working. It is in vacancy mode. The one that works is in occupancy mode. I don’t know how to ID the firmware .will call Jascozwave later today.

Jasco said it sounds like a bad switch and to return to seller. So Amazon shipping me a replacement and I will swap and Mail back defective one.
I had daisy chained the neutral but that should not be an issue correct ? It works fine for a couple of days after each air gap.
Also, how do I get the firmware rev as I had already tossed the box ?

Anyone have a good eli5 for toggling the modes (manual vs occupancy) at specific times? I can’t seem to get it to work. Thanks in advance.

You’ll need to use something that can execute custom commands, like webCoRE. If you are not familiar with it wiki.webcore.com is a good source. If you need help setting up a piston I can post a template once you have webCoRE setup.

1 Like

I’ve been using regular core for a while, haven’t made the switch yet. Where I’m getting hung up is the “then” portion of the command.

Here’s what I’ve got so far - trying to have them in manual mode from 8pm-5am, occupancy mode outside of that. I’m not sure the “toggle mode” descriptor is correct, but I’m not seeing anything more appropriate. Admittedly I’m not entirely confident on the logic built into core or webcore, one of the reasons I haven’t moved yet. Twenty or so working pistons, I’d rather not rock the boat until I have to.

ah in that case. The most recent version of the dth has three commands to simplify this Manual() Occupancy() and Vacancy(). you don’t need any paramaters or anything just call the mode you want.

I added these a while back to reduce confusion on how to call the SetModeNumber(value) command which it looks like you are trying to call, but i removed as an option. togglemode() is just like pressing the tile on the device, it will just advance to the next state.

Are these the ones in the list with the little home plates in front of them? If that’s the case - I’ve tried them and they do not successfully change the modes.

The piston looks like so:

If time is between 8pm-5am, then using hall light and laundry room light (home plate) Manual (), Else (home plate) Occupancy. I’ll leave it like that tonight unless I hear otherwise, but it did not trigger the mode change last night.

Yes the home plate icons are the ones. Can you go back in your recent history to see if the device changed last night? You should see the core event and the device confirming the mode change.

Edit: also your piston logic seems fine.

Thank you for the help so far. The events last night are a little unclear. It appears as if the piston activated (at 8:03, not 8pm), but from 8:05-8:13 the light continued to sense motion, triggering on. At 8:13 I went in through the app and changed it to manual, manually.

So essentially, piston worked, but the mode was not effectively changed.

I didn’t think I would even need this sort of integration (I may have posted as much above or in another thread), but lately the wife has been trying to get the baby to sleep in her own room…near where the hall lights and laundry lights continue activating. To have this working automatically would save a lot of trouble :slight_smile:

No problem. If you run into trouble let me know, no one needs an upset baby or wife.

I only have the switch versions in a few less used places in the house. Even then I only bought them to test with and probably haven’t given them the same attention I have with the dimmers…

So it seems to have worked tonight - there’s a chance I had been using the wrong command last night. One thing I did notice that doesn’t make much of a difference to me is that the tile changed modes, but the mode in settings did not change.

Either way, the lights seem to be in manual mode now…

Glad it worked!

The preferences setting mode and the operating mode are separate. The preferences settings cannot be changed except manually due to security reasons… last I looked. The device itself will operate in the mode listed on the tile. The preferences settings are only applied once the done button is pressed.