Issues with Zwave Shock sensors (inactive or open state) HEELLPP!

Hi, i’m having a lot of issues with the Monoprice Zwave shock sensors. When i pair the device its always shows it in an open state. I even tried the Rboys handler and this one only shows as Inactive, never changes. It does report on battery status thats it. I’m spent countless hours on this and it the only sensor that gives me issues. I’ve read that maybe the Zwave plus sensors are problematic although I have other zwave plus devices and they seem to work fine (Monoprice Window/Door sensors). I also remember like 1.5 years ago that these shock sensors worked fine, seems like over the years FW updates to the ST hub may have broken. Nontheless i have about 15 shock sensors that i’d like installed and non of them work, well i’m on my 6th one. I purchased them about 2 year ago just getting around to installing them now. I’ve been on various other forums trying to get this to work but still nothing. Also i’ve tried excluding/Including devices, hard resetting Hub several times and even tried difference ST hubs, all the same problem.

Please help, its been super frustrating. I even paid for the Rboys handler that was supposed to fix this, to no avail. I can provide my Hub ID to smarthings support is that helps.

Zwave Protocol Version: 5.03
Fireware: 000.024.00020

have you contacted @RBoy support?

1 Like

Yes, they just tell me to do the usual, try reboot long the hub, remove device and re-add, so on a so forth… I’ve tried pretty much everything. Even call Monoprice and they suggested trying another device handler from a guy called Kevin but that also they don’t work . Funny thing is some people report that it works perfectly for them what are they exactly doing that’s what I wanna know

It’s a common issue with some of those device. Your best bet is to reset the device, exclude it. Remove the battery for about 10 minutes and then pair again. It sometimes get stuck due to a firmware defect in some cases.
Also try to replace the battery.
There are other firmware issues issues for which the DTH has some fixes/workarounds.

I’ve tried all of what you recommended, still same issue. Do you know which firmware is problematic ? This way I know for sure if my batch of shock sensors are bad?
What do I do with all 15 sensors that I have? Garbage? There still brand new most of them are boxed unopened.
Last thing, since the rboys handler won’t work, can I get a refund?

Much appreciated!