Issues with Slider after Update


I created a device Handler for a custom ZigBee Device and I’m using a level Control cluster like this:

controlTile(“RollLevel”, “device.level”, “slider”, height: 1, width: 3, inactiveLabel: false, range:"(0…100)") {
state “level”, action:“switch level.setLevel”

It worked good so far, but after the last update the Pop-Up Screen looks like this:

How do I manage to put in the “done” button? I’m not able, to apply the value.

I work with a SmartThings Hub V2 and a Galaxy S6 with Android 7.0.

Hope someone here can help me :slight_smile:

For LAN devices, the value changes when you release the slider. That allows the user to set various levels. No done button. The “X” at the top exits the function or the back button on the android device.

I would assume it is the same for all device types.

1 Like

Hello Dave,
thank you for your reply. It’s a ZigBee Device and if I release the slider nothing happens like shown in the screenshot. Pressing “X” or back reults in not applying the value and the value will be reset to 0.

In an other thread I read that the new full screen slider should have something like a “done” button… but not for me

I have several DTH’s using the new format. As soon as I stop moving the slider or tap on X the value changes. I suggest you take a look at a couple of ST’s code for examples. It sounds like you’re not passing a value back correctly.

There is no “done” button for the slider.

Here are a couple example of my code you can reference:

Zwave Thermo

Zigbee Keen Vent


The reference to the ‘Done’ button is on the slider for the stock dimmer control…

Not on Android though: (stock dimmer)

1 Like

We’ll I’ll be darned! Here’s the problem on iOS…

They’re out of sync on this one :flushed:


Imagine that…


Thank you for all your help.

The probem must be something with passing the value… I’m new to SmartThings, sorry if this topic might be superficial :slight_smile:

As stated in my first post, I’m calling the function setLevel. setLevel looks like this:

def setLevel(value) {

With the old slider it worked just fine… but now the slider tile always states zero after pressing the “X”. What am I doing wrong?