Issues with new setup and help with troubleshooting an issue

I have a ST V3 HUB, Kwikset Z-wave plus 914 Deadbolt lock, GE Smart Dimmer “Z-Wave Plus”

The lock and dimmer are showing up with now issues.

I recently installed the automation “Lock User Management”, before adding the z-wave dimmer for a repeater.
It installed and was connected to the Kwikset lock, but I couldn’t make pin changes to the lock.

So I added the dimmer for a repeater and rebooted the HUB. And my first PIN Change went to blue and worked.

So I added two more PIN changes, and neither pin is added. They are both Red and say NO Response from the lock.

I see in the Notifications that it tried a few times and the gave me an exceeded message and it stopped trying.
The hub, lock and repeater are all within 50ft of each other. So I’m not sure what I should check or try out. I also tried doing a z-wave repair.

It says repair started
Network repair for device [03]: failed to update route (No idea what it means by device 03)
The it says network repair finished.

Any input or help is welcome.