Issues with installing/uninstalling an app

I’m running into an issue here with a custom app…

It’s an app by @dudz40 that I’ve had running for ages… it’s suddenly stopped working… and no matter what I tried it just won’t come back to life… so I decided to do a fresh start and reinstall it…

I tried to delete the app but nothing… the classic app spits out the generic red “An unexpected error occurred” message at the top and it just won’t delete the app.

Over on the IDE, I try to manually delete the app, but nothing… it won’t work either.

Finally, I’ve tried to install other instances of the app to see if it will work, but the installation fails with another red message…

I know, I could contact support for them to delete the app, but if I can’t reinstall it… what would the point be?

The app can be located here:

It uses another app also by him that bridges between ST and Domoticz…

All that so that the Somfy RTS blinds can be used from ST via an RFXCom…

anyone know of any other option to control said RTS blinds directly from ST?


it can happen if the smartapp created a device and this device is used by other smartapps.
in that case you need to remove the device from the other smartapps then remove your smartapp that will ultimately delete the device it created. just my 2cent

1 Like

now all I have to do is figure out what devices were created… Thanks for the tip!

look for Smartscreens Pause Switch device.

I disabled that button in the app… and nothing… still doesn’t let me uninstall it… :worried:

Not the button, the device itself.

met vriendelijke groeten,


Nothing… still won’t allow me to uninstall… “an unexpected error ocurred”

Could you pm me the app settings and state.

met vriendelijke groeten,