Issues connecting WeMo Light Switches to SmartThings Hub


(Scott) #1

I didn’t have real high expectations when it came to connecting the few WeMo devices I have to my newly acquired SmartThings hub. However when playing around with the app I saw that it’s a possibility. However I’m having issues getting them to connect. I get to the point where they are discovered and I can select the two switches but when I hit “Done” I get the following error “Failed to save page: firstPage”. Anyone have any thoughts on how to resolve this?

Thanks,


(Ryan Applegate) #2

Please try this again, the error you were seeing when clicking “Done” should now be resolved.


(Keith Croshaw) #3

If you’re only interested in on off control I seriously suggest going through IFTTT. I set up two virtual switches in SmartThings for my two WeMo’s. Four rules per switch. Two on the ST side and two on the Wemo side. Has been working great since, a little slow but to be expected when there’s a middleman. Good luck!


(Scott) #4

Got up this morning and noticed there wasn’t an exclamation point next to the WeMo connect app in labs. Gave it another go and it worked flawlessly. Whatever you did on the backend worked great.

Thank you guys for being so responsive. I’ve never once posted in a forum and had the company fix something. Very impressive!


(Nicholas Torres) #5

How do you resolve? I’m having the exact same problem

Finds three devices but keeps giving me that error. Failed to save page: firstpage


(Nvehr13) #6

I am currently experiencing this same issue. Is there another thread where this is being tracked? or do we have to wake this one up?

Thansk