Issues connecting GE/Jasco 45609's


(Raphael Turnerstone) #1

So I finally got around to installed a half dozen or so 45609’s. I thought they were the GE Version, but when I tried to add that version of the dimmer it said it did not match and I cancelled.

I went ahead and tried the Jasco and it seems to recognize it better, but I cannot control the light.

Basically, I went to:

Add Things
Switches & Dimmers
Jasco In-Wall Lighting Control On/Off Switch
Connect Now
When it goes to searching, I quickly tap the top of the wall switch and it finds it.
I give it a name with no special actions.

Then, when I go to my Things, it’s there, but turning it off/on does absolutely nothing.

I went ahead and removed them (I had to force remove in the app, twice) and tried a couple of times but it’s the same issue.

Is there something special I need to do to “reset” the switch back to default settings?

I’m a bit concerned because I also installed (3) of the VIZIA CRCS2-MRZ RF 2 Button Units and I have heard those are really tough to get going.

UPDATE: Some are working, some are not. Some units I need hit the switch on/off a couple of times before they are detected. I tried the Vizia and it doesn’t find them at all.

I was thinking it could be distance, but there are switches that work that are further than the hub than the additional switches are from switches. ie: Hub to first switch is 50’, it works. Hub to second switch is 100’, but only 20’ from the first switch. With Z-Wave, the distance is only 20’, right? The first switch should repeat the network to the second whether it is on or off?


(Edward Pope) #2

Try to do a Z-Wave Repair through the IDE. I have a bit of a spraw myself, but as I added switches I made sure to build out from closest to the hub (which was central to the house) to the outer switches that I wanted to automate.


(Raphael Turnerstone) #3

Thanks @theedpope ! How do I do a Z-Wave Repair ?


(Edward Pope) #4

You have to go into the developers tools, sign up… It is easy…

Then after you sign up and log in, you should see a “My Hubs” section. Select that, and then select your hub. You should see a button called “View Utilities” In that section you should see Z-Wave Repair. This should help if the mesh network has been brought up piecemeal. It helped with some of my minor issues. But, you could have also received some bad units as well.

I have been fortunate so far, I have had very little issue with many of the devices that I put into place. I had one issue with a non-supported but paired device, that I just had to find and assign a working Device handler for it manually.


(Raphael Turnerstone) #5

Thank you! I just repaired the network and will try to see if that helped. Why does the zwave Power Level, version, etc, all show ‘00’ for me though?


(Edward Pope) #6

Where are you seeing that?


(Raphael Turnerstone) #7

When I connect to the ide, go to my hub and select my hub … it’s there under the “Data” Section.


(Edward Pope) #8

Ok, just checked mine, and the news is good., Mine is the same way, so ti is probably not an issue. This hardware and software is still more or less in beta. While very good, and usable. There are issues like this. Probably low on the hit list, or not really an issue.


(Raphael Turnerstone) #9

Thanks for checking @theedpope ! I think I have all the units connected; I’m just doing a zwave repair after I connect each one.

Sometimes it seems slow to respond, but I guess that’s because the commands are coming in via internet to the hub and then out zwave. If I had a local zwave controller/remote, it would probably be instantaneous.


(Edward Pope) #10

Yes there is a bit of a delay due to the cloud nature of the hub. I understand that there will be a later version that will have more local commands. Hopefully things like lights and scheduling options will be run local. Which should reduce or eliminate most of our complaints