ISSUE: WeMo (Connect) showing multiple times within SmarthThings Labs

Under SmartThings Labs I have WeMo (Connect) showing 3 tiles/instances. All WeMo devices are defined under one instance only. I am unable to uninstall the other two that have no devices defined on them. I have also tried deleting the other two with no WeMo devices via the developer tools. Any advice on how to remove the additional instances to clean up the interface and reduce the item count to the correct amount.

After further review I have determined the following regarding multiple instances of WeMo (Connect). It appears everytime you add a new WeMo device to SmartThings beyond your initial import of multiple devices it creates multiple instances of WeMo (Connect). I am not sure if this is by design, a possible bug, or an afterthought. I attempted to add new WeMo devices I just purchased to the existing instance when they are discovered but noticed I am unable to create switches for them unless I go and create an entirely new device which then creates a new WeMo(Connect) instance rather than adding the new device(s) to the current instance.

Should we not have a single instance of WeMo (Connect) within SmartThings Labs to manage all WeMo devices integrated with SmartThings from a troubleshooting perspective rather than having multiple instances with the same name showing within Labs and development logging which may also be spawning additional processes that are not needed running on the hub and taking up additional resources?

Furthermore, if the answer is to remove all devices then add all at the same time to ensure you do not have multiple instances spawned, I do not believe to be a plausible solution as users tend to add devices over time. @Ben - are you able to shed any light here?

Looking into. word word word

I experienced this too. I don’t plan on adding any more Wemo’s going forward, so I probably won’t run into this again, but it happened to me. I ended up removing everything and starting from scratch since I am OCD and hate having duplication :slight_smile:

I had the same issue and remove it in from the online API site.

Ok - so this is a known bug - but not one that is on plan to be fixed in the next couple weeks (yet). For now you can go thru as you describe and delete and then reinstall. You can also go into the IDE site — http://ide.smartthings.com and navigate to your Locations page then click List SmartApps at the bottom of the screen. You should get to a view of all your installed SmartApps and solutions. You can hit Edit in the upper right to enable uninstalling. You should be able to uninstall the extra (Connect) apps.

Word of caution: don’t uninstall things like Hello, Home, etc from here as that can have negative consequences. (this page site needs some work)

@Ben - Thanks for the confirmation. Just as an FYI I attempted to uninstall from the IDE site and it would not uninstall. Here is how I was able to remove the instances beyond the first of WeMo (Connect), but of course it did not resolve the true issue…

In regards to removing the multiple instances beyond the first, I had to deselect a device from the first instance and ensure it was not being used by any actions or switches. I then had to add the device to the instance that I wanted to remove, then select uninstall in the IDE site, or via the ST Labs. At this point I now only had one instance of WeMo (connect) within ST Labs.

But here is where the chicken/egg conundrum comes into play. Once I want to re-add the device I used to remove the additional instance of WeMo (Connect) it will spawn another instance, or if and when I want to add new WeMo devices another instance will be created.

I guess I am just looking for confirmation on how to recover going forward and what sort of fix will be provided?

i.e. Will the fix when supplied migrate all current WeMo devices to a single instance of WeMo (Connect) within ST Labs or will we have to perform a manual action of adding/removing all devices at that point? Furthermore, once the fix is supplied when adding new WeMo devices beyond setting up your first device(s) is the intention to have them added to the initial defined WeMo (Connect)?

I just want to prepare for the correct scenario as I am looking to add more devices and want to minimize my headache if I start developing a bunch alerts/actions.

Keep up the great work, I can only see the product getting better and better with each iteration and becoming more acceptable and easier to use for John Q Public.

What was the error message?

I have the same problem with the Quirky Connect app, after the new dashboard update I now have two installs and can’t get rid of the old one. In the IDE if I try to delete it it just does nothing, no error or anything.

There was no error message provided when attempting via the IDE tools. Click on “uninstall” and nothing would occur. In regards to when trying to uninstall via ST Labs, the uninstall button does not even show up until you have a device selected/assigned within the component. Once you assign a device it will then uninstall. The reason I had no devices in the item was I tried to move and select them under the original instance of WeMo (Connect) to remove the secondary instance.

Just wanted to say that I also had this issue of multiple WEMO Connect Apps being installed without the ability to uninstall. Hopefully this bug will get squished soon?

Also, just tried deleting both WEMO SmartApps and it would only let me do one from the IDE, saying (just like the APP) that “There was an error uninstalling your SmartApp.”

I figured out how to get rid of excess Wemo (connect) smart apps.

  1. choose one Wemo you want to keep (don’t do anything to it)

  2. go to other Wemo devices and remove all smart apps

  3. Edit each Wemo device - Remove it.
    ---- you’ll notice the Wemo Connect app it was associated with is GONE----- :smile:

  4. go back to the Wemo device you kept and add the Wemo device you Removed previously. Hit Done

now you repeat steps 2-4 for each device. This allowed me to skinny my Wemo (Connect) apps.

It’s unfortunate that you have to go back and re-add all your smart Apps to the devices. But hey, it works.