Issue creating Door SmartApps with LFM-20


#1

I was thinkin I had an issue with the lfm-20 controller so I deleted off of the network. I finally went through all the steps to find it on the hub again. Now I cannot add the functionality that I had prior. For example:

Doors & Locks
Open and close it remotely: garage relay (LFM-20) selected
Know if it’s open or closed: Smart multi sensor selected
Done = failed to save page: doorDetail

This has been on ongoing thing for several hours. I have deleted all devices and added again. Also tried renaming to other devices, but still no help.

Please help me figure this out… getting an error for the switch that I have never seen before.

203ce57e-f1e7-4bdf-a9fd-32811d4d1722 ‎11‎:‎22‎:‎00‎ ‎AM: debug Parse returned [Glass Door was closed, Glass Door was inactive, Glass Door was 73°F, Glass Door Battery was 75%, Glass Door was -27 dBm, Glass Door Signal (LQI) was: 100%]

c30f0741-a3b5-43b6-aab5-c9deabb03c44 ‎11‎:‎21‎:‎53‎ ‎AM: error java.lang.IllegalArgumentException: Command ‘setDeviceType’ is not supported. Supported commands: [] @ line 153

c30f0741-a3b5-43b6-aab5-c9deabb03c44 ‎11‎:‎21‎:‎53‎ ‎AM: debug Setting Garage Door Sensor to ‘SmartSense Garage Door Sensor Button’

c30f0741-a3b5-43b6-aab5-c9deabb03c44 ‎11‎:‎21‎:‎53‎ ‎AM: trace lock.displayName: null?.displayName

c30f0741-a3b5-43b6-aab5-c9deabb03c44 ‎11‎:‎21‎:‎53‎ ‎AM: trace contact.displayName: Garage Door Sensor?.displayName

c30f0741-a3b5-43b6-aab5-c9deabb03c44 ‎11‎:‎21‎:‎53‎ ‎AM: trace state.currentAppLabel: Garage Door

c30f0741-a3b5-43b6-aab5-c9deabb03c44 ‎11‎:‎21‎:‎53‎ ‎AM: debug Updated with settings: [contact:Garage Door Sensor, garageDoorOpener:Garage Relay Switch, doorType:garage]


#2

I have the exact same issue. I can absolutely not save the any Settings for the MultiSensor. It will always say:
failed to save page: doorDetail

Any hint?


#3

Report it to support@smartthings.com. They should be able to help.


(Ash (www.smart-dots.com) / Ashutosh Jaiswal) #4

I had the exact same issue and I contacted Support. They told me that they changed the device type for my device and after that it started working. But the device type was the same as before, even though they said they changed it. What I would recommend is to change the device type in the IDE to something else and then change it back to Z-Wave Relay for the relay switch. See if that works. If it does not, then contact support.


#5

Contacted Support. Super Helpful. The device must be configured as “SmartSense Garage Door Multi” in the web interface (graph.api.smartthings.com).


#6

Yes support was super helpful. The garage relay needs to be as a Z-wave virtual monetary contact switch, and the multi needs to be set to smartsense garage door multi. After these are set you can add the door and everything works flawlessly! Even better than it did when I started deleting devices :smile: