IRIS - ST Migration of GE Z Wave Plus (Jasco) in wall Paddle Switch

After reading threads for 2 + hrs, trying to follow the instructions at the ST Support I still have not been successful in connecting.

Disconnected the wall switch from Iris - Check

Try to connect in ST Classic - didn’t locate device

Trying to connect in ST Connect currently sitting at 21% and still spinning

I have tried to the exclude process and was told there are no devices to exclude.

Do I need to factory reset this switch maybe?

Is this the same issue I am experiencing with the GE ZWP(Jasco) smart plug in switch too

Any suggestions

You should have excluded the switches from the Iris Hub before disconnecting.

If you didn’t then I’m then try using the Classic SmartThings App. Goto zwave utilities and put the Hub in Exclusion mode.

Turn on the GE switch and then turn off. This should reset the GE switch.

Now add the Switch the same way.

1 Like

I went thought this process for one of my new hubs.

  1. Remove from Iris properly
  2. Exclude manually from Iris Hub
  3. Exclude manually from ST HUB
  4. Pair with ST Classic app
  5. z-wave repair
  6. worked for me perfectly each time
1 Like

I did exclude/disconnect from the Iris hub. Well technically they wouldn’t disconnect I had to force remove them. Does this make a difference

In the Classic ST App. to clarify Zwave utilities >General Device exclusion > putting hub in exclusion mode> select Remove.

Is this correct? How long should this action take to be completed I am seeing the spinning blue line at this point.

I was able to successfully remove each of my GE devices from Iris using the above steps. You should be able to remove it from Iris, but steps 2/3 make sure there are no leftovers.

Once you put the Iris Hub in exclusion mode, turn the switch on/off a few times till iris sees it and resets it. Iris should see it a couple times as removed. Same thing with ST exclusion mode, turn it off/on a few times. it should show the device excluded once. I had to repeat these steps per device, i couldn’t reset multiple switches at same time, i had to do it one at a time.

1 Like

All zwave devices require some physical action at the switch for exclusion to succeed. for jasco switches, this usually is done by pressing up or down on the switch after the hub is in exclusion mode.

Sure does. All force delete does is tell the hub to kill it because it probably isn’t around anymore, but the device itself still thinks it is part of zwave network. Until a successful exclude is done by ST it won’t join.

Correct. Depending upon the distance from the hub it could take several seconds. Monitor your hub’s event log and you should see something like “removed device 00” and then the mobile app will say it successfully removed/deleted a device. It will keep searching too, so make sure to stop the exclusion process after you remove that 1 device, otherwise you could potentially remove more devices than you were expecting.


When I located the Remove ZWave Device Option… clicked on Remove ZWave devise options…the search timed out.

I have enabled the Remove option and used the paddle switch to turn on and then to turn off and Iris is still searching…It just stated a device wasn’t removed keep looking.

And now my thermostat is off line too. Sigh technology is killing me today

First let me state I am a newbee at using the thread environment…on the Iris hub issue Do I need to exclude these items from that platform prior to trying to connect to ST hub?

I noted you mentioned connecting to the ST in your comment.

On the 2nd process, which I suspect should be handled as a separate process. I have tried to use the exclusion mode and the App hasn’t located anything, I did turn the switch on and off as mentioned in other posts to the tread.

Still no success

Nope, the general exclude process via ST will do the trick.

Btw, welcome! We’re all here to help, so don’t hestiate to ask.

1 Like


Just to clarify the exclusion process is for the zwave device, so you only need to do the exclusion once, either in Iris or in SmartThings, but you do not need to do it twice.

Once SmartThings is in exclusion mode, I would click the paddle of the zwave device slowly, over and over until you see a message that says, unknown device is excluded.

Once excluded, place SmartThings in inclusion mode and then click the paddle slowly over and over until SmartThings shows that you added a device.

Double check the manual for the zwave device on what physical actions are needed for that device to be excluded. Not all zwave devices have the same actions.

I think zooz is different than Ge switches.

1 Like

Also, make sure that the hub and switch are close to each other. The incuding and exclusion process works much better when they are in the same room. Then move the hub back to where it will live and do a zwave repair.

I have 11 GE/Jasco outdoor zwave switches and 12 GE/Jasco wall switches, on my SmartThings system. I bought them all at Lowe’s and they had the Iris branding. So they definitely work. Once your sure you have your exclusion completed then look at your distance from the hub as mentioned above. Get a longer ethernet and get real close to the closest one just to see that it connects. Then connect the next closest one to that one working away from the hub.
Oh, and I had all these switches on a Staples Connect hub before I switched to SmartThings.