Iris Smart Plug iL03_1 (IL031)?

This is what I have for the Iris IL03-1 Smart Plug. I used the Zigbee Switch Power to get it to work. Currently won’t work for what I had intended it for. But I will use a different plug I have for the intended purpose.

Hopefully this will help when it comes to building a device handler.

Name Iris IL03-1 Smart Plug
Label Power Meter
Type ZigBee Switch Power
Version Published
Zigbee Id D0CF5EFFFE86C1FC
Device Network Id 66A1
Status ONLINE
Hub Home Hub
Last Activity At 2018-12-14 3:41 PM CST
Date Created 2018-12-14 2:59 PM CST
Last Updated 2018-12-14 3:41 PM CST
Data
application:
endpointId: 01
manufacturer: iMagic by GreatStar
model: 1113-S
Raw Description 01 0104 0051 00 07 0000 0003 0006 0402 0B05 FC01 FC02 02 0003 0019
Firmware
Current Version: 0x10006230
Target Version: 0x10006230
Last Updated: N/A
Last Checked: 2018-12-14 3:39 PM CST - Check Now
Current States
switch: off
checkInterval: 720
Execution Location Local

Not sure if someone found a solution for this but I found a similar post for a different Iris Smartplug by Blebson and used his Device handler and it worked for the on/Off switch atleast. Not sure if this is also a repeater.

First post so not sure if its ok to post the link but here it is.
Link here

1 Like

Should work with SmartPower outlet and run local

I got it working as a smart outlet. But do you know if this has a repeater too in it? Also when you add an IDE, what do you select in Add New Device? I cant get the IDE to show up in the list of available devices to start looking for the signal.

you can’t add a zigbee device from the IDE. have to add it from the mobile app.

Yes that is right but the new ST app does not have an option to pair a generic device. You have to select one of the available devices. The solution I received from another post is to use classic app where you do not have to pre select the device you are pairing. Hope they add this feature into the new app.

that is only a V3 hub/new app combination issue and selecting any non-SmartThings sensor from the list puts the hub into general inclusion mode, so you can pair any device.

Oh wow that is really good to know. Thanks. Thats how I did a few of those Iris outlets. Selected Centralite and Buscopa showed as the device. I had a feeling thats how it works. Is there anyway to find out if the outlet is also a Z Wave repeater?

This outlet is a Zigbee repeater

Does anyone know if this device supports energy monitoring? I tried a couple different device handlers, but the energy reading in the app is blank and won’t show any readings.

I tried zigbee switch power and the custom Iris smart plug one that someone posted along with a few other guesses. None of them work. I’m happy to help someone look into this if there is anything I can do to create a DH that will get this to work. I just don’t even know if the hardware supports it in the first place.

How about the “SmartPower Outlet” dth?

Can you pass along the Raw Description from the IDE for the device? Is it the same thing as the one on post #10?

Yes. Here’s the info.

  • divisor: 10
  • endpointId: 01
  • manufacturer: iMagic by GreatStar
  • model: 1113-S
  • zigbeeNodeType: ROUTER

I tried “SmartPower Outlet” and its the same. On/off still works, but no energy monitor. It just shows – in the bottom left where the I believe the energy usage should be. Thanks for your help with this.

1 Like

Ah, now that was super helpful! The model was the key : “1113-S”. That does not support power reporting, and will join as a regular switch using the DTH “Zigbee Switch”:

https://raw.githubusercontent.com/SmartThingsCommunity/SmartThingsPublic/7c3b12dc682f4bf5fffbd91d1fd19e117515be70/devicetypes/smartthings/zigbee-switch.src/zigbee-switch.groovy

Here’s where it’s fingerprint is called out:

	fingerprint profileId: "0104", inClusters: "0000, 0003, 0006, 0402, 0B05, FC01, FC02", outClusters: "0003, 0019", manufacturer: "iMagic by GreatStar", model: "1113-S", deviceJoinName: "Iris Smart Plug", ocfDeviceType: "oic.d.smartplug"

Ah, that’s what I was afraid of. The main reason I bought this was for the energy monitoring because on the Smartthings page for it, it says that it is supported. It is on other versions but not this one.

So, does anyone have a good recommendation for a smart plug that supports energy monitoring and works reliably with Smartthings?

for some reason the WWST page is combined with the other two Iris models that DO support energy monitoring

I’ve had outstanding reliability with the “GE ZigBee Plug-In Switch model 45853”. I have them on every appliance and every AV component throughout the house. They aren’t as cheap as the SmartThings branded plugs, but the form factor of the GE is much better. Power reporting is also instant.

Sorry the IL03 didn’t work out.

That’s what threw me off, but it’s not right and should be updated.