SmartThings Community

Iris Smart Plug, IDE, my first device handler... Please help :)


(Raeven Phillips) #1

Hello,

I’ve been working for nearly two weeks trying to get my new Iris smart plugs setup with my ST hub. I added the device handler two weeks ago and followed along the best I could as it’s my first go at it. I thought I had it right but never had the chance to truly are add my ST hub doors while I was trying to pair my first plug. Support was kind enough to send a replacement as it was just within the warranty period and when it finally arrived, I realized all my other sensors were out of battery (even though it didn’t report them being low… Oh well, nevermind). So my batteries have finally arrived and I’m trying to get everything set back up. I followed the migration instructions as support instructed removing everything and now re-adding them again. There seemed to be a glitch initially in the IDE as it didn’t set my hub at all but after click around enough it finally found it. I added the new device handler (by code as that seemed the correct way according to the info in the forum thread). But I’m lost on how to change the device type. I thought the first time I did this two weeks ago, that there was a drop down device type menu and I chose the recommended one “SmartPower Outlet” but I can’t find that anywhere. So that leaves me wondering if I just didn’t remember it right, if I’ve screwed up the whole device handler addition either the first or second time (and I have no way if knowing which one!), if I’ve missed the drop down menu somewhere, or if I’m actually just supposed to change the device type by literally typing in “SmartPower Outlet”.

Can anyone please help me with this? Am I missing where I’m supposed to change the device type? Did I create the device handler wrong? Or do I just type in SmartPower Outlet? Or something else?

Lastly, I can’t figure out how to exclude the Iris Smart Plug Z-Wave. It paired before the ZigBee part before I realized that I needed to setup the device handler again. I haven’t been able to get the ZigBee paired your but understood that I needed to exclude the Z-Wave repeater before I could start over pairing both parts of the plug again.

Thanks so much! I’m so very grateful for this awesome community willing to help me out when I’m so muddled!


#2

These are the steps for using custom code. See if that clears anything up:


(Raeven Phillips) #3

OK, I looked and found that when in IDE under the “devices” section there is a doodleb device type that had the SmartPower Outlet option. Do I wait till I pair the Iris plugs units and change each one’s device type there? Or am I back to changing it somehow in the device handler area? I was initially happy to have found this but now I’m still not sure what I need to do. Am I inching closer?


#4

Which device type handler are you using? IF it’s Custom code, I would ask in the author’s thread for that device type handler, as that’s where people can tell you about any of the specifics it requires.

I think this is the one most people are using:


(Ben W) #5

Unless you need the zwave repeater I would use “SmartPower Outlet” device handler.

I believe it shows up as a Thing, and you can switch it to “SmartPower Outlet” in the IDE. That should also get rid of the zwave bit.


(Realy Living Dream) #6

The Iris wall wart pairs twice as 2 separate devices. The ZigBee outlet and a generic z-wave device. So you can set the outlet as SmartPower outlet, and still use the Z-wave repeater .