Iris Smart Button

The generic “Zigbee Button” DTH is not custom, it is directly from ST and ST recently certified the Iris Button and added it to this generic DTH.

However, it still does not run local. You can check here if you have the device added:

According to ST support, the plan is to add many devices to these “generic” Zigbee/Zwave DTH and enable these “generic” DTH to run locally. No ETA on when this will happen unfortunately.

I bought a couple of these from Lowes for $10 a piece. I really like them. SmartThings recognized them without any additional configurations.

Hey all,
Could two of these be used as a “toggle” switch to drive a smart plug? Basically, one button on each of our two night stand lights to switch on or off one smart plug that is connected to two lamps.

Sure can. I use a SmartApp called Button Controller Plus to assign what they do. Just install it twice, once for each button, and set Button 1 to toggle the outlet. I use one of my buttons to toggle an outlet too, works really well. Had the Christmas tree plugged in to it for a while, now it’s cabinet lighting.

1 Like

I just put a new battery in this 2nd gen button and it’s reading at 110% battery life, lol!

Where are the OFFICIAL instructions for how to PAIR and RESET this button?
I searched, and probably read every post in this thread with the words pair or reset, and have followed all ‘instructions’, but they’re still not working.

I just bought 5 of these.
I opened and paired two of them.
One is using the default, ‘zigbee buton’ Device Handler (because I heard it’s been made ‘officially’ compatible now),
and the other one is using the @mitchp Device Handler (just to see if it matters for what’s happening here).

They show up in the SmartThings mobile app, but don’t report anything other than battery level.
Also, nothing happens in Live Logging when I click the button, hold the button, or force the battery tray in to get the light to come on.

Since their battery levels seem high enough (one fluctuates between 88% and 100%, and the other one seems to be at 77% I think), I assume replacing batteries is irrelevant.

Can anybody help me troubleshoot these, or are mine most likely duds, and I should take em back?


  1. What lead you to consider putting cardboard under the battery?

  2. Has yours continued to work properly since doing that?

EDIT: Actually, I think I found it…


Same questions to you about this cardborad bit, and now the bending of the prong.

OK, I finally got one of them to connect…properly…-ish…sort of…I think.

After seeing the comments quoted above about cardboard under the battery and bending the prong, I took a look in there, and went to work…

Poor Battery Contact Mechanism/Placement…

  1. Need to Prop Up the Battery to Make it Touch the Negative Contact
    Since it looked like the only negative contact for the battery (above it when battery is sitting in the tray with the tray below the battery) is close to the slider opening edge of the circuit board, I added some ‘rubber feet’ material ‘under’ the battery at that spot to help force it upward so that it actually touches the contact when closed.

  2. Need to Bend Positive Contact Prong to Make it Touch the Positive Contact
    Then, since the only way I could ever get it to give me any sort of response at all was when I pushed in really hard on the slider tray (which I now see as being the mechanism for causing the battery to touch the positive contact), I used a dental tool to bend the positive contact outward a bit to make sure it would touch when closing the slider tray ‘normally’.

Of course, now that I’ve done this, the slider tray is even MORE difficult to open, but it can be done (carefully, and with tools so as to not gouge the plastic), and the button appears to be working (with the new, default DH).

The only things that seems lacking a bit (other than no temp), are…

  1. Lacking PUSHED-vs-HELD Reliability
    The fact that it seems difficult to establish reliability of actions between PUSHED and HELD. It doesn’t seem to have much trouble noticing a PUSH, but needs more time than what’s configured to get it to notice a HOLD.

  2. No Instant Feedback?
    In the SmartThings mobile app (I’m on Android), there is no flash or blink or icon change or anything upon either being PUSHED or HELD. The only way I can tell if it was touched at all is to either watch ‘Recently’, ‘Live Logging’, or if/when it triggers actions from rules, etc.

Any advice on any of this?

Is there a way to use the button to trigger a phone call or text? I am thinking of using as a panic button but would like it to trigger a call or txt in addition to triggering lights and alarm.

I was able to pair 2 out of 3 eventually, but the third one will not pair; I have been trying since last night. I have followed all the recommendations on this page plus restarted my hub, rebooted my network. the battery is making contact because a button push/hold makes the red light blink, the same as the ones that are paired.
is there a manual way to pair this either by choosing another thing to emulate or in the IDE?

Is it resetting/blinking blue? If not that’s what you have to have happen. No way I know of to pair in IDE. To replace a device with it you need the buttons zigbee ID which I get from IDE so seems like a catch 22. Are you sure it isn’t paired as a thing or something else? Have you checked IDE for a out of place device?

I just used a small hook to bend pins up more and shimmed battery with a small square of paper in the drawer. Now the drawer actually pops out a bit when the grey lever is used so it must be making contact. I did get a green light blink once after bending/shimming but nothing in IDE.
boxes were sealed.
the zigbee ID is the mac address on the back, is there a way to find the device network ID?

That I don’t know sorry

I bought one of these on a whim and I was able to pair it with these instructions

However, it doesn’t appear to have any options to do anything. Do I have to do customized smart apps for it or are there some default options I’m not seeing? Sorry, still pretty new to ST.

It’s been a while but the app I used is called Button controller. Under more on Smartapps it comes up for me.

I don’t see a more option under SmartApps. Do I have to add Button Controller code manually?

It is located in Marketplace: SmartApps: More

You can also use he built in smart lighting.

Under “how do you want to trigger the action” use “button pressed”

This thing was working great for me then I had to change the battery because it died and now I’m finding that after a few days the button stops reporting temperature changes. I use it as a door bell. Usually if I go and press the button a bunch of times it wakes up and resyncs. Idk why it keeps going dormant!

Apologies for the delayed response…1. I noticed the power/connection
light was bit erratic. 2. Has worked fine for the past couple of months…

1 Like

Hi guys,
What exactly do I need to change in the code to have the device update temperature more often?
I’d like minimum hourly reporting, preferably every 30min.
Some of them update somewhat often, some virtually never do.
I realize it will kill battery. That’s fine.

Also, is there a way to have reporting update more frequently during certain hours?

I looked at the code, and I’m assuming I know where the reporting property is. I just have no idea what values mean what in the code to change.

anyone, anyone?