Iris Smart Button

I have stopped using these as actual buttons because mine are so unreliable, so I thought about simply utilizing them as temperature sensors. Problem…it appears, at least for me, that the device does not reports back at a regular interval set. When I look at at IDE. I can see that it would appear that the device did report on some temp changes. Does anyone know if this is how the device works? It senses a temp change and then reports?

Deleted, as I saw this is to be used as a device handler rather than a smart app, which resolved the error I was receiving.

1 Like

“No signature of method” often means you tried to paste code for a device type handler into the smartapps section of your account. So just in case it’s that, check the following and make sure you were doing the correct steps. This code is a device type handler, not a smart app.

If that’s not it, you’ll have to get one of the people who can read the code to help. :sunglasses:

1 Like

RESOLVED!! :slight_smile: Updated Steps for when I do my neighbors house:
-Installed Iris Smart Button code by Mitch Pond as a Device Handler. (Ensure this saves. Newbie misstep, saw it last night but it wasn’t there when I went back in today.) Re-adding the code resolved, re-paired & works like a charm!
-Device paired as “Iris Smart Button” this time (was pairing as “Thing” before).
-I had to re-pair the button (remove battery for 10+ seconds, place hub in pairing mode, depress the small grey leaver on button as re-inserting).
-Added a sliver of card stock to push the battery forward as others had recommended.
-Since it paired correctly this time, I did not have to manipulate anything in My Devices this time.
-Set up Automation >> Add SmartApp >> Lights & Switches>>Smart Lights.

Also, do any of the Iris Version 1 devices work with ST? I trust all my V1s so much more than V2s. V1s have more heft, have lasted longer, and had less technical issues over the last 3+ years w/ Iris. (Thanks for your response JDRoberts!)


Most of the iris V1 Z wave devices will work, but the zigbee and other protocol V1 devices will not work with SmartThings. You have to go to the V2.

1 Like

This is the most frustrating device I’ve ever tried to connect to my hub.

First time power on (pulled plastic tab out that keeps the battery from connecting) I got a blue light/flash for a second or so, but it did not connect.

Done the battery pull/re-insert holding button 2 seconds about 15 times with no improvement. When I insert the battery the red light comes on so I know I have a good battery connect (or so it seems) but never see any flashing or other activity and it won’t connect.

So frustrating - even at $10 on sale I think this thing is going to go back. The Aeon Mini-mote is larger, but SO much more reliable/easy to connect.

I had to slightly bend the battery contact toward the battery. Also put thin shims to push battery up toward battery connection under the button.

Had to fiddle with battery after this to get it to go in. Has worked great since then. The design and battery tray are weak.

Try that or take it back.

So even though I get a red light for a couple seconds when I insert the battery tray, that my problems may be contact related?

Yes, I have found when the connection is flaky. When you push the button, move switch, push on edges it will not work correctly.
If you scroll back in this thread some you’ll see others having issues with this button too. Others who posted what they did, shims,bent prongs, reinstalled smart button software ect…


K, off to bend and shim. So high tech. :wink:

I don’t know if you can see me, @TN_Oldman, but this is me smiling really happily. :smiley:

Yup - did some bending of the battery connect prong in the back of the device, shimming the battery by putting one thickness of paper beneath it, pressing things back together really hard and then I got the magical Red-Blue-Green sequence and the button was connected.



No problem, next time you’ll help me.

1 Like

How well does it work for you after you got it hooked up. I could only get it to work once and not again until running through the process again. I did try shimming it though.

I have not had any issues since the last time I messed with it. I don’t remember how much I shimmed the battery and or if I put the shim directly under the battery? I know it was difficult to push the tray in because the battery was up a little to high, and side prong was bent out. I just massaged / gently forced it in there.

These things are touchy and flaky. I think alot of people just give up on them, due to the battery tray / connection issue.

My first one was setup yesterday, but every time I’ve pressed it, it has worked for short (table lamp smart bulb) and long (overhead smart bulb). It is in the same room as my hub and a Zwave light switch so I assume it is benefiting from them being nearby. We may move the switch to the bedroom, which will be a better test of its range.

I’ve bought two more on sale ($10). I then moved the first button to the master bedroom and changed its assignments to two lamps there. Things started getting wierd…sometimes a short press would light up both lamps, or turn one off correctly but turn the other on, etc. So I set that switch to just control one of the lamps only and then it seemed to work consistently. That’s at the other end of the house so presumably the zigbee network is weaker down there and strange things happen.

Third sits next to me for now, when I put a smartswitch in the office I’m going to add it there also as a physical button so that my wife/son can get the lights on more easily (the switch is in a recessed area to the side of one of the desk, hard to reach.

So I’ve had mixed success in usage, but the good news was that the two new buttons paired w/out issue or having to bend connectors or shim the batteries like I had to on the first one.

I successfully paired mine, but I can’t seem to configure it. It only reports temp and no button pushes. I tried setting up Button Controller, which sees it but the Iris button push does do anything.

UPDATE: Cardboard under the battery seems to have gotten things working. Of course I may never be able to get the battery back out now…

1 Like

ST has added native support for this recently:

However it does not show temperature readings.

Native DTH is “Zigbee Button” and so far seem more responsive and the battery stopped draining so quickly. Probably due to the fact that the generic DTH doesn’t do temperature reporting.

1 Like

Likely going to return one button, it’s turned flaky and rarely works. Two others have been fine…


Should the zigbee button run local?

I changed my 2 iris buttons to zigbee button and they still do not seem to run local, according to the list.

Does anyone know?

If you are using a custom Device Handler then NO it doesn’t run local only native device types run local.