Iris Smart Button

I was afraid of doing that. I’ve broken the holder on smartthings FOB battery holder too. I barely pried on it. Not even sure if it bent.

1 Like

Just a heads up. I know people’s buttons are breaking, but right now the smart button (single) is on sale at lowes for $20.

The keyfob I had broke. Hopefully the buttons last longer.

Working fine with CoRE but a bit slow.

I thought I’d give one a try at the price. It broke!

Not worth it, IMO.

You say that but I’ve already bought 3 more :stuck_out_tongue:

If it breaks I can always solderfix the button or battery tab. The keyfobs battery tab broke, took all of 2 minutes to fix.


Non-programmer NOOB here… I have tried to use this code, but get the following error:

“No signature of method: script1481046718945423798485.metadata() is applicable for argument types: (script1481046718945423798485$_run_closure1) values: [script1481046718945423798485$_run_closure1@4d84b66f] Possible solutions: getMetadata(), getState(), setState(java.lang.Object), metaClass(groovy.lang.Closure)”

Steps I took:

  1. Open your github link.
  2. Select RAW
  3. Copied everything to Smartthings “from code” page.
  4. Press Create

Then the error was thrown.

Any ideas why?

Make sure you are putting this in the Device Type and not Smart App section of the IDE.

Thanks Michael. That worked. next time I’ll try thinking first :slight_smile:

1 Like

I can confirm that the above code works very well. The button controls a lamp. Now it is time to take out the manual on/off switch so my wife will quit turning it off.

I would hold up on removing it. Tape it into position. I have two of the Iris buttons and both broke first battery change and lots others with the same issue. I wouldn’t take one unless you paid me for life time replacements. Just my 2cents

Just picked one of these up because it was on sale for $15. Figured I couldn’t go wrong for that price. Got it paired last night along with the device handler above set up. It sees the device, battery status, and temperature but doesn’t respond to the button. I gave up on it last night and let it sit by the hub. Tried again this morning with no luck. So I reset it a couple times and still nothing. So removed it from the app and reset it again. Got the blinking blue light like they said on Lowe’s website after resetting it so paired it again. It picked up the device just fine. It actually responded to a button push and a minute later, the held function. But then after another 15 minutes of filling with it, there was nothing.

I don’t want to give up on it since it was so cheap but don’t know what else to try. Don’t see any activity in the live logging either on the API website.

You need to install the Button Controller smartapp from the marketplace to be able to use the button for things.

Didn’t know that existed. Just set up a piston in Core to use it before but just now tried that button app and still nothing. I think I just got a dead device. Because looking at live logging and device logging, there’s no entries other than ones that come up when I reset it and it shows the device updates.

I’m having the same exact problem. Seems to work but then dies again.

So I have the button working well, but there is a problem with temperature. It reports Celsius.

I found this in the code, but not being a programmer, I don’t know how to change it to Fahrenheit

def getTemperature(value) {
def celsius = Integer.parseInt(value, 16).shortValue() / 100
if(getTemperatureScale() == “C”){
return celsius
} else {
return celsiusToFahrenheit(celsius) as Integer

Do you have anything else reporting temperature in Celsius? I just wonder if there’s a global setting somewhere in SmartThings to modify the default. If not maybe try swapping the “return celsius” line with “return celsiusToFahrenheit(celsius) as Integer” and see what happens. You could easily revert it back if not.

Got this working after installing the custom device, button smart app, and bending the power prong and putting a small square of cardboard under the battery to help it keep in contact.


Many of us have been there and done that.

1 Like

The other temperature sensors are reporting in Fahrenheit. There is a setting in ST, and it is set to F.

I got this about a month ago and I’ve had similar troubles described here by other users.

  • unresponsiveness
  • losing connection all together randomly
  • sometimes requiring multiple presses to respond

Then my button completely died yesterday. No lights, no nothing, zero response.

Went to Lowes and got a replacement. I noticed a significant difference between to old and new button in terms of feel. Old unit I can push the battery tray it would move. The new unit is rock solid and the battery tray does not move at all when I push on it. Button itself feels a little bit more solid when pressed.

In terms of function, it’s been working great. Pairs right away and has not missed a button press since setting it up. Still a slight delay (~1-2 sec) but works every time.

Not sure if the new one I got is part of a new hardware revision but I would definitely only keep the units with a solid battery tray, if it moves then I would return for a different unit.