Iris Smart Button

I don’t know if this actually explains your problem, but many people (myself included) have noted this button to be very sleepy. That is, it often doesn’t register the first time you push it, because that just ends up waking it up. I guess that might still register as something in an event log, but regardless the Iris smart button is annoying to try to use for anything if you end up having to push it once just to wake up, then another time to do whatever it is you intended to trigger with the button press.

Thanks. I’ve seen that in a number of posts. I’m finding that even if I push the button several times in succession it still doesn’t trigger an event, so I think it goes beyond sleepiness.

In your case, probably. But best case scenario you have to tap it twice to get it to do what you want most times. I abandoned the button that came in a pack of Iris items I picked up a while ago.

Not trying to derail your button quest, and you may very well already know this, but are you aware that all you need is power in order to add an auxiliary switch that you can then tie back to your lights? There’s no need to have wires that run to the lights themselves.

If you had an electrical outlet anywhere near the top of the stairs, this might be an option. Of course, you may already know all this and be well past this point, thus why you’re looking for a button :stuck_out_tongue_closed_eyes:

FWIW, I use a smart button and it’s often very sleepy. Really a pain to use…but it does work.

Thanks . . . yes, I was aware of that. But there isn’t an outlet in a convenient location to draw power from.

As you can see . . . yes, there’s an outlet, but it’s not in a particularly convenient spot. That stairway gets used a LOT, and to have to walk around either side of the railing to get to a switch would be a nuisance. I want to just put a button right at the top of the stairway, on one of the railing posts.

Although I did just get a brainstorm . . . well, more of a drizzle, actually . . . of an alternative that might work. But I’m not giving up on the button quite yet.

Quite a few options, depending on your exact requirements:

What is it exactly that you are trying to do? Just turn the light on before you walk downstairs? Why not just put a motion sensor on the first stair against the wall? When there is motion turn downstairs light on. If the light is already on it won’t do anything. If it’s off, it will turn it on. I would set the switch downstairs to have a delay in turning off to give you time to get up the stairs so the motion sensor doesn’t turn it back on. An Amazon Echo is an easier solution, although not as cheap. Then again you can use the Echo for a lot of other things as well.

You could make your own button thats not sleepy using a mono price contact sensor.

Are we sure that the Iris Smart Button is “sleepy”?

My iris smart button works the first time I hit the button every time.

The problem could be a weak zigbee mesh!!! That was my initial problem.

Initially my iris smart button worked only some of the time, but ti was due to a weak zibee signal from the hub to the far side of the garage door where I wanted to place the smart button. I had NO zigbee repeaters at first.

I purchased a smartthings power outlet ( I Support Smartthings when possible :slight_smile: ) and placed it into the laundry room, as I wanted to monitor my washing machine, and was hoping the laundry room was close enough to the garage to fix the intermittent issues I was having with the iris smart button.

It did work and the iris smart button does NOT seem to go to skeep.

The iris button is usually only used on the weekends, it is placed on the far side of the garage next to the garage door to be used when I am walking out of the garage on foot and NOT in my car, to shut the door on the way out.

I hit the button, the red light blinks twice and the garage door closes.

HERE is a tip

Having a strong mesh (zigbee or zwave) seems to be much more important than one might think at first.

One might think that as long as the device is paired and works some of the time, everything is working.

For computers this is the case but it does not appear to be the case for Zigbee and ZWave.

Quality of Ethernet or WiFi signal for computers impacts performance long before it will cause data to actually get dropped

When using Ethernet and/or normal computer WIFI some amount of data does get lost, but the protocol has handshaking, so any data that is lost is re-transmitted.

As far as I can tell Zigbee and ZWave protocols do not have error detection and handshaking that compares to what Ethernet/TCP/IP performs.

Normally when we think of a computer network, using our computers (Ethernet/TCP/IP) the protocol has some built in error detection and handshaking that goes on between the devices or programs that are communicating. So data that does not arrive at the destination can be resent. The sender sends some data and as it is sending the data it asks the receiver to confirm that the data is received. An acknowledgment or ACK. The receiving side sends ACKs as it receives data. If the sender does NOT receive an ACK for any piece of data, it re-sends the data, and data is numbered so that the entire messages can be assembled in the correct order even if data arrives out of order on the receiver side.

Zigbee and ZWave do NOT appear to have this. If the button sends a click message and it is dropped, the button has NO way to know the message was NOT received and does not send the message again!!!

Is there any way to confirm which devices have this “sleepy” issue?

Yes. :sunglasses: Almost all zigbee and zwave battery powered devices sold for home automation are sleepy devices. It’s done to extend the battery life.

That said, your points about the strength of the mesh are definitely important.

As far as your other comments about network topology, I’ll just say that’s not quite how it works. I don’t want to hijack this thread with a long technical discussion, but there are other threads that already exist to discuss the various protocols if you’re interested in those details. :control_knobs:

There is an acknowledgment methodology in mesh, and messages do get sent more than once. But there’s no forced sequencing.

It should be enough for this thread to say that strengthening the mesh is always a good idea, but some zigbee devices are better at failed message management than others, and this particular one doesn’t seem to be very good at it. But then, this is also a very inexpensive device, so that’s not that surprising.

If you want to discuss specific protocols further, the following is a good thread:

@JDRoberts

Is there anyway to confirm which devices “go to sleep” and then require more than 1 button press to get the device to send a button press event to the hub?

According to at least one other thread on this forum, sleep period cycle was defined in seconds, not days and weeks.

For those devices that are confirmed “sleepy” and that require 2 button presses, do we know of the sleepy period?

One definition for behavior for sleepy devices listed on this forrum, which seem to make sense to me, is that when asleep these devices are NOT listening for incoming commands, and therefore when asleep will miss configurations sent from the hub.

This behavior makes sense to me in terms of saving power, because actively listening for incoming wireless commands takes energy and getting commands from the hub might be VERY rare.

However, if the device is NOT listening for button presses then it will miss button presses. Either it listens for button presses or it does not.

If one button press turns on button, the button could then send the message at that time without another button press. There is no battery savings with not sending the command on the first button press, this is in contrast to turning off active listening for some amount of the time to conserve power.

The ZigBee mesh issue may be relevant; the Iris Smart Button is the only ZigBee device on the network. The problem is occurring, though, when the button is only about 15 feet from the hub (although with an intervening wall), and I’ve also had it fail to pick up button presses when I’m standing right next to the hub.

The motion sensor is an interesting idea, though it’s a relatively high-traffic area so I’d be concerned about it turning on just because people are walking past the stairwell.

I’m using a GE 12722 switch, and in a “normal” 3-way configuration I could use the GE 12723 add-on switch (which I’ve done on a number of other circuits. However, I don’t have a traveler running from the switch for this light, nor do I have a convenient power source at the top of the stairway. There is, however, a 2-gang box with only a single switch just a step or two behind you in the view in the picture I posted. I’m thinking I could put another GE 12722 in that box, but with no load connected to it - just power, neutral, and ground - and then set up an automation rule that says “when upstairs switch is turned ON, turn ON downstairs switch”, and likewise for OFF.

. . . although I’m warming up to the motion sensor idea. I might be able to mount it in a location that would minimize “false positives” and only capture movement that’s actually on the stairs. And I could program the bottom switch to automatically turn off after 15-30 seconds. This might be easier than using another actual switch.

I think two ideas are being conflated here. One is sleepy devices and the other is active joins. Sleepy devices can be either Z wave or zigbee. Active joins only applies to zigbee devices.

Sleepy devices

With sleepy devices, it’s not even seconds, it’s usually milliseconds. It’s like sleep for 9 ms, wake up and check to see if anything’s happening, go back to sleep. But most sleepy devices receive very few incoming action messages. You don’t “turn on” a motion sensor. The sensor wakes up, checks the deltas on the environment, and then decides whether or not to report to the hub. But there’s not an incoming message that it would miss. You can turn on a wall switch or a pocket socket with a network command. But you can’t turn on this button.

Active Joins

Active joins are a whole separate issue. Zigbee devices generally check in with the coordinator periodically. For example, the SmartThings arrival sensor checks in every 30 seconds. A sleepy device won’t miss the response to the check in, because it woke up to send the check in.

Active joins benefit greatly from a strong mesh.

A digression: Wifi works completely differently-- but eats batteries

All of this is really different than how Wi-Fi device works, because the Wi-Fi device is in a star topology and it’s continuously connected. But that’s why Wi-Fi devices use 10 or 20 times as much power as mesh devices, And why you aren’t likely to see a battery powered WIFI contact sensor or door lock. The batteries would only last a couple of weeks instead of a year or two.

pressing twice

OK, back to devices that need to be pressed once to wake up.

I started to write a technical answer to this but it got to 8 paragraphs and I realized I still haven’t covered all the possibilities and even I was getting bored! :stuck_out_tongue_winking_eye: So the short answer is, yeah, it happens for some devices in some situations.

So what can you do about it?

  1. New batteries. You’re much more likely to see this behavior when battery strength has fallen below 50%. So keep the batteries fresh.

2. See if signal strength is the issue

next step would definitely be to try to strengthen the mesh and see if that helps. Easiest way to test this is just to move the button into the same room as the hub but about 10 feet away (and at least 10 feet away from the Wi-Fi router), then do a network heal, then see if the button’s behavior is any different in that location. Don’t press it any more often than you would in the original location, we just are testing signal strength here.

If the button has more acceptable behavior when it’s close to the hub (but not too close) then that’s very good. That means you could probably solve the issue just by adding a zigbee repeater near the original location.

( and I know you guys get tired of hearing me say this, but again, anytime you change the physical locations of your devices, including adding new devices, you need to do a network heal so all the neighbor tables are up-to-date. With zigbee, this is easy. Leave all the devices except the hub on power in their desired locations. Take the hub off power (including removing any batteries) and leave it off power for at least 15 minutes. This will cause all the individual devices to go into panic mode because they can’t find the coordinator. Then when you put the hub back on power, everybody will rebuild their individual neighbor tables. It can take a while for this to get done, so you may not see full results until the next day.)

3. Test inactivity

If the button shows the same flaky behavior of requiring two presses sometimes even though it’s within one hop of the hub, then you need to see if activity makes a difference.

Start by pressing the button once and only once a day at about the same time every day. If it requires two button presses, then try pressing it twice a day, once in the morning and once in the evening.

If pressing the button once a day worked fine, try pressing it every other day. If that works fine, go to once a week.

You’re basically just trying to see if a long period of inactivity then requires a second button press when it wakes up. And if so, how long is long.

The unfortunate thing about this is this is usually just part of the device design. If you can find an activity period that works, then you can decide whether or not this particular device is going to fit your use case. If you have a device in the guestroom that needs to be pressed once a week to stay ready, you can make the decision whether you’re going to do that or whether you’re just going to tell guests they need to press it once to wake it up the first time. But there won’t usually be any way that you can change the activity period For a specific device. You just have to decide whether it’s acceptable. (Well, fresh batteries may make a difference, but that’s why we’re doing this test in this order.)

4. Interference

I don’t want to spend too much time on this right now, but if you notice that the button only seems to have problems at a particular time of day rather than after a particular number of hours, it might be interference, in particular Wi-Fi interference.

5. The weird ST issue

Every platform has some weird issues, and here’s one for SmartThings: if you have Zigbee lightbulbs (Cree, GE, Osram, whatever) connected directly to the SmartThings hub (so not through the Hue bridge) smartThings may try to use them as zigbee repeaters and the bulbs sometimes lose some of the messages. This one is really annoying. But if it’s happening, it will probably be affecting multiple zigbee devices, like sensors. But it could affect the iris button as well. Really any battery powered zigbee device. There is at present no solution for this problem except to remove the bulbs from the hub. They’re just flaky repeaters and consequently can cause problems for other devices.

Anyway, I hope at least this answer stays on topic for this thread without going too deep into the technical weeds.

There are a lot of things that can cause an extra button pressed to be required, and you just have to eliminate them one by one. I’ve tried to list them in an order that will give you more diagnostic information as you go.

Also, the optimal location for a zigbee device is 10 to 12 feet from the hub and from the Wi-Fi router. Right next to the hub is not a good place to try and get zigbee signals through. The zigbee antenna in the hub is omnidirectional and spreads as it gets away from the point of origin. So you have a much larger region of signal activity about 10 feet from the hub than you do right on top of the hub.

1 Like

You can rig up shields on a motion sensor to block areas or narrow a beam. (like a piece of pipe in front of the sonsor on ST sensors, flaps, etc.) I’ve done this to only monitor very specific areas. You can also hide them in a fashion so they almost function like switches…

1 Like

Any wall mounting ideas for this button to use as a (wall)switch?

This might actually be close.

1 Like

@Jim_Newman @JDRoberts thanks for the thoughtful writeup

@Jim_Newman If the lights you want to control are under control of a zwave device, I would recommend the linear Aux switch over the GE because a linear aux switch can directly control another zwave device without wires.This eliminates delays of going through the smartthings huib, On and Off control is instant!

I have a linear zwave aux switch controlling a GE zwave light switch in my garage. I got the GE light switch on sale for $10 so I used that instead of buying another linear switch.

But back to the original question, is Jim_Newman’s Iris button working as expected? Or is it defective? Or is it a network issue?

As far as I can tell, my Iris smart button does NOT need a double press in order to send a command.

Prior to adding a zigbee repeater, button presses were intermittent.

In fact, I had different behavior if the garage was empty, or if there was a car parked in the garage.

With a car in the garage, before the repeater, the button acted intermittently, remove the car from the garage and the button worked better.