Iris Motion Sensor Won't Join

I have a 2nd gen Iris motion sensor I’m trying to add to my hub (CentraLite 3326-L) that I just can’t get to join. Each time, it looks like the sensor joins (it goes from blue blinking LED to three quick green flashes and then stops blinking), but on the SmartThings side I’ve still got nothing.

Twice, it has created a “thing”, but even after manually changing the device type in the IDE, it never updates after the initial join. In the events log for the hub, I can see the zbjoin event that occurs right around the same time as the three green flashes. Most of the time after the zbjoin event, if I go to my devices and look for the device network ID that was reported int he zbjoin event, nothing is there.

I’ve tried reseting the sensor by removing and reinserting the battery with the button held down, and I’ve replaced the battery on the sensor just in case. Neither made a difference.

Does anyone have any tips or troubleshooting ideas I can try?


I had something very similar occur with a completely different Zigbee device that was working and I inadvertently removed it from the IDE. I would get visual confirmation it would reset and pair every time, but no device was ever added. I saw the zbjoin event as you did and I even tried manually creating the device and entering the Device Network ID and Zigbee ID from that event along with the appropriate device handler. I stumbled upon the following post and ended up modifying the device handler and adding

device.endpointId = 1

just before every Zigbee method called within the code. That fixed it for me.

My Iris Motion Sensors are using the SmartSense Motion device handler. You could try adding it and doing what I did.

Thanks. That was a good tip. It didn’t solve my problem, but it set me on right track. Somewhere else, I saw a post about having duplicate DTHs published to the same location. (Maybe it was @jkp who posted that, can’t remember now.)

Anyway, @mitchp’s Iris Motion Sensor DTH was published from back before official SmartThings integration of Iris devices. I deleted that from my account, and the Iris motion sensor joined up just fine.


Maybe I was just coincidentally lucky. It looks like the advice @jkp was giving was to re-publish custom device types.

Whatever the case, it’s working fine now.

1 Like