SmartThings Community

IRIS Keypad Battery Change Question

#43

So the batteries must be old/bad/whatever… the duracell is nominal 3v but should come around 3v2 or 3v3. Same as the energizer. In fact you made me think im going nuts, so i went and measured all different types of batteries i have that say 123 on them. (Not inclusive of rechargeable ones). One thing is apparent. All voltages are the same accross new batteries i measured (well some SLIGHT…and i mean SLIGHT variation, nothing to concern with).

Then i even went and checked data sheets and manufacturer info and the voltages i was reading were in line with literature.

(Joel W) #44

All the batteries were new, and the date was showing not even a year old. So I don’t know what to say. But I did notice the percentage went up when I removed and replaced the 123A batteries.

(Arn B) #45

The batteries on my Xfinity keypad gave out while reporting 100%. When the device went offline the keypad was blinking, would not communicate, nor accept a pin.

Got some brand x, “Surefire” 123A lithiums at Lowes and it’s back, but did have to hold down the 2 key to get the volume level back up to where it was previously set.

The original CR123A batteries lasted about 9 months under heavy use from all the SHM Delay app testing.

(Arn B) #46

Anyone know how to get the battery icon to light the Centralite or Iris Keypad?

Sigh, the new batteries suddenly died without warning last night after about a week, with the device showing 100% charge in the Phone app and ActionTiles. It appears the failure was caused by the transmit icon never shutting off. it also may have been transmitting 100% of the time for all I know.

Anyhow I purchased two new Energizer Cr-123A, then followed the factory reset instructions at http://www.centralite.com/downloads/DataSheet-3SeriesSecurityKeypad.pdf. Thought I would have to re-join the device with ST, but it connected, worked fine, and the transmit light shut off with the keyboard. Hopefully the batteries will last for a while, they now show 99%.

(Joel W) #47

That is something I have asked about before. How did you get the volume to raise? I have the IRIS as you know. I thought I read somewhere someon got the battery light to turn on, But don’t remember where .

(Arn B) #48

Press and hold the 2 key. My device does not get very loud
hold 5 key lower the volume.
8 key in theory is sound on/off

(Joel W) #49

Thank you will try, is there feedback when pressing the 2 key?

(Arn B) #50

Simply hold the 2 key down. It beeps in increments until it reaches the maximum, then continues beeping at the maximum

(Joel W) #51

The difference between low and high is hard to hear.

#52

Yeah, I found my way here with forum search looking for help pairing my Iris Keypad. I bought one brand new and for the life of me I can’t get it to pair. Iris doesn’t seem to have official instructions - the best I can find is another thread in this forum that I’ve already (also) posted to… no luck. Can anyone point me at a more descriptive and/or official document for how to pair the keypad?

When I add a single (verified good) battery the IRIS, WIRELESS, and OFF light up for a second or two, then the WIRELESS flashes two or three times, goes off, then both IRIS and OFF also turn off… then nothing. The batteries clearly work because button pushes get beeps and lights, but as far as pairing is concerned I can’t make any progress. I’m extremely frustrated!

(Arn B) #53

Take a look at Section 14 of the SHM Delay documentation

#54

Sorry to be so daft, but, um, what am I looking for? Section 14 doesn’t have anything about pairing (it seems to focus entirely on the post-pairing DTH side of things).

(Arn B) #55

First link in Section 14 points to this post, lots of good information at the end of the post.

#56

My understanding is that pairing is “remove both batteries, wait 30 seconds, hold the tamper switch activated on the back, install one batter, count to two, release tamper switch, activate discovery mode on the hub.” I’ve done this dozens of times to no avail. My hub clearly starts to blink, so that part is “acting as expected.” Using a computer to watch my IDE logs, I can see “discover” mode active, but I never see any new devices show up.

I just called Iris over the phone. They confirmed my reset process is correct. From what I cant tell the only success to prove you got into pairing mode is the IRIS logo and wireless lights flash for a second or so, but then all lights go dark (whereas during a normal power-on zero lights activate in any way).

What else can I do here?

Asking some more specific questions:

  1. Should I expect the keypad to show up during the normal “Add a Thing” workflow? If so, presumably it shows up as some sort of default or unknown device, right? (I have not installed the DTH yet; I expect I pair it first and the device is an “unknown” type until I install and connect the DTH)
  2. If I am supposed to “Add Device Manually,” then what do I choose?
  3. Are the streaming debug logs useful during pairing?
(Arn B) #57

Install the dth first

#58

Done! Unfortunately that didn’t help (I have the same inability to pair the Iris keypad).

(Arn B) #59

Iris Keypad PDF link http://pdf.lowes.com/useandcareguides/812489023049_use.pdf

  1. Try a factory reset as shown in the “TroubleShooting” (scroll down)
  2. Then try the “geting started” section (scroll up). Where it says “Devices” in the app", put ST into pairing mode. If nothing happens try manually selecting the keypad in ST paring

I recently installed a new IrIs keypad and pairing was a bit dicey, but then it just showed up in the IDE.

#60

I’ve tried dozens of time across many days with different parameters - nothing is working. Any other ideas? The fundamental problem, in my opinion, is this crappy keypad - there’s no real way to tell what’s going on.

#61

I got it!! The trick for me seemed to be two separate reboots of the keypad, which I stumbled into accidentally.

  1. remove both batteries
  2. depress “tamper” switch on the back (hold down)
  3. insert a single battery, watch the light go on, count approximately 2 seconds
  4. release tamper switch
  5. pause about 10 seconds to ensure the keypad is fully booted and has processed the previous steps (which are a “reset” command)
  6. remove battery
  7. insert a single battery, thus rebooting the device normally one extra time after having previously performed the reset

This caused my Iris to get recognize almost instantly by my hub, which I already had in Add a Thing mode.

#62

:sigh: I had to re-pair my keypad and couldn’t remember how, Googled it, and ended up back at my own post (haha)! I had a really hard time re-pairing and I suspect there’s another twist not represented in my previous post: I think my hub has a caching or delay problem. I recently picked up a Sonos device that was powered on my LAN but not connected to ST. While trying to pair my Iris I kept getting the Sonos to show up (but not the Iris), so I decided to unplug the Ethernet to the Sonos and then power it off (by unplugging from the wall)… oddly the device still shows up in pairing like 2 hours later… clearly the hub isn’t seeing recent pair request and/or it is caching old ones. I’m not sure what to make of this, but it’s enough for me to post here.